BLF Not Showing Correct Status When Using DNS-SRV
Last modified date: 2015/04/20 views: 1199
Description

Yealink phone supports two kind of server redundency-failover and fallback. Please find related explaination about this on Page 359 of Administrator Guide below:

Yealink_SIP-T4X_IP_Phones_Administrator_Guide_V73_40.pdf 

If the primary server fails, the phone will register to the backup server, and also subscribe for the BLF keys on the backup server as well.  When the primary server comes back online, the phone will register back to the primary server, but the BLF subscriptions remain on the backup server until reboot. 


Cause

When Primary comes back, phone will re-register to Primary after one expire. But phone will still subscribe BLF status to Secondary. Because the server address refers to the IP address provided in Contact header of the 200 OK message (like “Contact: <sip:200@110.110.110.110:5060>; expires=300). In this case, phone registers and subscribes to different serves and that cause the BLF not sychronized issue. ” 

图片9.png

This is the redundancy machenism applied on all Yealink phones and it is part of RFC. 

图片10.png

Resolution

To solve this issue, we suggest you to use Fallback-Successive mode. 

account.X.fallback.redundancy_type=1  ##1=sucessive mode, 0=concurrent mode(default value)## 

account.X.fallback.timeout=    ##Time interval for phone to detect wehther the working server is available or not## 

account.X.sip_server.1.address= Yealink-2.Yealink.com   ##domain name in SRV record## 

account.X.sip_server.2.address = Yealink-3.Yealink.com 


More Information

If you need further information or support, please feel free to contact Yealink FAE for further support by Support@yealink.com .


Product Type
SIP-T48G , SIP-T46G , SIP-T42G , SIP-T41P , SIP-T38G , SIP-T32G , SIP-T29G , SIP-T28P , SIP-T26P , SIP-T27P , SIP-T23G , SIP-T23P , SIP-T21P , SIP-T20P , SIP-T19P , SIP-T22P , W52P , VP530
Version
V70 or higher
200/200
Please login to post your comment