Two methods for BLF Pickup
Last modified date: 2019/06/16 views: 11144
Description

Introduce the 2 methods to achieve BLF Pickup function.


Cause

Let our customer be clearer about BLF Pickup function.


Resolution

Method 1: Use Feature code to pick up calls.

Go to DSS key interface through web interface.
1.png

To configure pickup code only for one account.

There are 2 ways to meet this function.

a. Then go to Account->Advanced->Directed Call Pickup Code->Enter the pickup code here.

2.png

b.  Direct enter the pickup code at the Extension item.
4.png

To configure the pickup code for all accounts.

Go to Features->Call Pickup->Enabled this function and enter the pickup code.

Here pay attention that this ‘*20*’ code will be applied to all accounts.
5.png

In summary, when using this method to meet BLF call pickup function, then phone will dial ‘*20*2111’ this format to pick up calls. Just like pickup code+ Extension number.

 

Method 2: Use Dialog-info to pick up calls.

This method can only be applied in some account only.

Go to Account->Advanced->Dialog Info Call Pickup->Enabled

6.png

In summary, when using this method to meet BLF call pickup function, then phone will only dial the number to pick up the call. And phone will pick up the call by handling the ‘Replaces’ info. in the INVITE message.

 

Let’s make an example here.

-          3005 makes a call to 2111;

-          There is BLF visual LED indicating on the DSS key;

-          3004 enter the DSS key to pick up the call.

I have also attached the pic about the process.

7.png

The following are the detailed info. to see the Replace segment info.

INVITE sip:3005@10.2.5.140:5060 SIP/2.0

Via: SIP/2.0/UDP 10.2.10.12:5060;branch=z9hG4bK2960309036

From: "3004" <sip:3004@10.2.5.140:5060>;tag=569954982

To: <sip:3005@10.2.5.140:5060>

Call-ID: 0_3558384849@10.2.10.12

CSeq: 2 INVITE

Contact: <sip:3004@10.2.10.12:5060>

Proxy-Authorization: Digest username="3004", realm="3CXPhoneSystem", nonce="414d535c0ae6154d54:6c15b707c9af77afeabbf04011ee8b31", uri="sip:3005@10.2.5.140:5060", response="fa79ff33e26525100ad88ac7f60cafdc", algorithm=MD5

Content-Type: application/sdp

Allow: INVITE, INFO, PRACK, ACK, BYE, CANCEL, OPTIONS, NOTIFY, REGISTER, SUBSCRIBE, REFER, PUBLISH, UPDATE, MESSAGE

Max-Forwards: 70

User-Agent: Yealink SIP-T27G 45.80.0.20

Allow-Events: talk,hold,conference,refer,check-sync

Replaces: MzZlNTA3OTliYjI3ZGI1NzAzODRhZmM4MTFjMTVkMmI.;to-tag=806700092;from-tag=6242c57a

Content-Length:   302

 

For more details, you can also refer to the trace packet here:

blf-dialog_info-pickup.pcapng


More Information

If there are any other questions, please feel free to contact with ticket.yealink.com .


Product Type
VP59 , SIP-T58V , SIP-T58A , SIP-T56A , T57W , T54W , T53W , T53 , SIP-T54S , SIP-T52S , SIP VP-T49G , T4S , SIP-T48G , SIP-T46G , SIP-T42G , SIP-T41P , SIP-T40G , SIP-T40P , SIP-T29G , SIP-T27G , SIP-T23G , SIP-T23P , SIP-T21(P) E2 , VP530 , SIP-T38G , SIP-T32G , SIP-T28P , SIP-T26P , SIP-T22P , SIP-T21P , SIP-T27P
Version
V70 or higher
200/200
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