Explanation of Jitter Buffer
Last modified date: 2017/08/01 views: 121
Description
       

Yealink phones support 2 types of Jitter Buffer, fixed and adaptive, and users may wonder that the Jitter Buffer is and which type they should use.

 

Cause
       

Yealink provides an option of Jitter Buffer settings, either to be adaptive or fixed, and users may not understand which one to choose in their environments.

 

Resolution
       

Jitter buffer is a shared data area where voice packets can be collected, stored, and sent to the
voice processor in even intervals. Jitter is a term indicating variations in packet arrival time,
which can occur because of network congestion, timing drift or route changes. The jitter buffer,
located at the receiving end of the voice connection, intentionally delays the arriving packets so
that the end user experiences a clear connection with very little sound distortion.

 

IP phones support two types of jitter buffers: fixed and adaptive.

A fixed jitter buffer adds the fixed delay to voice packets. You can configure the delay time for the static jitter buffer on IP phones.

An adaptive jitter buffer is capable of adapting the changes accordingly base on the network's delay. The range of the delay time for the dynamic jitter buffer added to packets can be also configured on IP phones. 

 

Maximum Delay and Minimum Delay

The 2 parameters are used to limit the range of delay. When receiving a rtp packet, it will be defined as an underflow event if the packet delay is smaller than minimum, and vice versa an overflow event if it is greater than maximum.

Either overflow or underflow will case RTP packet loss, and lead to audio loss.

The Max delay and Min delay are used only when the Jitter Buffer is configured to be “fixed”.

If the Jitter Buffer is configured as adaptive, it will adjust itself accordingly base on the network latency. Usually it is recommended to use adaptive Jitter Buffer.

 

More Information
       

Auto Provision parameters:

For wired network, can be configured via web user interface or auto provision

voice.jib.adaptive =  

(Default 1)

  ##This decides the Jitter Buffer to be adaptive or fixed, 1 means adaptive, 0 means fixed##

voice.jib.min=

(Default 60)

  ##minimum delay time in milliseconds##

voice.jib.max=

 (Default 240)

  ##Maximum delay time in milliseconds##

voice.jib.normal=

(Default 120)

  ##Normal delay time in milliseconds##

For wireless network, can only be configure via auto provision

voice.wifi_jib.adaptive =

(Default 1)

##This decides the Jitter Buffer for wireless network to be adaptive or fixed, 1 means adaptive, 0 means fixed##

voice.wifi_jib.min =

(Default 60)

##minimum delay time in milliseconds##

voice.wifi_jib.max =

(Default 500)

##Maximum delay time in milliseconds##

voice.wifi_jib.normal =

(Default 240)

##Normal delay time in milliseconds##

 

Product Type
Yealink VC Cloud Management Service , VC Desktop Software , VC Mobile for Android , VC400 , VC120 , VC110 , T49G , CP960 , CP860 , SIP-T58V , SIP-T58A , SIP-T56A , SIP-T54S , SIP-T52S , SIP VP-T49G , SIP-T48S , SIP-T48G , SIP-T46S , SIP-T46G , SIP-T42S , SIP-T42G , T4S , SIP-T41S , SIP-T41P , SIP-T40G , SIP-T40P , SIP-T29G , SIP-T27G , SIP-T27P , SIP-T23G , SIP-T23P , SIP-T21P E2 , SIP-T19P E2 , SFB-T46G , SFB-T42G , SFB-T41P , SFB-T48G , SFB-T40P , T48G Skype for Business , T46G Skype for Business , T42G Skype for Business , T41P Skype for Business , T40P Skype for Business , W52P , W56P , VP530 , SIP-T38G , SIP-T32G , SIP-T28P , SIP-T26P , SIP-T22P , SIP-T21P , SIP-T20P , SIP-T19P
Version
All
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