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LDAP Directory on Yealink IP Phones

Introduction

LDAP stands for Lightweight Directory Access Protoco) which is a client-server protocol for
accessing a directory service LDAP is a directory service protocol that runs over TCP/IP. The
nitty -gritty details of LDAP are defined in RFC 1777 "Lightweight Directory Access Protocol:

The following gives an overview of LDAP from a user's perspective.
What kind of information can be  stored in the directory?

The LDAP information model is based on entries. An entry is a collection of attributes that has a

globally-unique Distinguished Name (DN). The DN is used to refer to the entry unambiguously.

Each of the entry's attributes has a type and one or more values. The types are typically

mnemonic strings, like "cn" for the common name, or "mail" for the email address. The syntax of

values depends on the attribute type. For example, a
J e n s e n DattribAte might contain the value "babs@example.com”.

How is the information arranged?

In LDAP, directory entries are arranged in a hierarchical treelike structure. Traditionally, this
structure reflected the geographic and/or organizational boundaries . Entries representing
countries appear at the top of the tree. Below them are entries representing states and national
organizations. Below them might be entries representing organizational units, people, printers,
documents, or just about anything else you can think of. The following shows an example of an

LDAP directory tree using traditional naming.

c=Us
st=California
The Organisation o=Acme

Organisation Unit

ou=Sales ou=Marketing

cn=Barbara Jenson

LDAPenables you to locate organizations, individuals, and other resources such as files and
devices in a network, whether on the Internet or a corporate intranet, and whether or not you

know the domain name, IP address, or geographic whereabouts. An LDAP directory can be
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distributed among many servers on a network, then replicated and synchronized regularly. LDAP
is particularly useful for storing informat ion that you wish to read from many locations, but
update infrequently.

This guide provides configurations on the LDAP server and IP phones, and applies to the
following Yealink IP phones:

CP860 IP phones running firmware version 71 or later

SIRT48G,SIRT46G, SIPT42G and SIPT41P IP phones running firmware version 73 or later

SIRT58A, SIP VRT49G,SIRT40P,SIRT29G,SIRT23P/G SIRT21(P) E2 CP960and W56P IP

phones running firmware version 80 or later

SIP-T48S, SIPT46S, SIRT42S, SIPT41S, SIRT40G,SIRT27G SIRT19(P) E2CP920, W6®
and W52P IP phones running firmware version 81 or later

VP59,W53P and CP930W-BaselP phones running firmware version 83 or later

SIRT57W, SIRT54W, SIRT53W, SIRT53, SIPT48U, SIPT46U and SIPT43U IP phones

running firmware version 84 or later
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Installing and Configuring the LDAP Server

An LDAP server is essentially a bit like arBQL serverwhich is mainly used for storing/retrieving
information about people (such as contacts). The configuration settings on the phone will be

altered depending on how the LDAP server is configured.

Before using the LDAPfeature on IP phones,you must make sure the LDAP server is prepared
properly, otherwise, you need to install and configure an LDAP server.This chapter showsyou
how to install and configure an LDAP server. We recommend you to use the OpenLDAR
Microsoft Active Directory, Microsoft Active Directory Application Mode (ADAM) or Sun One
Directory Serveron Windows system.

OpenLDAP

Installing the OpenLDAP Server

This section shows you how to install an OpenLDAP servepn Microsoft Windows 2007 system.
The OpenLDAP server software is available for free. You can download it from

http://www.userbooster.de/en/download/openldap -for-windows.aspx?l=en
To install the OpenLDAP server:

1. Double click the OpenLDAPapplication to start the installation. You will be prompted for
the installation.

OpenLDAP Installation

Wizard will install the OpenlDAP software on your computer.

2. Click Yesto continue the installation.

3. Follow the default settings and click Next until the Destination Folder screen appears


http://www.userbooster.de/en/download/openldap-for-windows.aspx?l=en
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4. Click Change to locate the installation path from the local computer system and then click
Next .

You need to remember the installation path (e.g., D\OpenLDAP) located here.

The screenshot for reference is shown as below:

OpenLDAP
Installation

Instsll OpenlDAP for

R

5. Follow the default settings and click Next until the Ready to install OpenLDAP for

Windows screen appears

OpenLDAP Installation

Ready to install OpenLDAP for Windows

n. Click Back to installation s Click Close to exit

s Foad Map

6. ClickInstall to start the installation.
7. Click Close to exit the Setup Wizard.

For more information on how to install the OpenLDAP server for windows, refer to the website
online:

http://lwww.userbooster.de/en/support/feature -articles/openldap-for-windows-installation.aspx


http://www.userbooster.de/en/support/feature-articles/openldap-for-windows-installation.aspx
http://www.userbooster.de/en/support/feature-articles/openldap-for-windows-installation.aspx
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Configuring the OpenLDAP Server

Editing the slapd.con f File

Access the OpenLDAP installation path Edit the manager information for LDAP.

1.

Open and edit the slapd.conf file using your favorite text editor .
Find the commands
Suffix "dc= maxcrc, dc=com"
Rootdn "cn= Manager,dc= maxcrc,dc=com"
Suffix defines the components of the domain name.
Rootdn defines the manager as a management user foraccessng the LDAP server.
For example
Suffix "dc=yealink,dc=c om"
Rootdn  “"cn= Manager,dc=yealink,dc= com "

The suffix line means that the domain name of the LDAPdirectory is yealink.com. The

Rootdn line defines a management user named as Manager.

If the domain name contains additional components, for example, yealink.com.cn, thesuffix

line will be edited as below:
Suffix  "dc=yealink,dc=com,dc=cn"
Rootdn  “"cn= Manager,dc= yealink,dc=com,dc=cn"

Double click slappasswd.exe to modify the user password for the management user.Type

the new password twice.

# | D:\OpenLDAP\slappasswd.exe [rae]-E@]| 52

New password: secret
Re—enter new password: secret_

m| »

Starting the Slapd Serv ice

To start the slapd service:

1.
2.
3.

Click Start->Run.
Entercmd in the pop -up dialogue box and click OK to enter the command line interface.

Access theserver installation path. For example,execute the following commands to access
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the server installation path at D:\ OpenLDAP.

IC:\Users\ylB215>d:

iD:\>cd OpenLDAP

[D: \OpenLDAP>_

4. Executethe command slapd.exe -d 1 -f ./slapd.conf to start the slapd service.

IC:\Users\ylB215>d:
(D:\>cd OpenLDAP

D:\OpenLDAP>slapd.exe —d 1 —f ./slapd.conf

If the serviceruns successfully, you can find thep r o mglapd starting DZ

The screenshotfor reference is shown as below:

M C:\Windows\system32\CMD.exe - slapd.exe -d 1 -f ./slapd.conf

config_build_entry: “cn=schema"
B>core

<en={2>nis>
en={2>nis>
Yen={2>nis"
3>inetorgperson>
>

config_build_en

config_bhuild_entr

config_build_entry

config_bhuild_entry: '

backend_startup_one: starting “dc=yealink.dc=com"

bdb_db_open: warning — no DB_CONFIG file found in directory ./data: (2>

w

ﬁxpect poor performance for suffix “dc=yealink.d n
bdb_db_open: database “dc=yealink.dc=co dbenv_open{./datad.
bdb_monitor_db_open: monitoring disabled; configure monitor database to

slapd starting

Please do not close this window to make sure the LDAP server keep running.

Adding the Initial Entry to the LDAP  Directory

You can add the initial entry to the LDAP directory by using the LDIFfile. Create a new text
document, then modify the filename extension as Idif and place the document to the OpenLDAP
installation path. For example, create a textdocument named as test.txt, right-click the test.txt
document and then select to rename it, modify the filename extension as Idif. Open the LDIFfile
with your favorite text editor and input the corresponding content. The following shows an

example of the content of the LDIF file:

dn: dc=yealink,dc=com
objectClass: top
objectClass: dcObject
objectClass: domain

dc: yealink
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dn: ou=roles,dc=yealink,dc=com
objectClass: top
objectClass: organizationalUnit

ou: roles

dn: ou=people,dc=yealink,dc=com
objectClass: top
objectClass: organizationalUnit

ou: people

dn: cn=Test Users,ou=roles,dc=yealink,dc=com
objectClass: groupOfUniqueNames
cn: Test Users

uniqueMember:

uid=sspecial,ou=people,dc=yealink,dc=com

uniqueMember:

uid=jbloggs,ou=people,dc=yealink,dc=com

dn: cn=Special Users,ou=roles,dc=yealink,dc=com
objectClass: groupOfUniqueNames
cn: Special Users

uniqgueMember:
uid=sspecial,ou=people,dc=yealink,dc=com

dn: cn=Admin Users,ou=roles,dc=yealink,dc=com
objectClass: groupOfUniqueNames
cn: Admin Users

uniqgueMember:

uid=admin ,ou=people,dc=yealink,dc=com

dn: uid=admin,ou=people,dc=yealink,dc=com
objectClass: person

objectClass: inetOrgPerson

cn: State App

displayName: App Admin

givenName: App

mail: admin@fake.org
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sn: Admin
uid: admin

userPassword: adminpassword

dn: uid=jbloggs,ou=people,dc=yealink,dc=com
objectClass: person

objectClass: inetOrgPerson

cn: Joe Bloggs

displayName: Joe Bloggs

givenName: Joe

mail: jploggs@fake.org

sn: Bloggs

uid: jbloggs

userPassword: password

dn: uid=sspecial,ou=people,dc=yealink,dc=com
objectClass: person

objectClass: inetOrgPerson

cn: Super Special

displayName: Super Special

givenName: Super

mail: sspecial@fake.org

sn: Special

uid: sspecial

userPassword: password</span>

To add the initial entry using the  test.Idif file:

1. Click Start->Run.
2. Executecmd in the pop -up dialogue box and click OK to enter the command line interface.

3. Access the server installation path. For example, execute the following commands to access
the server installation path at D:\ OpenLDAP.
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4. Executethe command slapadd -v - ./test.Idif to add the initial entry .

The screenshot for reference is shown as below:

C:\Windows\system32\cmd.exe = e

ID:\OpenLDAP>slapadd -v -1 ./test.ldif
5498c388 hdb_db_open: warning — no DB_CONFIG file found in directory ./data:

ﬁxpect poor performance for suffix “dc=yealink.,dc=com".
5498c388 bdb_monitor_db_open: monitoring disabled; configure monitor database to

: Ydc=yealink,dc=com" (BBB0BOAA3)>
: “ou=roles.dc=yealink.dc=comn" (BBABBAGB4)>
: You=people.dc=yealink,dc=com" (BBBBBAGBS >
dc=yealink.,.dc=con" (BBB0BBB6 >
=roles.dc=yealink,.dc=comn" (BBABBAABT>
0 dc=yealink,dc=con" <(BABOBABAS>
ople,.dc=yealink.dc=com" (BR0BABB?>
people.dc=yealink,dc=con" (ABBABAAa)>
ded: 901a1 ou=people.dc=yealink.dc=com" (BBBBABBLH>
nunuuuuuuuuuuuuuuuuu 100.08% eta none elapsed none fast?
[Closing DB.

D:\OpenLDAP> _

Configuring the LDAPEXxploreTool2

The LDAPEXxploreTool2 application supports ruming on the Windows system. The application is
a graphical LDAP tool that enables you to browse, modify and manage contact entry on the
LDAP server.

If you have an LDAPEXxploreTool2 application installed on your computer, open it now, otherwise,
download the application from http://Idaptool.sourceforge.net/ . And then complete the

installation following the wizard.

Creating a Configuration

To create a configuration:

1. Double click the LDAPExploreTool2.exe tarun the application.

2. Click File->Configurations .

7| LDAPExplorerTool 2 EI@
Tools

Open last configuration

Configurations...

Quit

3. Click New to create a new configuration.
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4. Enter a name in the Configuration name field under the Configuration tab.

Configuration @

Configuration | Server | Connection | Option | SSL/TLS |

Configuration name LDAP

[8]3 | Cancel l

5. Enter the domain name or IP address of the LDAP server in theServer name or IP field
under the Server tab. Check the checkbox of Use default port for the Server port and

Server SSL port.

Configuration @

Configuration Server | Connection | Option | SSL/TLS |

Server name or IP 10.3.6.128

Server port 380 V¥ Use default port
Server SSL port 636 ¥ Use default port
Version

#3C2

Test connection

[8]3 | Cancel l

6. Enter the user DN and password in the User DN and Password field under the Connection

tab.

The user DN and password correspond with the Rootdn and Rootpw defined in the

slapd.conf file.
For example, according to the manager information defined in the slapd.conf file:
Rootdn "cn= Manager,dc=yealink,dc=c om"

Rootpw secret

10
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Enter cn=Manager,dc=yealink,dc=c om in the User DN field and secret in the Password
field under the Connection tab.

Conﬁgurggon

Configuration | Server Connection | option | SSL/TLS |

User DN ,m I Anonymous login
Password [T v store password
Use SSL port

" Yes & No
tselEs € Yes & No (TLS is only used

on non SSL ports)

Base DN ]dc=yealink,dc=cn Guess value I

ok I Cancel I

7. Click Guess value to fill the Base DN automatically.

8. Click Test connection to test the connection to the LDAP server. If you encounter an error
or warning during the test, you need to resolve the error or warning first according to the
prompt, and then retry to test the connection.

9. Click OK to accept the change.

Adding Entries

To add entries:

1. Click File->Configurations , select the configuration created above, and then click Open.

The screenshot for reference is shown as below:

| LDAPExplorerTool 2 = on |
File Tools

& de=yealink de=com

11
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2. Right-click the root entry, and then select Add to add a new entry.

| LDAPExplorerToal 2
File Teols

[E=E = =8
E-Root-de=yealink dc=com ou=roles,dc=yealink de=com
=

Entry
Add..
Copy tow.
Rename...

feuig
Delete...

Euid Search...

3. Enter the desired values inthe corresponding fields.
Parent DN: It will be automatically generated according to the server configuration .
Entry RDN: The format is cn=XXX.Thisis a unique identifier for each entry.

Object Class (from schema): Select the structure class which the entry belongs to. Each
structure class has its must attributes and may attributes. For example, we selectperson
from the Object class (from schema) drop-down menu.

4. Select the desired attributes for the object class.

Must attributes: Double click attributes to add them to the entry node. All attributes listed

in the Must attributes field must be added and each value of the attribute must be set.

May attributes: Double click the desired attributes to add them to the entr y node. The

attributes listed in the May attributes field are optional.

Common attributes are listed in the following table:

Attribute Name Description
cn commonName Full name of the entry.
) The first name also called
gn givenName o
Christian name.
Surname, last name or family
sn surname

name.

telephoneNumber

telephoneNumber

Office phone number.

homePhone homeTelephoneNumber Home phone number.
mobile mobileTelephoneNumber | Mobile or cellular phone number.
pager pagerTelephoneNumber Pager telephone number.
company company Company name.
o] organizationName Organization name.
ou organizationlUnitName Usual department or any sub

entity of larger entity.

5. Right-click the selected attribute and then select Add value .

12



Installing and Configuring the LDAP Server

The screenshot of adding a new entryis shown as below:

New entry creation ‘i‘
Parent DN 'W,d@yea
Entry RDN [cn=Hebe Tan
Object class (from schema) person v
Object class (manual)
2 cEn=;ebe Tan,ou=roles.de=veainkde=dt - The value of cn here must be the same
<n
Tian 5 H
5 Enteranewvawe | @sthat of cn configured in the Entry
= objectClass .
person He RDN field.
= telephoneNun|
2218 oK Cancel |
MUST attributes MAY attributes

sn userPassword

cn telephoneNumber

objectClass seeAlso
description

Attribute( when schema Add

is unavailable)

Save Cancel

6. Click Save to confirm the configuration.
7. Repeat steps 2 to 6 to add more contact entries.

You can find the added entries at the left of the LDAP catalog.

| LDAPExplorerTool 2 oo ==
File Tools
=) Root-dc=yealink dc=com [2 cn=Hebe Tian,ou=roles,dc=yealink,dc=com|
= ou=roles @ telephoneNumber
cn=Test Users - subschemaSubentry
cn=Special Users & modifyTimestamp
en=Admin Users - structuralObjectClass
cn=Hebe Tian & modifiersName
cn=Ella Zhang B-sn
& ou=people & entryCSN
uid=admin [ creatorsName
uid=jbloggs & objectClass
uid=sspecial & hasSubordinates
en=Jonn Liu &) entryDN
B-cn
@ createTimestamp
[ entryUUID

Microsoft Active Directory

Installing the Microsoft Active Directory Domain Services

This section shows you how to install anactive directory on Microsoft Windows Server 2008 R2

Enterprise 64bit system.
To install the Microsoft Active Directory Domain Services:

1. Click Start->Run.

2. Enterdcpromo in the pop-up dialogue box and click OK.

13
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3. The Active Directory Domain Services Installation Wizardwill appear after a short while,

click Next .

@] Active Directory Domain Services Installation Wizard x|

Welcome to the Active Directory
Domain Services Installation
Wizard

This wizard helps you install Active Directory Domain
Services (AD DS) on this server, making the server an
Active Directory domain controller. To continue, click Mext.

[" Use advanced mode installation

Leam more about the additional options that are
available in advanced mode installation.

More about Active Directory Domain Services

< Back Next = Cancel

4. Read the provided information and click Next.

@/ Active Directory Domain Services Installation Wizard

Operating System Compatibility
Improved securty settings in Windows Server 2008 and Windows Server 2008 R2
affect older versions of Windows

1. Windows Server 2008 and "Windows Server 2008 R2" domain controllers have a
new more secure default for the security setting named "Allow cryptography algorithms
compatible with Windows NT 4.0." This setting prevents Microsoft Windows and
non-Microsoft SMB "clients” from using weaker NT 4.0 style cryptography algorithms
when establishing securty channel sessions against Windows Server 2008 or
"Windows Server 2008 R2" domain controllers. As a result of this new default,
operations or applications that require a security channel serviced by Windows Server
2008 or "Windows Server 2008 R2" domain controllers might fail.

Platforms impacted by this change include Windows NT 4.0, as well a5 non-Microsoft
SMB "clients" and network-attached storage (MAS) devices that do not support
stronger cryptography algorthms. Some operations on clients running versions of
Windows earierthan Windows Vista with Service Pack 1 are also impacted, including
domain join operations peformed by the Active Directory Migration Tool or Windows
Deployment Services.

For more information about this setting, see Knowledge Base aricle 342564
(http://go microsoft . com/fwlink/?Link|ld=104751).

< Back Next = Cancel

14
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5. Mark the Create a new domain in a new forest radio box and click Next .

@! Active Directory Domain Services Installation Wizard

Choose a Deployment Configuration

You can create a domain controller for an existing forest or for a new forest.

" Bxisting forest

| sdda domain contoller to an existing domain

" Create a new domait i &t existing forest
Thiz server will become the first domairn cantrollen in the: new domair:

%' Create a new domain in a new forest

More about possible deployment configurations

< Back Next > Cancel |

6. Enter an appropriate domain name for the forest root domain and click Next .

@! Active Directory Domain Services Installation Wizard

Name the Forest Root Domain
The first domain in the forest is the forest root domain. ks name is also the name of L= =
the forest. i

Type the fully qualified domain name (FQDN) of the new forest root domain.

FQDN of the forest roct domain:
|dap yealink.com

Example: comp .contoso.com

< Back Next = Cancel

15
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The wizard will check if the domain name is in use on the local network.

o Active Directory Domain Servi
Name the Forest Root Domain

The first domain in the forest iz the forest roct domain. ks name is also the name of
the forest.

Type the fully qualfied domain name (FQDN) of the new forest root domain.

FQDM of the forest root domain:
Idap yealink .

Example: comg
Verifying NetBIOS name...

<Back | MNet> | Canced |

7. Select the desired forest functional level from the Forest function al level drop-down menu,

and click Next .

For more information, click domain and forest functional level s.

@! Active Directory Domain Services Installation Wizard

Set Forest Functional Level
Select the forest functional level.

Forest functional level:

Windows Server 2003 j
Details:
e Windows Server 2003 forest functional level provides all features that are -
vailable in Windows 2000 forest functional level, and the following additional
eatures:

- Linked-value replication, which improves the replication of
changes to group memberships.

- Mare efficient generation of complex replication topologies
by the KICC.

- Forest trust, which allows organizations to easily share LI
i You will be able to add only domain controllers that are running
- Windows Server 2003 or later to this forest.
Mare about domain and forest functional levels
< Back Next > Cancel |

8. Select the desireddomain functional level from the Domain function al level drop-down

menu, and click Next .

16
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For more information, click domain and forest functional level s.

@ Active Directory Domain Services Installation Wizard

Set Domain Functional Level
Select the domain functional level.

Domain functional level:

Details:

e features available at the Windows Server 2003 domain functional level include a
Il features available at the Windows Server 2000 domain functional level and the
ollowing additional features:
- Constrained delegation. which an application can use to take
advantage of the secure delegation of user credentials by
means of the Kerberos authentication protocal.
- lastLogon Timestamp updates: The lastLogonTimestamp attribute is
updated with the last logon time of the user or computer, and it is j

i You will be able to add only domain controllers that are running
Windows Server 2003 or later to this domain.

More about domain and forest functional levels

< Back Mext > Cancel

If you select Windows Server 2008 R2 for the forest function al level, you will not be
prompted to selecta domain functional level.

The wizard will check if the DNS is properly configured on the local network.

! Active Directory Domain Servi

Set Domain Functional Level
Select the domain functional level.

Damain functional level:
Windows Server 2002 j

Details:

el include o
Examining DMS corfiguration. .. and the

e is

More about domain and forest functional levels

< Back Next = Cancel

17
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9. Select additional options for this domain controller if required, and ¢ lick Next .

@! Active Directory Domain Services Installation Wizard

Additional Domain Controller Options

Select additional options for this domain controller.
¥ DNS server
¥ Global catalog
I Fead-only domain contoller (BODE]
Addttional information:

The first domain controller in a forest must be a global catalog server and ;I
cannot be an RODC.

We recommend that you install the DNS Server service on the first domain
controller.

Mare about additional domain cortroller options

< Back Next = Cancel

You may get a warning telling you that the server has one or more dynamic IP addresses. We
recommend assigning a static IP address to the server.

10. The wizard will prompt a warning about DNS delegation. Since no DNS has been

configured yet, you can ignore the message and clickYes.

@ Active Directory Domain Services Installation . x|

A delegation for this DMS server cannot be created because the
I 4, authoritative parent zone cannot be found or it does not run
~ Windows DNS server, If you are integrating with an existing DNS
infrastructure, you should manually create a delegation to this
DMS server in the parent zone to ensure reliable name resolution
from outside the domain petrilab.local, Otherwise, no action is
required.

Do you want to continue?

ey | ]

11. Specify the desired paths for the database, log files and SYSVOL foldersand click Next .

18
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For more information, click placing Active Directory Domain Services files

@ Active Directory Domain Services Installation Wizard

Location for Database. Log Fles. and SYSVOL
Specify the folders that will contain the Active Directory domain controller
database, log files, and SYSWVOL.

For better pefarmanice and recoverability, store the database and log files on separate

volumes.
Database folder:

Browse... |
Log files folder:
|C:\Windows\NTDS Browse... |
SYSVOL folder:
IC:\Windows\SYS\u"OL Browse... |

Mare about placing Active Directory Domain Services files

< Back Next > Cancel |

12. Configure the password for the active directory recovery mode, and click Next .

For more information, click Directory Services Restore Mode password

The password should be complex and at least 7 characters long.

@ Active Directory Domain Services Installation Wizard

Directory Services Restore Mode Administrator Password

The Directory Services Restore Mode Administrator account iz different from the domain
Administrator account.

Assign a password forthe Administrator account that will be used when this domain
controller is started in Directory Services Restore Mode. We recommend that you
choose a strong password.

Password: I.o.o.o.o.

Confirm password: quuuo

More about Directory Services Restore Mode password

< Back Mext = Cancel

19
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13. Review your selection and clickNext .

@ Active Directory Domain Services Installation Wizard

Summary

Review your selections:
Canfigure this server as the first Active Directory domain controllerin a new forest.  «

The new domain name is "ldap yealink.com”. This is also the name of the new
forest.

The NetBIOS name of the domain is "LDAP".
Forest Functional Level: Windows Server 2002
Domain Functional Level: Windows Server 2003

\Site: Defautt-First-Site-Name

]

Ta change an option, click Back. To begin the operation, click Mext.

These settings can be exported to an answer file for use with Export settings. . |
other unattended operations.
More about using an answer file

< Back Mext > Cancel

The wizard will prompt that the system beginsto create the Active Directory Domain

Services

Active Directory Domain Services Installation Wizard

The wizard is configuring Active Directory Domain Services. This process can take
from & few minutes to several hours, depending an your environment and the options
that you selected.

Securing Kerberos Policy

Cancel |

[ Reboot on completion

20
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14. Click Finish to complete the installation and exit the wizard.

@ Active Directory Domain Services Installation Wizard x|

Completing the Active Directory
Domain Services Installation
Wizard

Wetive Directory Domain Services is now installed an thisﬂ
computer for the domain "ldap yealink .com”.

This Active Directory domain controller is assigned to the
site "Default-First-Site-Name". You can manage sites
with the Active Directory Sites and Services
dministrative tool.

To close this wizard, click Finish.

< Back I Finish I LCaticel

Installing Active Directory Lightweight Directory Services Role

You should also install the Active Directory Lightweight Directory Services role on the Windows

Server 2008 system.
To install the Active Directory Lightweight Directory Services role:

1. Click Start->Administrative Tools ->Server Manager .
2. Right-click Roles, and then select Add Roles.

3. The Add Roles Wizard willpop up, click Next .

Add Roles Wizard x|

%ﬂa Before You Begin
g This wizard helps you install roles on this server. You determine which roles to install based on the tasks you

Server Roles want this server to perform, such as sharing documents or hosting a Web site.

Confirmation Before you continue, verify that:
Progress

« The Administrator account has a strong password
s « Network settings, such as static IP addresses, are configured
« The latest security updates from Windows Update are installed

If you have to complete any of the preceding steps, cancel the wizard, complete the steps, and then run the
wizard again.

To continue, dick Next.

r Skip this page by default

cprevos [ exts | et Cancel

21



Installing and Configuring the LDAP Server

4. Check the Active Directory Lightweight Directory Services

Add Roles Wizard

ﬁé Select Server Roles

Before You Begin

ADLDS

Select one or more roles to install on this server.
Roles:

e mmares tive Directory Domain Ser talled)
o [] Active Directory Federation Services

rogress Active Directory Lightweight Directory Services
Results [] Active Directory Rights Management Services

checkbox and click Next .

Description:
Active Directory Certificate Services
[AD C5) s used to create certification
authorities and related role services
that allow you toissue and manage
certificates usedin a variety of
applications.

[] Application Server

[] DHCP Server

[] DNS Server

[] Fax Server

[] File Services

[] Hyperv

[] Metwork Policy and Access Services
[] Print and Document Services

[] Remote Desktop Services

[] web Server (115)

[] windows Deployment Services
[] windows Server Update Services

More about server roles

<previous || next> |

Install Cancel

5. Follow the default settings and click Next .

6. When the installation is completed, click Close.

After the installation succeeds, you will find the Active Directory Lightweight Directory

Services role listed in the roles of the server manager.

. Server Manager

=

Fle Acton View Help

Active Directory Domain Services
‘Ef' Active Directory Lightweight Directory Services
il Features
3 Diagnostics
St Configuration
{55 storage

~) Roles Summary

roles and features,

~) Roles: 20f 17installed
/iv Active Directory Domain Services

(i) Active Directory Lightweight Directory
Services

~! Active Directory Domain Services

“! Role Status

Messages: 1
System Services: 9 Running, 1 Stopped

4

e 2]
i Server Manager (1L0215) frotes |
= e

View the health of the roles installed on your server and add or remove

Stores directory data and manages communication between users and domains, indud
logon processes, authentication, and directory searches.

Roles Summary Help

i Add Roles

52 Remove Roles

AD DS Help

Go to Active Directory Dor
Services

_—

£} Last Refresh: Today at 13:00 Configure refresh

Configuring the Microsoft Active Directory Server

Adding an Entry to the Active Directory

You can add entries to the active directory one by one in this way.

To add an entry to the Active Directory

1. Click Start->Administrative Tools ->Server Manager .

2. Double click Roles->Active Directory Domain Services ->Active Directory Users and
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3.

4.

5.

Computers .

Right-click the domain name created above (e.g
New ->Organizational Unit

.,Idap.yealink.com), and then select

Fle Acton View Hep
e 2ml0
T Server Manager (1L0215)
= @ Roles
= T Active Drectory Domain Services
= ] Active Orectory Users and Computers [ y10215.1dac
© 3 Delegate Control
i Active Drec e .
FF Active Drectony
% i Features
* ’Mm
# g Configraton
® [ Storage

)

Change Domain...
Change Domain Controller...

Al Tasks

Refresh
Export List...

|

4 |

E. Server Manager

=101 ]

Enter the desired name of the organizational unit.

New Dbject - Organizational Unit

--;d: Createin:  Idap yealink.com/

MName:

Iyealink|

¥ Protect container from accidertal deletion

o]

Cancel

Help

Click OK to accept the change.
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6. Right-click the organizational unit created above, and then select New->Contact .

E. Server Manager = =10 x|
Fle  Aton  Vew Help
e 2m §0/XRD a5 H-|m
s Server Manager (YL0215)
= B Roles
= ¥ Active Drectory Doman Senvices .
= T} Actve Drectory Users and Computers [ 0215.dec There ace 10 e 20 show ) this view, More Actons ’
= 33 dap.yesink com
# ] Bultn
® 1 Computers
# 2. Domain Controlers

7. Enter the desired values in the corresponding fields.

New Object - Contact |

&) Create in:  |dap yealink com, ealink

First name: Isan Initials: Isz

Last name: Irhang
Full name: Isan sz. zhang
Display name: ||

oK I Cancel

8. Click OK to accept the change.

9. Double click the contact created above.
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10. Configure more properties of the contact.

san sz. zhang Properties e |

General |Flddr&ss| Telephones | Organization | Member Of |

& san sz. zhang

First name: I Initials: Isz

Last name: Iﬂﬂang

Digplay name: I

Description: I

Office: I

Telephone number: I Cther... |

E-mail: I

Web page: I Cther... |

ok | canced | il |

11. Click OK to accept the change.
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Adding Entries to the Active Directory Using the Idifde Tool

You can usean LDIF file to perform a batch import of all entries to the active directory.

To create the LDIF file:

Create a new textdocument and then modify the filename extension as Idif. For example, create

a text document named astest.txt, right-click the test.txt document and then select to rename it,

modify the filename extension as Idif. Open the LDIFfile with your favorite text editor and input

the corresponding content. The following shows an example of the content of the LDIF file:

##Create a new organizational unit##

dn: OU=yealink,DC=Idap,DC=yealink,DC=com
changetype: add

objectClass: top

objectClass: organizationalUnit

ou: yealink

name: yealink

#create a new contact##

changetype: add
object Class: top
objectClass: person
objectClass: organizationalPerson
objectClass: contact
cn: san zhang

sn: zhang
givenName: san
initials: zs

name: san zhang
ipPhone: 2336
mobile: 15557107369

dn: CN=san zhang,0U=yealink,DC=ldap,DC=yealink,DC=com

To import the test.Idif file:

1. Click Start->Run.

2. Entercmd in the pop-up dialogue box and click OK to enter the command line interface.
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3. Executethe command cd to accessthe path of the test.Idif file. For example, execute cd

c\Windows to accessthe path of the test.ldif file at c:\\Windows .

[z+] Administrator: G:\Windows\system32\cmd.exe
Microsoft Windows [Version 6.1.76881]
Copyright <c> 288? Microsoft Corporation. All rights reserved.

C:UsersMidninistrator?ed c:“Windows

c:Windows>

4. Executethe command Idifde -i -f test.ldif to import the file.

If the entriesareaddeds uccessfully, younentiesmbdifiedd t he prompt |

successfully DZn" indicates the number of the added entries ).

The screenshot for reference is shown as below:

[5] Administrator: G\Windows\system32\cmd.exe

Microsoft Windows [Version 6.1.76881
Copyright <c> 28A? Microsoft Corporation. All rights reserved.

C:\lsers“Administrator>cd c:“Windows

c:“\MWindows>1difde -i -f test.ldif
Connecting to “ylB215.1dap.yealink.com"

Logging in as current user using S8PI
Importing directory from file "test.ldif™
Loading entries...

2 entries modified successfully.

The command has completed successfully

c:Windows>

You can also export the existing entries on the active directory into a *.Idif file first, modify the
file, and then import the modified file into the active directory. For more information, refer to
the network resource.

Adding Entries to the Activ e Directory Using the Csvde Tool

You can also usea CSV file to perform a batch import of all entries to the active directory. Create

a new document using a spreadsheet application (e.g., Microsoft Excelland then savethe

document to your local computer usi ng ] Sav e as DZ.iForexarhpke, cfeateramat | *. ¢ s v Dz
document named astestxls, click] Save asDZto save t.OpentheoCGSUfleent as t es't
with the spreadsheet application and input the corresponding content. The following shows an

example of the CSV filecontent:

A B c D E F G H I J
initial
s

DN objectClass ou name cn sn givenName ipPhone mobile

OU=yealink, DC=1dap, organizationallni
; DC=yealink, DC=com t

CN=san

zhang, 0U=yeal ink, DC

=ldap, DC=yealink, DC
3 =com
CN=si
1i, 0U=yealink, DC=1d contact si1i si 1i 1i si sl 2222 123456789002
ap, DC=yealink, D(=co
CN=wu
wang, 0U=yealink, DC=
1dap, DC=yealink, DC=
5 _com

yvealink yealink

contact san zhang san zhang san zhang SZ 1111 123456789001

contact wu wang Wu wang wang wu L 3333 123456789003
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The first line lists the attributes of the entries.

The second line lists the values of anorganizational unit in the corresponding attribute columns.

The other lines list the values of contacts in the corresponding attribute columns.

To import the test.csv file:

Click Start->Run.

Entercmd in the pop -up dialogue box and click OK to enter the command line interface.

Executethe command cd to accessthe path of the test.csvfile. For example,execute cd

c:\Windows to accessthe path of the test.csv fileat c:\ Windows .

[ Administrator: G:\Windows\system32\cmd.exe

Microsoft Windows [Version 6.1.76881]
Copyright <{c> 208? Microsoft Corporation.

All rights reserved.
C:Users™Admninistratoricd c:Windows

c:MWindows>

Executethe command csvde -i -f test.csvto import the file.

I f the added
successfully DZn'(indicates the number of the added entries).

entries are

The screenshot for reference is shown as below:

s u cneeptries rhodified y

you

[z Administrator: C:\Windows\system32\cmd.exe

Mic ft Windows [Nersion 6.1.76801]
Copyright {c> 208? Microsoft Corporation.

C:\lUsers“Administrator>cd c:sWindows

c:“\Windows>csvde —i —f test.csv
Connecting to "Cnull>"

Logging in as current user using SSPI
Importing directory from file "test.csu"
Loading entrie

4 entries modified successfully.

The command has completed successfully

c:sWindows >

All rights reserved.

The csvde tool cannot edit or delete the existing entries on the active directory.

You can also export the existing entries on the active directory into a *.csv file first, modify the
file, and then import the modified file into the active directory. For more information, refer to

the network resource.

Creating User Account s

You can create user accounts to allow access to resources on thective directory. User accounts

are very important and useful.

To create a user account :

1.
2.

Click Start->Administrative Tools ->Server Manager .

Double click Server Manager ->Roles->Active Directory Domain Services ->Active

28



Installing and Configuring the LDAP Server

Directory Users and Computers .
3. Select the domain name created above (e.g.,|dap.yealink.com).

4. Right-click Users, and then select New->User.

5. Enter desired values in the corresponding fields and clickNext .

6. Enter the passwordfor the user, select the appropriate options and click Next .
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