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About This Guide

About This Guide

BroadSoft UC-One is a complete Unified Communications solution, providing a
comprehensive suite of services meeting both business and consumer requirements.
The UC-One solution effectively leverages multiple BroadSoft products: BroadWorks,
BroadTouch and BroadCloud, to provide the full UC-One User Experience.

This guide describes the BroadWorks device management interface and introduces
how to deploy Yealink W52P IP DECT phones for the administrator using the BroadWorks
device management interface. In addition, the guide provides the detailed instructions
for BroadSoft integrated features. The BroadCloud features are not available on Yealink
WS52P IP DECT phones. The BroadSoft BroadWorks features are available on Yealink
WS52P [P DECT phones running UC-One firmware version 50 or later. These features

require support from the BroadSoft BroadWorks platform.

Who should use this guide?

This deployment guide is intended for system and network administrators familiar with
configuring and deploying Yealink W52P IP DECT phones and with the components of

the BroadSoft environment.

Before reading this guide, you should be familiar with the following:

e  Previous knowledge of and experience with BroadSoft UC-One components
e  Access to BroadSoft UC-One product documentations and relevant firmware
e  Previous knowledge of and experience with Yealink IP phones

e  Access to Yealink IP phones documentations and relevant firmware

In This Guide

This deployment guide includes the following chapters:
e  Chapter 1, “BroadWorks Device Management” describes BroadWorks device
management.

e  Chapter 2, “Configuring Device Management on BroadWorks” describes how to

configure device management on BroadWorks.

e  Chapter 3, “Configuring BroadSoft UC-One Integrated Features” describes how to

configure BroadSoft integrated features on the BroadSoft server and IP phones.

e  Chapter 4, “Upgrading Firmware” describes how to upgrade the firmware of IP

phones.
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e  Chapter 5, “Downloading and Verifying Configurations” describes how to

download configuration files and verify configurations.

e  Chapter 6, “Troubleshooting” describes how to troubleshoot the phone problem.

Summary of Changes

This section describes the changes to this guide for each release and guide version.

Changes for Release 73, Guide Version 73.10

Major updates have occurred to the following sections:

e Xtended Services Interface on page 26
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BroadWorks Device Management

BroadWorks Device Management

Overview

The BroadWorks Device Management is a comprehensive solution for simplifying the
integration, deployment, and maintenance of access devices in your network. Access
devices connect to BroadWorks to download the configuration files, firmware, and other
static files required to deliver services. The administrator can manage and control all

aspects of device configuration centrally in the network.

BroadWorks

HTTP(S)

Access Device

Key Concepts

To use device management, it is important to first understand a few key concepts and
how they are applied to the BroadWorks server.

BroadWorks uses the following three key concepts for delivering services and

managing devices:

e  The Device Profile Type
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° The Device Profile

e The User
Device Profile Type

When a new type of device is added to the network, a new device profile type should
be created on BroadWorks to manage that device. Only the system administrator can
add, modify and delete the device profile type. For more information on how to create
a device profile type, refer to Creating the Device Profile Type on page 8.

Device Profile

When a new device is added to the network, a new device profile should be created on
BroadWorks to manage that device. The device profile should be created from a given
device profile type. This gives the device profile a set of predefined settings that are
consistent with other devices of the same type in the network. For more information on
how to create a device profile, refer to Creating the BroadWorks Device Profile on page
14,

User

The administrator can assign a device profile to one user or multiple users. The number
of ports attribute in the device profile type allows BroadWorks to control the maximum
number of users who can be associated with a given device profile.

The following figure shows one user per phone device relationship:

Device Profile 1 User A

Associate User A
Base A

Device Profile 2 User B

Device Profile Type
Yealink W52P

Associate User B
Base B

Device Profile 3 User C

Associate User C 0

Base C
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The following figure shows multiple users per phone device relationship:




IP Phones Deployment Guide for BroadWorks Environment

Network Architecture

The device management functionality is fully integrated into the BroadWorks platform.
The Xtended Services Platform (XSP) hosts the access URL and authenticates all
requests made by the device. Once authenticated, the XSP will request the
configuration files from the profile server and download them to the device over
HTTP(S). The Profile server stores the device configuration files which are built by the
BroadWorks Application server.

The BroadWorks Application server supports ongoing device management by
generating notifications to trigger the end device to synchronize its settings, and
provide inventory control of devices in the field.

Device Files Device Templates
HTTP PUT
PROFILE <— | APPLICATION
A

HTTP GET

SIP NOTIFY

(sync/reset)
HTTP{S) GET
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Configuring Device Management on BroadWorks

This chapter introduces the privileges of the system administrator and group
administrator on BroadWorks. The following two sections provide a system
administrator or a group administrator with step-by-step instructions on how to
configure device management feature, such as customizing tags, uploading files and so
on.

Log in BroadWorks as System Administrator

The following sections provide information on how to customize BroadWorks tags,
create the device profile type and define the device profile type files at the system level.
If you don't have the privilege of system administrator, proceed to the next section Log
in BroadWorks as Group Administrator on page 14.

Customizing BroadWorks Tags

Service integration on BroadWorks is based on the concept of “Tags”. Tags are
variables that can be embedded in template configuration files. When BroadWorks
generates a configuration file from a configuration template, the tags are replaced with

actual values. Tags are delimited with a beginning and ending % sign.

There are two types of tags:

e  Dynamic Built-in Tags: These tags are predefined by BroadWorks. The value of
each built-in tag is dynamically evaluated based on the context of the device
profile. A built-in tag for one device is evaluated differently from another device.
All built-in tags are prefixed with “BW”.

For more information on dynamic built-in tags, refer to BroadSoft Device

Management Configuration Guide.

e  Static Tags: These tags are defined by the administrator. For example, system
default tags and device type specific tags. The value of each static tag is assigned

by the administrator.
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Creating System Default Tags

To create system default tags:

1.
2,

Click on Resources->Device Management Tag Sets.

Select the System Default.

BR«“ADSOFT T

System Welcome Default Administrator [Logout

Options: Device Management Tag Sets

Display all the device management tag sets in the system. Tag sets can also be deleted
Resources

Call Center

Communication Barring Delete Taq Set Name Edit
Meet-We Conferencing System Default Edit
Utilities =] tagSetName Edit
[Page 10f1]
Tag SetName - Starts With = Find  Find All

OK Ay Add Cancel

Click Add to add a new tag.

Enter the desired name in the Tag Name field.
The tag name must not start with “BW”.

Enter the desired value in the Tag Value field.

The tag in template configuration files can be replaced by the configured tag value.

BR«“ADSOFT s - s

System Welcome Default Administrator [Logout

E1 = Device Management Tag Sets Add Tag

Profile
Resources
SR
Call Center

Communication Barring
Meetie Conferencing Tag SetName: System Default
Utilities Tag Name: % NEW_CUSTOM_STATIC_TAG %

Add a new device managementtag to an existing tag set.

Tag Value: value

6. Click OK to accept the change.

7.

Repeat steps 3 to 6 to add more system default tags.

The following table lists some system default tags required in template configuration

files.
Tag Name Valid Value Description

%SNTP SERVER 1% IP address/FQDN The NTP server

- - Example: time-a.nist.gov address
%SNTP SERVER 2% IP address/FQDN The alternate NTP

- B Example: time-b.nist.gov server address
%DNS SERVER 1% IP address The DNS server

- - Example: 199.19.193.12 address
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Tag Name

Valid Value

Description

%DNS_SERVER 2%

IP address
Example: 199.19.193.39

The alternate DNS

server address

Enables or disables

%SBC_ADDRESS%

Example: 199.19.193.9

%USE_SBC_BOOLEAN% Boolean the outbound proxy
server
IP address/FQDN The outbound proxy

server address

%SBC_PORT%

Integer
Example: 5060

The outbound proxy
server port

Creating Device Type Specific Tags

To create device type specific tags:

1. Click on Resources->Device Management Tag Sets.

Click Add.

Enter the tag set name in the Tag Set Name field (e.g., YealinkW52P-Tags).

2
3
4. Click Add.
5

Enter the desired name in the Tag Name field.

The tag name must not start with “BW”.

6. Enter the desired value in the Tag Value field.

The tag in template configuration files can be replaced by the configured tag value.

7. Click Apply to accept the change.

8. Repeat steps 4 to 7 to add more device type specific tags.

The following table lists some device type specific tags required in template

configuration files.

Tag Name Valid Value Description
English
Turkish
Portuguese
Spanish
. The language of the
%LANGUAGEWEB% Italian .
web user interface
French
Deutsch
Polski
Czech
Enables or disables
%FEATURE_KEY_SYN% Boolean feature key

synchronization.
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Tag Name Valid Value Description

Enables or disables
%CALL_WAITING_BINARY% Boolean

call waiting feature

Creating the Device Profile Type

Device profile types are the templates for device profiles. They can be created,
modified and deleted at the system level. Creating device profile types is a crucial step
in the initial planning and deployment. Device profile types should be defined in
conjunction with the services being offered to the users. Device profile type can only be
deleted when there is no any reference to the device profile type, for example, no

device profile is associated with the device profile type.

There are two primary steps to create a device profile type:

o Defining the access profile: For the aspects related to the signaling and media
interoperability with BroadWorks.

o Defining the configuration profile: For the aspects related to the configurations of

the device.

Defining the Access Profile

When adding a new device profile type to the system, the first step is to define the
access profile. The access profile consists of attributes relating to the signaling and
media integration with BroadWorks. These attributes tell BroadWorks how to interact
with device profiles of this type. Another important configuration of the access profile is
the maximum number of ports available on the device. This attribute allows BroadWorks
to control the number of users who can be associated with a given device. The other
related configurations of the access profile are encapsulated in the “Standard Options”
and the “Advanced Options” fields.

The following table shows an example of defining the access profile. Parameters not

identified in the following table can be usually left as the defaults.

Parameter Value Description

Identity/Device Profile Type Yealink_W52P

. . Intelligent Proxy
Signaling Address Type

Addressing

Standard Options

Defines the number of

o users who can be
Number of Ports Limited To 5 . . .
associated with a device

of this device profile.
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Parameter Value Description

Determines SDP handing

Ringback Tone/Early Media Local Ringback - No for initial INVITE
Support Early Media messages sent to the
device.

Defines whether requests
Authentication Enabled for a device need to be
authenticated.

Defines whether a
device of this device
Registration Capable Checked profile type is allowed to
be registered to the
BroadWorks.

Defines whether the
RFC3264 hold

mechanism is used in the

RFC3264 Hold Checked

SIP signaling.

Advance Options

Determines which type of
notify event is sent to the
device. BroadWorks
reboots the remote
device via a NOTIFY

request with an event

Reset Event checkSync

type of either reSyn or

checkSync.

Defining the Configuration Profile

When adding a new device profile type to the system, the system administrator must
decide which level of configuration management is supported. There are three levels
available for configuring:

e Not Supported: this is the default option. You don’t need to make any configuration.

e  Device Management: when the Device Management is marked, the parameters
needing to be configured are summarized in the following table. Parameters not
identified in the following table can usually be left as the defaults.

Parameter Value Description

Use Default System Tag Selects the device tag set
Device Configuration | Set and Tag Set. created in the section
Tags Select the tag set name | Creating Device Type

(e.g., YealinkW52P-Tags) | Specific Tags on page 7.
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Parameter

Value

Description

from the pull-down list of
Use Default System Tag
Set and Tag Set.

Allow Identity/Device
Profiles to Configure
Custom Tags

Checked

Determines whether new
static tags can be
customized at the profile
level.

For more information on
how to customize static
tags at the profile level,
refer to Customizing a

Static Tag on page 15.

Allow Groups to
Configure Custom
Tags

Checked

Determines whether new
static tags can be
customized at the group
level.

For more information on
how to customize static
tags at the group level,
refer to Customizing a

Static Tag on page 15.

Device Access
Protocol

http

Determines the transfer
protocol used by the

device to get its files.

Device Access FQDN

<BroadWorks-Xsp-Cluste
r-Address>
Example:

xsp.iop1.broadworks.net

Represents the FQDN of
the XSP used by the
device to get its files.

Device Access Port

<BroadWorks-Xsp-Port>

Represents the port
number of the XSP used by

Example: 80 . o
the device to get its files.
Represents the name of
Device Access d the Broadworks DMS web
ms

Context Name

application which has

been predefined.

Device Access URI

<device-type-name>
Example: Yealink_W52P

Ensures the uniqueness of
the URL for each device
type. It typically contains
the device type name.

Legacy: when the Legacy is marked, the parameters needing to be configured

are summarized in the following table:
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Parameter Value Description

. . Defines the number of
Legacy Configuration

2 Config File configuration files for the
Type

device profile type.

Specifies the system file
y000000000025.cfg name requested by the
device.

CPE System File

Name

Specifies the device file
Device File Format %BWMACADDRESS%.cfg | name requested by the
device.

To create a device profile type:

1. Click on Resources->Identity/Device Profile Types.
2. Click Add.
3. Make the desired change.

BR-=ADSOFT o - e

System Welcome Default Administrator [Logout

Options:

Identity/Device Profile Type Add

Add a new identity/device profile type

Profile
Resources
Senices
Call Center
Communication Barring
WeetMe Conferencing * IdentityDevice Profile Type

Utilities Signaling Address Type: Non-intelligent Device Addressing ~

—Standard Option:
Number of Ports: @ Unlimited ) Limited To
Ringback Tone/Early Media Support @ RTP - Session
(") RTP - Early Session
@ Local Ringback - No Early Media
Authentication: @ Enabled

() Disabled
() Enabled With Web Portal Credentials
[T] Registration Capable Authenticate REFER
[I] Static Registration Capable [| RFC3264 Hold
[C] E164 Capable [C] Video Capable
[] Trusted [] Use History Info Header
—Advanced Options
[] Rovte Advance [] Forwarding Override
[] wireless Integration [] Conference Devce
[ PBY Integration [ Mobility Manager Device
[] Add P-Called-Party-ID [] Music On Hold Device
[] Aute Configuration Soft Client [] Requires Broadworks Digit Collection
[ Recuires BroadWorks Call Waiting Tone [] Requires MWI Subscription
[T] Advice of Charge Capable [] Support Call Center MIME Type
[] Support Emergency Disconnect Control [] Support Identity In UPDATE and Re-INVITE

["] Enabla Monitoring
ResetEvent: ) reSync ) checkSync @ Not Supported
Trunk Mode: @ User © Pilot ©) Proxy
Unscreened Presentation Identity Policy: @ Profile Presentation Identity
(Z) Unscreened Presentation Idertity
(*) Unscreened Presentation Idertity With Profile Domain

Web Bzsed Configuration URL Extension:

Davice Configuration Options: @ ot Supported () Device Management ) Legacy

4. Click OK to accept the change.

11
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Defining Device Profile Type Files

This section describes how to define the configuration files and static files that IP phones

download. There are two configuration files both of which are CFG formatted. We call

them the system file and the device-specific file. The static files are required when

employing some particular features on IP phones. The following provides detail

information for these files.

System File

The system file will be effectual for all IP phones of the same model. The system file has
a fixed name for the W52P IP DECT phone: y000000000025.cfg.

The following table lists the parameters used to define the system file.

Parameter

Value

Description

Device Access File

Format

<system-file-name>.cfg
Example: y000000000025.cfg

Specifies the name of
the system file.

Repository File Format

<system-file-name>.cfg
Example: y000000000025.cfg

Specifies the name of
the system file stored in
the Device
Management

repository.

File Category

Dynamic Per-Type

Specifies the type of the

file.

File Customization

Administrator

Identifies who can
customize the system

file.

Assign File

Custom

Authentication Mode

User Name and Password

Defines the

authentication method.

Device Access HTTP
Authentication

Digest

Device-Specific File

12

A device-specific file is only effectual for the specific IP phone. The device-specific file is

named after the MAC address of the IP phone. The file name format of the

device-specific file is as below:

<MAC address>.cfg
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The following table lists the parameters used to define the device-specific file:

Parameter

Value

Description

Device Access File
Format

%BWMACADDRESS%.cfg

Specifies the name of the
device-specific file.

Repository File Format

%BWMACADDRESS%.cfg

Specifies the name of the
device-specific file stored
in the Device

Management repository.

File Category

Dynamic Per-Device

Specifies the type of the
file.

File Customization

Administrator and User

Identifies who can
customize the
device-specific file.

Assign File

Custom

Authentication Mode

User Name and Password

Defines the authentication
method.

Device Access HTTP
Authentication

Digest

Static File

In addition to configuration files, the IP phone may require static files before it can

deliver service. Tags cannot be added to the static files. The following lists the static files
required for the W52P IP DECT phone:

° <firmware-version>.rom

e  contactData.xml
e  AutoDST.xml

e dialplan.xml

e ca.crt

e ca.pem

. blacklist.xml

The following table lists the parameters used to define the static file:

Parameter

Valuve

Description

Device Access File Format

<file-name>.cfg

Example: 25.73.0.1.rom

Specifies the name of

the static file.

Repository File Format

<file-name>.cfg

Example: 25.73.0.1.rom

Specifies the name of

the static file stored in

the Device

13
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Parameter Value Description
Management
repository.

. ) Specifies the type of the
File Category Static .
file.
Determines whether the
File Customization allow static files can be
customized.
Assign File Custom
. The static file is not
Authentication Mode Not set

authenticated.

Device Access HTTP
Authentication

Basic

To define the device profile type files:

1. Click on Resources->ldentity/Device Profile Types.

Select the desired device profile type (e.g., Yealink_W52P).
Click on Files and Authentication.

Click Add.

Make the desired change and upload the files.

A T o

Click Apply to accept the change.

Log in BroadWorks as Group Administrator

The following sections provide information on how to customize static tags, create the

device profile, upload files and so on at the group level.

Creating the BroadWorks Device Profile

14

Device profiles represent the devices themselves. When a new device profile is created
from a device profile type, it inherits a representation of the access and configuration
profiles defined at the device profile type level.

To create a device profile:

1.  Click on Resources->Identity/Device Profiles.

2. Click Add.


http://199.19.193.15/Group/DeviceInventory/

Configuring Device Management on BroadWorks

3. Select the desired device profile type (e.g., Yealink_W52P) from the pull-down list
of Identity/Device Profile Type.

BR:+ADSOFT el -Home
Group Welcome  [Logout
Options: N i

=— Identity/Device Profile Add
» Resources | Add a new group identityidevice profile.
[ sevoes |

Sevice Scripts

Acct/Auth Codes

Call Center * Identity/Device Profile Name: Test_W52P

Calling Plan IdentityiDevice Profile Type: Yealink_W52P -

Meet-Me Conferencing

Protocal: SIP 2.0 ~
Utiliies
Host Name/IP Address: Port

Transport: Unspecified ~

MAC Address: 0015655f3cTd
Serial Number:
Description:
Outbound Proxy Server
STUN Server:

Physical Location

Authentication
() Use Identity/Device Profile Type Credentials
@ Use Custom Credentials

* Device Access User Name: testuser

*Device Access Password: essssssse

* Re-fype Device Access Password: eeeesssee

4. Set the following parameters:

Parameter Example Value Description

. . . Defines the device profile
Identity/Device Profile Name Test_W52P

name.
Specifies the MAC address
MAC Address 0015655f9c7d .
of the device.
Use Custom Specifies the authentication
Authentication
Credentials method.
Device Access User Name testuser Specifies the user name.
Device Access Password Admin123. Specifies the password.

5. Click OK to accept the change.

Customizing a Static Tag

You can add a static tag at the group level for the specific device profile or the specific

device profile type.
To add a static tag for the specific device profile:

1. Click on Resources->Identity/Device Profiles->Search to list all existing device

profiles.

15
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You can click Next to turn to the next page.

BR«“ADSOFT

Help -Heme
Group Welcome  [Logout
Options: = "
= Identity/Device Profiles
» Resources Add or modify group level identity/device profiles. Displays all the identity/device profiles defined at group level
Semvices

Service Scripts
AcctAuth Codes

Call Center

Calling Plan

Meet-Me Conferencing

Utilities

DAl T o

l OK I Add I Cancel

Enter search criteria below

- Stans With -
Identity/Device Profile HName [&] Identity/Device Profile Type  Available Ports  Host Name/lP Address ~ MAC Address Status  Version Edit
4601 Yealink T28P Unlimited 00156565461E  Online  Yealink SI Edit
4602 Yealink T28P Unlimited Online  Yealink SI.. Edit
4603 Yealink T28P Unlimited Online Edit
Test_W52P Yealink_W52P g 0015655F9C7D  Online Edit
W52P_SCA Yealink_W52P 4 10.3.6.155 00156540AD50 Online  Yealink Sl Edit

[Page 10f 1]

l OK I Add I Cancel

TI

Select the desired device profile (e.g., Test. W52P) and click Edit.

Click the Custom Tags tab.

Click Add to add a new tag.

Enter the desired tag name (e.g., LANGUAGEWEB) in the Tag Name field.

Enter the desired tag value (e.g., English) in the Tag Value field.

BR«ADSOFT
Group

Options:

Profile
Resources

Semices
Semice Scripls

Acct/Auth Codes

Call Center

Calling Plan

Meet-Me Conferencing
Utilities

Help - Home

Welcome  [Logou

Identity/Device Profile Custom Tag Add

Add a new custom device management tag to the Identity/Device Profile.

Identity/Device Profile Name: Test_W52P
Identity/Device Profile Type: Yealink_W52P

Tag Name: o5 LANGUAGEWEB %

TagValue: English

7. Click OK to accept the change.

After the above settings, the customized static tag will only be effectual for the device
profile (e.g., Test. W52P).

To add a static tag for the specific device profile type:

1. Click on Utilities->Device Configuration.

The interface lists all existing device profile types.

BRADSOFT Help - Home
Group Welcome [Logout
Options: - n
=T Device Configuration
Resources Lists the configurable devices for the group.
SR
8 Script: "
l\:;’il:ljm EC”mjiss ice Profile Type (4] Configure Device Edit
Call Center Yealink_W52P Edit
== Yealink T28P Edit
Calling Plan (Fase 1 or1)
Meet-lle Conferencin £
» Utilities Identity/Device Profile Type Jid Starts With ~ Find  Find All

2. Select the desired device profile type (e.g., Yealink_W52P).
3. Click the Custom Tags tab.

16
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4. Click Add to add a new tag.
5. Enter the desired tag name (e.g., LANGUAGEGUI) in the Tag Name field.

6. Enter the desired tag value (e.g., English) in the Tag Value field.

BR:ADSOFT Help -Home
Group Welcome [Logout

Options:
Profile
Resources
SERAGES OK Cancel
Senice Scripts
AcctAuth Codes
Call Center

Device Configuration Custom Tag Add

Add a new custom device management tag for the IdentityiDevice Profile Type in this group.

Identity/Device Profile Type: Yealink_W52P

 calngPlan | Tag Name: o5 LANGUAGEWEB %
Meet-hle Conferencing Tag Value: English
B Utilities

7. Click OK to accept the change.

After the above settings, the customized static tag will be effectual for the device profile
type (e.g., Yealink_W52P). All device profiles associated with this device profile type
can also use the customized tag.

Uploading Device Template Configuration Files

Yealink provides two types of template configuration files: system and device-specific
template configuration files. Before uploading the device template configuration files to
BroadWorks, the built-in tags and static tags can be embedded in template

configuration files.

The following table describes system template configuration items that are generally
required for the W52P IP DECT phone to work with BroadWorks.

ltem Description

System Template Configuration Items <e.g., y000000000025.cfg>

. Configures the WAN port to obtain IP
network.internet_port.type = 0
address from DHCP server.

Configures the primary and secondary
NTP servers.

The tags %SNTP_SERVER_1%

and %SNTP_SERVER_2% are pre-created
on BroadWorks.
e.9.,%SNTP_SERVER_1%=time-a.nist.gov
and %SNTP_SERVER_2%=time-b.nist.gov
Enables or disables call waiting.

0 (Disable),1 (Enable)
call_waiting.enable The tag % CALL_WAITING_BINARY % is
= %CALL_WAITING_BINARY% pre-created on BroadWorks.

e.g., %CALL_WAITING_BINARY%=1

or %CALL_WAITING_BINARY%=0

local_time.ntp_server1
= %SNTP_SERVER 1%
local_time.ntp_server2
= %SNTP_SERVER 2%
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ltem Description

Enables or disables feature key

synchronization.

0 (Disable),1 (Enable)

The tag %FEATURE_KEY_SYN% is

pre-created on BroadWorks.

e.g., %FEATURE_KEY_SYN%=1
or %FEATURE_KEY_SYN%=0

Configures the access URL for

bw.feature_key_sync
= %FEATURE_KEY_SYN%

downloading the firmware.

e.g., %BWDEVICEACCESSFQDN%=
xsp.iop1.broadworks.net,

firmware.url = %BWDEVICEACCESSPORT%=80,
http://%BWDEVICEACCESSFQDN | %BWDMSCONTEXT%=dms and
%:%BWDEVICEACCESSPORT%/% | %BWDEVICEACCESSURI%=Yealink_W52
BWDMSCONTEXT%/%BWDEVICE | P

ACCESSURI%%FIRMWARE_VERSI | These tags are dynamic built-in tags,
ON% which are predefined by BroadWorks.
The tag %FIRMWARE_VERSION% is
pre-created on BroadWorks.

e.g., %FIRMWARE_VERSION%=25.73.0.1

0.rom

The following table describes device-specific template configuration items that are
generally required for the W52P IP DECT phone to work with BroadWorks.

ltem Description

Device-specific Template Configuration ltems <%BWMACADDRESS%.cfg>

Enables or disables the first line.
0 (Disable),1 (Enable)
"%BWLINE-BINARY-1%" identifies

whether to assign a line port to the first

account.1.enable
= %BWLINE-BINARY-1%

user.

Configures the name to be displayed
on the phone for the first line.

The tag “%BWCLID-1%" will be
replaced by the Calling Line ID (CLID)
retrieved from the Calling Line ID First

account.1.display_name
= %BWCLID-1%

and Last Name fields in the first user’s
profile on BroadWorks.

Configures the user ID for the first line.
account.1.user_name The tag “%BWLINEPORT-1%" will be
= %BWLINEPORT-1% replaced by the line/port setting in the
first user’s address on BroadWorks.
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ltem Description

Configures SIP authentication for the

first line.
account.1.auth_name If the authentication service is assigned
= %BWAUTHUSER-1% on BroadWorks, the tags
account.1.password “%BWAUTHUSER-1%" and
= %BWAUTHPASSWORD-1% "%BWAUTHPASSWORD-1%" will be

replaced by the first user’s
authentication settings on BroadWorks.

Configures the first line as a private or
shared line.

0 (Private),1 (Shared)
%BWSHAREDLINE-BINARY-1% indicates
whether the first line is shared.

account.1.shared_line
= %BWSHAREDLINE-BINARY-1%

You can upload device template configuration files at the profile level or at the group
level.

To upload device template configuration files at the profile level:

1. Click on Resources->ldentity/Device Profiles->Search to list all existing device
profiles (Click Next to turn to the next page).

2. Select the desired device profile (e.g., Test. W52P) and click Edit.

3. Click the Files tab.

The interface lists all existing files.

Profile

Group Welcome [Logout
deion Identity/Device Profile Modify

» Resources View or modify files used by the Identity/Device Profile

Semvices
 SeniceScripts |
 AccAuhCodes |

Call Center

Calling Plan

Meet-Me Conferencing Identity/Device Profile Name: Test_W52P

Utilities Identity/Device Profile Type: Yealink_W52P

Files ‘Custom Tags

Rebuild the files Reset the phones
(After rebuilding the files, be sure to reset the phones for your changes (o take effect)

File Format [4] fnme"m‘ eq ccessFile ?Tim :i;'lnlale Edit

:WMACADDRESS% x v w Download T Edit

¥000000000025.cfg v %mw Download Download  Edit
[Page 10f1]

4, Select the desired template configuration file (e.g., %BWMACADDRESS%.cfg) and
click Edit.

5. Mark the Custom radio box in the Assign File block.
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6. Click Browse to upload the desired template configuration file.

BR:*ADSOFT

Options:

Calling Plan

Utilities

Profile

Service Scripts
A des

Conferencing

Help - Home

Welcome [Logout

Identity/Device Profile File Modify

Wodify an existing IdentityDevice Profile file

= T

IdentityDevice Profile Name: Test_W52P
Identity/Device Profile Type: Yealink_W52P
File Format: %BWMACADDRESS%.clg
Access File: hitp/sp1.iop1 net
Repository File: Download
Template File: Download

Yealink W52P/0015655f9c7d.cig

—Assign

© Manual
© Default
® Custom
Upload Configuration File:
Currently using file:

Browse

cig.template

#1version:1.0.0.1 »

$#File header "#!version:1.0.0.1" can not be edited or
deleted.##

i Accountl
Settings
## <

Rebuild the files Reset the phones

7. Click Apply to accept the change.

After the above settings, template configuration files will only be effectual for the device
profile (e.g., Test_ W52P).

To upload device profile type template configuration files at the group level:

-

Click on Utilities->Device Configuration.

The interface lists all existing device profile types.

Dol

Select the desired device profile type (e.g., Yealink_'W52P) and click Edit.
Click the Files tab.

The interface lists all existing template configuration files.

BR«=ADSOFT

Options:

Profile

Senices

Resources

Senice Scripts
AccliAuth Codes
Call Center

Calling Plan
Meet-lle Conferencing
» Utilities

Help - Home
Welcome [Logout]

Device Configuration Files
Wiew and modify files used by the IdentityDevice Profile Type in the group.

Rebuild the files Resetthe phones
(After rebuilding the files, be sure to resetthe phones for your changes to take effect)

Device Type URL. hitp/fxsp1.iop1.broadworks.net.80/dmsiYealink_W52P/

Files Custom Tags

Identity/Device Profile Type: Yealink_W52P

_ Is _ Repository  Template _
File Format [4] Authenticated  ACCESSFile. = = Edit
hitp:iixsp1.iop1.broadworks.net:80/dms/Yealink_W52P4%
25BWMACADDRESS%25}.cfg

Note: this URL has undefined content. Validate it manually by replacing any EER R

content between {} with valid value(s).

%
BWMACADDRESS%.cfg

y000000000025.cfg v hitp-iixsp1.iop1 net80/dms/Yealink_W52P/y000000000025 cfg Download Download  Edit
[Page 10f1]

4. Select the desired template configuration file (e.g., y000000000025.cfg) and click

Edit.

5. Mark the Custom radio box in the Assign File block.

6. Click Browse to upload the desired template configuration file.

7. Click Apply to accept the change.
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Note

After the above settings, template configuration files will be effectual for the device
profile type (e.g., Yealink_W52P). All device profiles associated with this device profile
type can download the configuration files.

Commonly, template configuration files for each phone model have been uploaded by
the system administrator. At the group level, you can upload the new template
configuration files for the specified phone to override the old template configuration files.
For more information on how to define template configuration files, refer to Defining
Device Profile Type Files on page 12.

Uploading Static Files

You can upload static files at the profile level or the group level.

To upload static files at the profile level:

1. Click on Resources->ldentity/Device Profiles->Search to list all existing device
profiles (Click Next to turn to the next page).

2. Select the desired device profile (e.g., Test_ W52P) and click Edit.

3. Click the Files tab.

The interface lists all existing files.

Select the desired static file (e.g., 25.73.0.1.rom) and click Edit.

Mark the Custom radio box in the Assign File block.

Click Browse to upload the desired static file.

A

Click Apply to accept the change.
After the above settings, the static files will only be effectual for the device profile (e.g.,
Test_W52P).

To upload static files at the group level:

1. Click on Utilities->Device Configuration.
The interface lists all existing device profile types.
2. Select the desired device profile type (e.g., Yealink_W52P) and click Edit.
3. Click the Files tab.
The interface lists all static files.
Select the desired static file to edit (e.g., 25.73.0.1.rom).
Mark the Custom radio box in the Assign File block.

Click Browse to upload the desired static file.

N o g &

Click Apply to accept the change.

After the above settings, the static files will be effectual for the device profile type (e.g.,
Yealink_W52P). All device profiles associated with this device profile type can
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Note

download the static files.

Commonly, static files for each phone model have been uploaded by the system
administrator. At the group level, you can upload the new static files for the specified
phone to override the old static files. For more information on how to define static files,
refer to Defining Device Profile Type Files on page 12.

Assigning the Device Profile to the User

22

To assign the device profile to the user:

1.

2
3
4.
5

Group =Users : 4602 Welcome [Logout

Options: Addr

Click on Profile->Users->Search to list all existing users.
Select the desired user.

Click on Addresses.

Mark the Identity/Device Profile radio box.

In the Identity/Device profile block, select the created device profile (e.g.,
Test_W52P) from the pull-down list of Identity/Device Profile Name.

Enter the register’s user name in the Line/Port field.

Select the domain name (e.g., pbx.yealink.com) from the pull-down list after the
sigh @.

»

Client Applications Phone Number: 4602 ~ Activated

Profile

\ncoming Calls Addresses allows you to view and maintain your phone number and other identities that are used to make and receive calls.
Incoming Calls

Calling Plans

8.

Messaging Extension: 4602
Senice Scripls
Utllities

@ Identity/Device Profile ) Trunking () None
IdentityDevice Profile
IdentityDevice Profile Name: Test W52P (Group) -

*Line/Port: 4602 @ pbx yealink.com ~ AdvancedSetlings

Aliases: sip: 4502@pbx.yealink.com

sip @ pbx.yealinkcom ~

sip @ pbx.yealinkcom ~

sip @ pbx.yealinkcom ~
oK Apply Cancel

Click Apply to accept the change.

To check the users assigned the device profile:

1.
2.

Click on Resources->Identity/Device Profiles.

Click Search to display all existing device profiles.
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You can click Next to turn to the next page.

Group

Options:

Profile
Resources
Semvices

Service Scripts
AcctAuth Codes

Call Center

Calling Plan

Meet-Me Conferencing

Utilities

Identity/Device Profiles

Add or modify group level identity/device profiles. Displays all the identity/device profiles defined at group level

l OK I Add I Cancel

Enter search criteria below

Identity/Device Profile Name Jid

Starts With ~

Help -Home
Welcome [Logouf]

Identity/Device Profile Hame [A]  Identity/Device Profile Type ~ Available Ports

4601 Yealink T28P
4602 Yealink T28P
4603 Yealink T28P
Test W52P Yealink_W52P
W52P_SCA Yealink_W52P

l OK I Add I Cancel

Host NameiIP Address  MAC Address
Unlimited 00156565461E
Unlimited
Unlimited
] 0015655F9CTD
4 10.3.6.155 00156540AD50
[Page 10f 1]

3. Select the desired device profile (e.g., Test_W52P) and click Edit.

4, Click the Users tab.

5. Click Search to display all users assigned to the device profile.

Status
Online
Online
Onling
Online
Onling

Version Edit
Yealink I Edit
Yealink 51... Edit

Yealink SI dit

TI

Group

Help -Home
Welcome [Logoul

Options:

Profile

» Resources
Senvices
Service Scripls
Acct/Auth Codes

Call Center

Calling Plan
Meet-Me Conferencing
Utilities

Identity/Device Profile Modify

View the line/ports assigned on the |dentity/Device Profile

e T

Users Files
Enter search criteria below
Line/Port User Part Jig Starts With +
Primary N Endpoint
LineiPort Line/Port [4] Port
(= 4602@pbx yealink.com 1 Primary

Apply l Cancel

OK l

Custom Tags
Dn User Last
Type 1D Name
Main 4602 4602
[Pagefof1]

=
5

=
]
R

IS
&
=
=)

Extension

4602

Depariment  Edit
Edit

As shown in the above figure, only the user 4602 has been assigned to the device

profile Test W52P
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Configuring BroadSoft UC-One Integrated
Features

This chapter provides the detail instructions and configurations for the following
BroadSoft integrated features:

e  Xtended Services Interface

e  Simultaneous Ring Personal

° Line ID Blocking

e  Anonymous Call Rejection

e  BroadSoft Directory

° BroadSoft Call Log

e Hunt Group

e  Call Park

e Instant Group Call

e  Authentication

e  Authorization/Account Codes

e  Call Waiting

e  Diversion Inhibitor

e Do Not Disturb

e  Call Forward

e  Alternate Numbers

e  Sequential Ring

e  Call Transfer

e  Feature Key Synchronization

e  Call Pickup

e  Network Conference

e  Calling Line ID Presentation

e  Calling Line ID Blocking Override
e  Connected Line Identification Presentation
e  Connected Line Identification Restriction
e  Shared Call Appearance

° Music on Hold
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e  Voice Messaging

To configure the above features on Yealink W52P IP DECT phones, check whether the IP
phone is running UC-one firmware version (x.x.193.x). If the IP phone is running a neutral
firmware, you need to upgrade the phone firmware to the UC-One firmware version in
advance. Contact Yealink field application engineer for the UC-one firmware or
download it online:

http://www.yealink.com/SupportDownloadfiles_detail.aspx?Cateld=308&flag=142.

Xtended Services Interface

Note

26

The Xtended Services Interface (XSI) is an HTTP-based, REST-ful Application
Programming Interface (API) available over BroadWorks, targeted to end-user
functionalities such as call log lists, directories and end-user service configurations. IP

phones interoperate with BroadWorks XSI using HTTP messages.

IP phones implement BroadWorks XSI to access the following XSl features:

e  BroadSoft Directory

e  BroadSoft Call Log

Before accessing the BroadSoft directory and call log, make sure that the
authentication information for XSI access has been properly configured on IP phones.

For the IP phone to access XSl features, the Xtended Services Platform (XSP) must first
authenticate the XSl user. The IP phones running firmware version 73 or later support two

XSI authentication methods:

e  User Login Credentials for XSI Authentication: the IP phone uses the XSl user login
credentials (web portal login user ID and password) for XSI authentication. If no
custom tag is configured for the XSl user password, the XS| user password will be
not available from the Device Management configuration file. In this case, the end
user needs to manually configure it on the IP phone or enter the password in the

login screen.

° SIP Credentials for XSI Authentication: As of BroadWorks release 20.0, the IP phone
can use the XSI user ID along with SIP authentication credentials for XSI
authentication. SIP authentication credentials are the register name and password
of the SIP account registered on the first line of the phone, which can be obtained
through Device Management configuration file. No end user input or manual
configuration is required. This method is not applicable to IP phones with firmware

version prior to 73.
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You can configure the authentication method the phone uses for XSI access. For more
information on how to configure the phone, refer to the following section.

Note The lock state of SIP credentials is not taken into account for the SIP credentials for XSI
authentication scheme. For example, the IP phone can be locked out for signaling but
can still use its locked SIP credentials for XSI authentication and to be authenticated
successfully.

The IP phone only supports to use the register name and password of the first account
on the phone for the SIP credentials for XSI authentication scheme. To use this
authentication scheme, ensure that the SIP register name and password of the
corresponding user are properly pre-configured on the first line of the phone.

Configuring Yealink IP Phones

The XSl is configurable using template configuration files or via web user interface.
To configure the XSI using template configuration files:

1. Add/Edit XSI parameters in template configuration files:

Parameter Description Value

Configures the authentication
method the IP phone uses for
XSl access.

. o .| 0- User Login Credentials for XSI
sip.authentication_for_xsi o Oor1
Authentication

1-SIP Credentials for XSI
Authentication

The default value is 0.

Configures the XSl user ID for
xsi.user XSI access authentication. %BWLOGIN-ID-1%
The default value is blank.

Configures the access URL of

. the Xtended Services Platform
xsi.host %XSP_ADDRESS%
server.

The default value is blank.

Configures the password for XSI
authentication.

The default value is blank.
%XSIPASSWORD-1

xsi.password Note: It is required only when o
0

the value of the parameter

“sip.authentication_for_xsi” is

set to 0.
. Configures the port of the Integer from 1 to
xsi.port .
Xtended Services Platform 65535
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Parameter Description Value

(XSP) server.
The default value is 80.

Configures the access protocol

. of the Xtended Services
xsi.server_type http or https
Platform (XSP) server.

The default value is http.

The following shows example configurations for user login credentials for XSI
authentication in the template configuration file (e.g., y000000000025.cfg):

sip.authentication for xsi = 0

xsi.user = $BWLOGIN-ID-1%

xsi.host = %$XSP ADDRESS%
xsi.password = $XSIPASSWORD-1%
xsi.port = 80
xsi.server type = http

2. Customize the static tags on BroadWorks.

The following table shows an example:

Tag Name Value

%XSIPASSWORD-1% | yealink

%XSP_ADDRESS% xsp.yealink.com

For more information, refer to Customizing a Static Tag on page 15.
Please contact your BroadSoft reseller for the actual values of these tags.
3. Upload template configuration files.
For more information, refer to Uploading Device Template Configuration Files on

page 17.

After the above configurations, the tags in the template file will be replaced by the

actual parameter values. An example is shown as below:

sip.authentication for xsi = 0
xsi.user = 4605@pbx.yealink.com
xsi.host = xsp.yealink.com

xsi.password = yealink
xsi.port = 80

xsi.server type = http
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After successful update, user can find the web user interface of the IP phone is

similar to the one as shown below:

=
Yealink | ws»
Account Network
XSI
Contacts 0
Allow SIP Authentication for XSI Disabled AN 7] P
Remote Phone Pepyeikcom
Book XSI Server [xsp.yealink.com [7)
XSI Port 180 0
Network Directory
XS1 Server Type HTTP A e
XSI Username [4605@pbx.yealink.com [7]
XS1 Password sessanss [7]
Directory 0
Group Enable Group
Enterprise Disabled + Enterprise
GroupCommon Disabled + GroupCommon
EnterpriseCommon  Disabled EnterpriseCommon
Personal Enable ~ Persanal
Update Time Interval{60-86400) l—
(Minutes) 1440 0
Metwork Call Log Enabled - @

The following shows example configurations for SIP credentials for XSI authentication in
the template configuration file (e.g., y000000000025.cfg):
sip.authentication for xsi =1
xsi.user = $BWLOGIN-ID-1%

xsi.host = %XSP_ADDRESS%

xsi.port = 80
xsi.server type = http
account.l.user name = $BWLINEPORT-1%

account.l.password = $BWAUTHPASSWORD-1%

After editing the configuration file, upload it to BroadWorks. The tags in the template file
will be replaced by the actual parameter values. An example is shown as below:

sip.authentication for xsi =1
xsi.user = 4605@pbx.yealink.com
xsi.host = xsp.yealink.com

xsi.port = 80
xsi.server type = http
account.l.user name = 4605

account.l.password = yealinkl1105
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After successful update, user can find the web user interface of the IP phone is similar to
the one as shown below:

-
Yealink | ws:»
Status Account Network Phone
XST
Contacts e
Allow SIP Authentication for XSI Enabled - @ .
Remote Phone i +
Book XSI Server xsp.yealink.com o
N XSIPort 80 o
Network Directory
XSI Server Type HTTP - e
XSI Username 4605@pbx.yealink.com (7]
Directory @
Group Enabled = Group
Enterprise Disabled = Enterprise
GroupCommon Disabled = GroupCommon
EnterpriseCommon  Disabled - EnterpriseCommon
Personal Disabled ~ Personal
Update Time Interval(60-86400) ’7
(Minutes) 1440 o
Metwark Call Log Disabled - e

Simultaneous Ring Personal

Simultaneous ring personal allows a user to have up to 10 secondary locations to be
alerted simultaneously in addition to the user’s primary location, when receiving an
incoming call that matches the pre-defined criteria. The call is connected to the user
who answers the call first. The enhancement, Answer Confirmation, allows simultaneous

ringing personal to prompt the callee to enter a digit to confirm the acceptance of the
call.

Configuring the BroadSoft Server
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To assign the simultaneous ring personal service to a user:

1. Log into the web portal as a group administrator.
Click on Profile->Users->Search to display all existing users.

Select the desired user (e.g., 4605).

> N

Click on Assign Services.
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5. In the Available Services box, select Simultaneous Ring Personal and then click
Add>.

BR«ADSOFT beio - Home
Group >Users : 4605 Welcome [Logout

Options:

B Profile
ncoming Calls
| outgoingcals |

| CalingPians |
Client Applications
Messaging
Senice Scripts
Utilities

Assign Services

Assign Services allows you to assign or unassign senvices and service packs for a user. If a service or service pack is unassigned the senvice data that has been
filled out will be lost

Available Service Packs User Service Packs

Add =

Remove <

Add All ==

Available Services User Services

Basic Call Logs Add > Shared Call Appearance 35 -

Call Center - Premium Shared Call Appearance 5
- Simultaneous Ring Personal
Remove Speed Dial 100
Speed Dial 8
Third-Party MWI Control
Third-Party Voice Mail Support
Three-Way Call
Two-Stage Dialing
Video Add-On
Video On Hold User

= 1

6. Click Apply to accept the change.

Add All ==

1 [

@ o
@ @
3 3
2 3
s &
z z

To configure simultaneous ring personal for a user:

1. Log into the web portal as a group administrator.

2. Click on Profile->Users->Search to display all existing users.

3. Select the desired user (e.g., 4605), who has been assigned the simultaneous ring
personal service.

4. Click on Incoming Calls->Simultaneous Ring Personal.

5. Click Add to add a new simultaneous ring personal entry.

6. Set the parameters of the simultaneous ring personal criteria.
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The following shows an example:

Description:

R-entry1

Use simultaneous ring personal:  Selected

Selected Time Schedule: Every Day All Day
Selected Holiday Schedule: None
Calls from: Any phone number

BR«+ADSOFT

Group =Users : 4605

Help - Home

Welcome [Logou

I ———

Options:

Profile

Incoming Calls
Qutgoing Calls
Call Control
Calling Plans
Client Applications

v

7.

Messaging
Senvice Scripts

Utilities

Simultaneous Ring Personal Add

Allows you to add a simultaneous ring personal entry. Specify the time schedule andfor holiday schedule you would like calls simultaneously rung. Also, you can
have the call simultaneously rung when only the specified numbers call or all numbers call. If you need more than 12 numbers or more distincttime or holiday
periods, you can create multiple simultaneously ring personal entries.

* Description: R-entry1|
1@ Use simultangous ring personal
) Do notuse simultaneous ring persenal
Selected Time Schedule: Every Day All Day ~
Selected Holiday Schedule: Mone ~

[ Calls from
@ Any phone number
") Following phone numbers:
[”] Any private number
[] Any unavailable number

Specific phone numbers:

Click OK to accept the change.

8. Configure the following parameters for simultaneous ring personal.

Parameter Description

Simultaneous Ring Personal

Specifies whether to use the simultaneous

ring personal service.

Do not ring my Simultaneous Ring
Numbers if I'm already on a call

Specifies whether secondary phone
numbers or URIs should be alerted while

the primary location is already on a call.

Answer confirmation required

Allows simultaneous ring personal to
prompt the answering party to enter a
digit to confirm the acceptance of the

call.

Phone Number / SIP-URI

Specifies the phone number or SIP URI of

the location.

The following shows an example:

Simultaneous Ring Personal: Selected

Do not ring my Simultaneous Ring Numbers if I'm already on a call: Selected

Continue the search process if the base location is busy: Selected

Enable caller to skip search process: Selected

Answer confirmation required: Selected




Configuring BroadSoft UC-One Integrated Features

Phone Number / SIP-URI: 4602 4603

Group ~Users : 4605 Welcome [Logou
Options: . .
— Simultaneous Ring Personal
rofile
rr a Ring Personal allows you to listup to 10 phone numbers or SIP-URI addresses you would like to ring in addition to your primary phone when you
Incoming talls receive a call. This feature is helpful when you are not at your phone but you would like your cell phone to ring when you get a call. You can also turn off
Outgoing Calls simultanaous ring when you are at your desk on a call. The criteria for each Simultaneous Ring entry can b a list of up to 12 phone numbers or digit patterns, a
Call Control specified time schedule, and a specified holiday schedule. All criteria for an entry must be satisfied for the call to enter Simultaneous Ring (phone number and day
W of week and time of day). Ifthe criteria do not match, the call continues as ifthis service was notturned on. Warning: if your cell phone or other phone has voice mail
Lalling Plans

that picks up before your office voice messaging picks up, your voice mails could be on your cell phone messaging system!
Client Applications

Semvice Scripts
Utilities

Simultaneous Ring Personal: @ on ) Off

Do notring my Simultaneous Ring Numbers if 'm already on a call

Answer confirmation required Phone Number / SIP-URI Answer confirmation required Phone Number / SIP-URI

4602 o

4603 o

0 s

0 s

0 s

Active Description Ring Simultaneously Calls from Edit
R-entry1 Yes All calls Edit

e ———

9. Click Apply to accept the change.

For more information on simultaneous ring personal, refer to BroadWorks Web Interface

Administrator Guide.

Line ID Blocking

Line ID blocking allows a user to block his identity from showing up when placing a call.
When a user uses with this feature enabled places a call, the BroadWorks sends an
INVITE to the callee with From header: From:

“Anonymous” <sip:anonymous@anonymous.invalid>. The callee’s phone LCD screen
presents “anonymous” instead of the caller’s identity. This feature does not apply to
calls between the same group users.

Configuring the BroadSoft Server

To assign the calling line ID delivery blocking service to a user:

1. Log into the web portal as a group administrator.
Click on Profile->Users->Search to display all existing users.

Select the desired user (e.g., 4605).

> 0N

Click on Assign Services.

33



IP Phones Deployment Guide for BroadWorks Environment

34

5. Inthe Available Services box, select Calling Line ID Delivery Blocking and then click

Add>.

Group =Users - 4605

Options:

Help - Home

Welcome [Logout

» Profile
Incoming Calls

Call Control

Qutgoing Calls

Assign Services

Assign Services allows you o assign or unassign services and service packs for a user. If a service or service pack is unassigned the service data that has been
filled out will be lost.

= L

Calling Plans
Client Applications

Messaging
Senice Scripts
Utilities

Available Service Packs User Service Packs
Add >
Remove =
Add All ==
Remave Al 4
Available Services User Services

Basic Call Logs Add =
Call Center - Premium

>

BroadWorks Anywhere
BroadWaorks Mobility

Busy Lamp Field

Call Forwarding Always

Call Forwarding Busy

Call Forwarding No Answer

Call Forwarding Not Reachable
Call Forwarding Selective

Calling Line 1D Blocking Override

Calling Name Delivery -

= =

[m]

Remave <

Add All ==

o
Fy
3
H
®
z

6. Click Apply to accept the change.

To configure line ID blocking for the user:

1. Log into the web portal as a group administrator.

el

Click on Profile->Users->Search to display all existing users.

Select the desired user (e.g., 4605), who has been assigned the calling line ID

delivery blocking service.

o »

Click on Outgoing Calls->Line ID Blocking.
Mark the On radio box in the Block Calling Line ID on Outgoing Call field.

Group =Users : 4605

Options:

Erofile

» Outqoing Calls
Call Control

Incoming Calls

Help - Home

Welcome [Logout]

Calling Line ID Delivery Blocking

Calling Line ID Delivery Blocking allows you to block your number from being shown when calling other numbers. Members of your group can still see your number
when they are called. You have the choice of turning it on or off for all calls and then selectively turning it back on or off using the feature access codes.

= T

Calling Plans
Client Applications
Messaging

Utilities

Service Scripts

Block Calling Line ID on Qutgoing Calls: = On © Off

OK Apply Cancel

6. Click Apply to accept the change.

For more information on line ID blocking, refer to BroadWorks Web Interface

Administrator Guide.
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Anonymous Call Rejection

Anonymous call rejection allows a user to automatically reject incoming calls from
callers who deliberately block their identities from showing up. This feature does not
apply to calls between the same group users.

Configuring the BroadSoft Server

To assign the anonymous call rejection service to a user:

1. Log into the web portal as a group administrator.
2. Click on Profile->Users->Search to display all existing users.
3. Select the desired user (e.g., 4604).
4. Click on Assign Services.
5. In the Available Services box, select Anonymous Call Rejection and then click
Add>.
Group =Users : 4604 Welcome [Logout
Opticns: Assign Services
¥ Profle Assign Services allows you to assign or unassign services and service packs for 2 user. If a service or service pack is unassigned the service data that has been
% filled out will be lost
utgoing Calls
Calling Plans

Available Service Packs User Service Packs
Client Applications

llessaging
Service Scripls
Utilities

Add =

Remave <

Add All ==

Available Services User Services

Add > Alternate Numbers

Authentication

Automatic Callback

Automatic Hold/Retrieve

Barge-in Exempt

BroadTouch Business Communicator Desktop - Video
BroadTouch Business Communicator Mobile - Video
BroadTouch MobileLink

BroadWorks Anywhere

BroadWorks Mobility <

6. Click Apply to accept the change.

Basic Call Logs

[l »

|
Remove <

Add All ==

a a
@ @
3 3
2 2
= 5
= =

To configure anonymous call rejection for a user:

1. Log into the web portal as a group administrator.

N

Click on Profile->Users->Search to display all existing users.

o

Select the desired user (e.g., 4604), who has been assigned the anonymous call

rejection service.

4. Click on Incoming Calls->Anonymous Call Rejection.
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5. Mark the On radio box in the Anonymous Call Rejection field.
BR«ADSOFT Help - Homs
Group >Users - 4604 Welcome  [Logouf]

Options:

»

Profile
Incoming Calls Callers whose numbers are unavailable are not rejected. Callers that are rejected are informed that you are not accepting calls from unidentified callers. Your
Outgoing Calls phone does not ring and you do not receive any indication that they called. However, this does not apply to calls within your group.

Call Control
Client Applications
Messaging Anonymous Call Rejection: ié‘un 0 off

Anonymous Call Rejection

Anonymous Call Rejection allows you to reject calls from callers who have blocked the display of their number. Only deliberate anonymous numbers are rejected

6.

Semwice Scripts
Utilities

= T

Click Apply to accept the change.

For more information on anonymous call rejection, refer to BroadWorks Web Interface

Administrator Guide.

BroadSoft Directory

IP phones support to access the BroadSoft directory locally. The BroadWorks server

provides six types of directories: Enterprise Directory, Group Directory, Enterprise

Common Directory, Group Common Directory, Personal Directory and Custom Directory.

36

Enterprise Directory: It contains a list of all users in the enterprise. Each entry in the
enterprise directory contains the name, user ID, extension, group, department, etc.
The enterprise directory is created automatically from BroadWorks. The user has

just read-only access.

Group Directory: It contains a list of all users in the group. Each entry in the group
directory contains the name, user ID, extension, department, etc. The group
directory is created automatically from BroadWorks. The user has just read-only

access.

Enterprise Common Directory: It contains a list of common contacts in the
enterprise. Each entry in the directory contains the name and phone number. Only
the enterprise administrator can add a new contact to the enterprise common
directory. The enterprise common directory is shared with all users within the same
enterprise. The user has just read-only access.

Group Common Directory: It contains a list of common contacts in the group. Each
entry in the directory contains the name and phone number. The group
administrator can add a new contact to the group common directory. The group
common directory is shared with all users within the same group. The user has just

read-only access.

Personal Directory: It contains a list of personal contacts of the user. Each entry in
the directory contains the name and phone number. The user can add a new
contact to the personal directory.

Custom Directory: It contains a subset of the users in the group or enterprise. The

administrator can add a custom directory, such as an Executive Directory,
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containing the desired users.

Note WS52P IP DECT phones do not support to display the custom directory.

Configuring the BroadSoft Server

To view the group directory:

1. Log into the web portal as a group administrator.
2. Click on Utilities->Group Directory.

3. Click Search to display a list of all users in the group.

BR-*ADSOFT et - o
Group ‘Welcome  [Logouf]
- —
o Group Directory
Rerone) Displays the group directory listing. A summary of the group directory can be generated, which can be easily printed and a detailed phone list can be generated.
Senices o
Senvice Scripts
Acctiauth Codes
Group Directory Summal Group Directory Detail
Enter search criteria below
ot > @ Starts Ve @
Name [&] User ID Phone Number Extension Department Mobile E-mail Address YahoolD IM&P ID
35143514 2413333514 +44-2413333514 3514
Anywhere Portall (BroadiWorks. Portall
CallCenter (Call Center) CallCenter +44-2413333511 3511
Hunt Group (Hunt Group) HuntGroup
Ins {Instant Group Call) 2413333650 +44-2413333515 3515
Instant Group (Instant Group. Instantgroupt
Meet-MeConference (Meet-Me C. Meet-Me-Conference +44-2413333512 38512
Paging Groupt (Group Paging) 1234567 +44-2413333501 3501
Paging Group2 (Group Paging) PagingGroup2
Paroup (Group Paging) 2413333701
Voice Portal (voice Portal) 232319244_¥MR +44-2413333513 3513
yealink, 3601 2413333501
yealink, 3502 2413333502 +44-2413333502 3502
yealink, 3503 2413333503 +44-2413333503 3503
yealink, 3504 2413333504
yealink 2505 2413333505 +44-2413333505 3505
yealink, 3506 2413333506 +44-2413333506 3506
yealink, 3507 2413333507 +44-2413333507 3507
yealink, 3508 2413333508 +44-2413333508 3508
yealink, 3509 2413333509 +44-2413333500 3509
[Page10of2] Next Last

4. To display the summary of group directory, click Group Directory Summary.

A printable summary page appears in a separate browser window.

Phone List
35143514 2413333514 H44-2413333514 (3514
Anywhere Portall (BroadWorks Anywhere)  |Portall
CallCenter (Call Center) CallCenter +44-2413333511 (3511
Hunt Group (Hunt Group) HuntGroup 1
Ins (Instant Group Call) 2413333650 +44-2413333515 (3515
Instant Group (Instant Group Call) Instantgroup 1
Ieet-IeConference (MMeet-IMe Conferencing) Meet-Me-Conference [+44-2413333512 (3512
Paging Group 1 (Group Pagng) 1234567 +44-2413333501 |3501
Paging Groupz (Group Paging) PagingGroup2
Pgroup (Group Paging) 2413333701
Woice Portal (Veice Portal) 232319244 VMR [+44-2413333513 (3513
vealink,3501 2413333501
yealink, 3502 2413333302 +44-2413333502 |3502
yealink, 3503 24133333503 +44-2413333503 (3503
vealink, 3504 2413333504
yealink, 3505 2413333305 +44-2413333505 |3505
yealink, 3506 24133333506 +44-2413333506 (3506
vealink, 3507 2413333507 H44-2413333507 (3507
yealink, 3502 24133333508 +44-2413333508 (3508
yealink, 3509 24133333509 +44-2413333509 (3509
vealink, 3510 2413333510 H44-2413333510 (3510
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5. To display the details of group directory, click Group Directory Detail.

A printable detail page appears in a separate browser window.

Phone List
3514,3514 Anywhere Portall (BroadWorks Anywhere)
2413333514 Woice; +44-2413333514 Portall

Extension: 3514

CallCenter (Call Center)

Callcentsr

Hunt Group (Hunt Group)

Woica: +44-2413333511 HuntGroupl
Extension: 3511

Ins (Instant Group Call)

Instant Group (Instant Group Call)

2413333650 Voice: +44-2413333515 Instantgroupt
Extension: 3515
Meet-MeConference (Meet-Me Conferencing) Paging Group1 (Group Paging)
Meet-Me-Conference Woice: +44-2413333512 1234567 Voice: +44-2413333501
Extension: 3512 Extension: 3501
Paging Group2 (Group Paging) Pgroup (Group Paging)
PagingGroup? 2413333701
Voice Portal (Voice Portal) wealink, 3501
232319244_VMR Voice: +44-2413333513 2413333501

Extension: 3513

yealink,3502 yealink,3503
2413333502 Woice; +44-2413333502 2413333503 Voice: +44-2413333503
Extension: 3502 Extension: 3503

yealink,3504 yealink, 3505
2413333504 2413333508 Voice: +44-2413333505
Extension: 3505

yealink,3506 yealink,3507
2412333506 Wbite: +44-2413333506 2413333507 Voice: +44-2413333507
Extension: 3506 Extension: 3507

yealink,3508 yealink,3509
2413333508 Woice; +44-2413333508 2413333509 Voice: +44-2413333509
Extension: 3508 Extension: 3509

yealink,3510

2413333510

Woice: +44-24
Extensian

133510
3510

To add a contact to the group common directory:

1. Log into the web portal as a group administrator.

. Click on Utilities->Common Phone List.

. Click Add.

2
3
4. Enter the name in the Name field.
5

. Enter the phone number in the Phone Number field.

Group

Options:

Help - Home

Welcome [Logout

Common Phone List Add

Profile
Resources

Add a comman phone number ta the list

Semvice Scripts

Call Center

Senices

Acct/Auth Codes

Calling Plan
Meet-Me Conferencing
B Utilities

OK Cancel

*Name: Bob

*Phone Number: 4606
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6.

You

Click OK to accept the change.
Then the contact appears in the group common directory.

can also import common contacts from an existing comma-delimited text file (file

format must be .csv). To produce a comma-delimited text file, refer to the instructions for

a program such as TXT.

To import a comma-delimited text file:

1.

2
3.
4

Log into the web portal as a group administrator.

Click on Utilities->Common Phone List.

Click on Import Phone List.

Click Browse to locate the CSV file from your local system.

The first line of the CSV file must define two columns “Name” and “Number”.

Group

|options:

Profile

wADSOFT bl -ome

Welcome [Logout

Common Phone List Import

5.

The

Import common phone list entries from a CSV file. For details about the CSV file, click on the Help link for this page.
= =

Select a Phone List File: Browse... |

| Hectleonferencing | l oK l Apply. l Cancel
tiliti

Click Apply to accept the change.
Then the contacts in the CSV file appear in the group common directory.

following shows an example of the contacts in an import list created in a text file

before the file is converted to a CSV file. Each value in an import list created in a text file

mus

Toa

> N

t enclose in quotation marks and separate by a comma.

"Name", "Number"
"Jane","8003"
"Jony","8001"
"Jane","8005"

"John", "8o09"

dd a contact to the personal directory:

Log into the web portal as a group administrator.
Click on Outgoing Calls->Personal Phone List.
Click Add.

Enter the name in the Name field.
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5. Enter the phone number in the Phone Number field.

BR«ADSOFT Help - ome
Group >Users : 4605 Welcome  [Logout]
Options: B
e Personal Phone List Add
rofile

\ncoming Calls Add a personal phone entry.
» Outqoing Calls Ok Cancel

Call Control

Calling Plans

Client Applications *Name: Lily

Messaqing *Phone Number: 4608

Senice Scripts

Utilities

6. Click OK to accept the change.
Then the contact appears in the user’s personal directory.

You can also import personal contacts from an existing comma-delimited text file (file

format must be .csv). For more information, refer to the introduction above.

For more information on BroadSoft directory, refer to BroadWorks Web Interface

Administrator Guide.

Configuring Yealink IP Phones
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The BroadSoft directory is configurable using template configuration files or via web

user interface.
To configure the BroadSoft directory using template configuration files:

1. Add/Edit BroadSoft directory parameters in template configuration files:

Parameter Description Valid Value

Enables or disables the IP
phone to display the group
directory.
bw_phonebook.group_enable ) Boolean
- - 0-Disabled
1-Enabled

The default value is 1.

Configures the group
directory name displayed
on the LCD screen of the %BWGROUP-1%

handset.

bw_phonebook.group_displayn

ame

The default value is Group.

Enables or disables the IP
phone to display the group
bw_phonebook.group_commo | common directory.

Boolean
n_enable 0-Disabled
1-Enabled
The default value is 1.
bw_phonebook.group_commo | Configures the group String within 99
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Parameter

Description

Valid Value

n_displayname

common directory name
displayed on the LCD screen
of the handset.

The default value is
GroupCommon.

characters

bw_phonebook.enterprise_ena
ble

Enables or disables the IP
phone to display the
enterprise directory.
0-Disabled

1-Enabled

The default value is 1.

Boolean

bw_phonebook.enterprise_disp

layname

Configures the enterprise
directory name displayed
on the LCD screen of the
handset.

The default value is
Enterprise.

%BWENTERPRISE-1
%

bw_phonebook.enterprise_com

mon_enable

Enables or disables the IP
phone to display the
enterprise common
directory.

0-Disabled

1-Enabled

The default value is 1.

Boolean

bw_phonebook.enterprise_com

mon_displayname

Configures the enterprise
common directory name
displayed on the LCD screen
of the handset.

The default value is

EnterpriseCommon.

String within 99

characters

bw_phonebook.personal_enab

le

Enables or disables the IP
phone to display the
personal directory.
0-Disabled

1-Enabled

The default value is 1.

Boolean

bw_phonebook.personal_displ

ayname

Configures the personal
directory name displayed
on the LCD screen of the
handset.

The default value is

Personal.

String within 99

characters
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Parameter Description Valid Value

Configures the interval (in

minutes) for the IP phone to
. ) . update the data of the Integer from 60 to
directory.update_time_interval .
BroadSoft directory from the 86400
BroadSoft server.

The default value is 1440.

The following shows an example of BroadSoft directory configurations in a
template file (e.g., %BWMACADDRESS%.cfg):

bw _phonebook.group enable = 1
bw_phonebook.group displayname = $BWGROUP-1%
bw phonebook.group common enable = 1

bw phonebook.group common displayname = GroupCommon

bw phonebook.enterprise enable = 1

o

bw_phonebook.enterprise displayname = %BWENTERPRISE-1%
bw_phonebook.enterprise common enable = 1
bw_phonebook.enterprise common displayname = EnterpriseCommon
bw phonebook.personal enable = 1
bw_phonebook.personal displayname = Personal

2. Upload template configuration files.

For more information, refer to Uploading Device Template Configuration Files on
page 17.
After the above configurations, the tags in the template configuration file will be
replaced by the actual parameter values. An example is shown as below:
bw phonebook.group displayname = Group
bw phonebook.enterprise displayname = Enterprise
After successful update, user can access the BroadSoft directory by pressing the

OK->Directory->Network Dir via the handset. The IP phone connects to load the

desired directory, and then displays contacts of this directory on the LCD screen.

You can also configure BroadSoft directory via web user interface at the path

Contacts->Network Directory.

BroadSoft Call Log

IP phones support to access the BroadSoft call log locally. The BroadSoft call log allows
users to view and dial the stored numbers in the following lists: Missed Calls, Received
Calls, Placed Calls and All Calls. Each call log entry contains call information such as
remote party identification, time and date.
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Configuring Yealink IP Phones

The BroadSoft call log is configurable using template configuration files or via web user

interface.
To configure the BroadSoft call log using template configuration files:

1. Add/Edit BroadSoft call log parameters in template configuration files:

Parameter Description Valid Value

Enables or disables
BroadSoft call log
feature.
bw_phonebook.call_log_enable . Boolean
- - T 0-Disabled
1-Enabled

The default value is 1.

The following shows an example of the BroadSoft call log configuration in a
template configuration file (e.g., % BWMACADDRESS%.cfg):

bw phonebook.call log enable = 1
2. Upload template configuration files.

For more information, refer to Uploading Device Template Configuration Files on
page 17.

After successful update, user can access the BroadSoft call log list by pressing the
History soft key via the handset. The IP phone connects to load the desired call log list,
and then displays call log entries of this list on the LCD screen.

You can also configure BroadSoft call log via web user interface at the path

Contacts->Network Directory.

Hunt Group

Hunt group allows incoming calls to a central phone number to be distributed among a

group of users according to a hunting policy.

Configuring the BroadSoft Server

To assign the hunt group service to the group:

1. Log into the web portal as a group administrator.

2. Click on Resources->Assign Group Services.
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3. In the Available Services box, select Hunt Group and click Add>.

BR-=ADSOFT e -t
Group Welcome [Logout

JOptions:
Profile

» Resources
Sevice Scripts

| ActAuncoges |
Call Center

Assign Group Services

Assign or UasSign group semices for the group

Available Services Assigned Services

Calling Plan
Meet Me Canferencing
Utiliies

A

Add >

Add AL 2

Remove A1

4. Click Apply to accept the change.
To add a hunt group:

1. Log into the web portal as a group administrator.
2. Click on Services->Hunt Group.
3. Click Add.

4. Set the parameters of hunt group:

The following shows an example:

Hunt Group ID: HuntGroup1
Name: Hunt Group
Calling Line ID Last Name: Group
Calling Line ID First Name: Hunt

5. Mark the desired radio box in the Group Policy field.

e  Circular: Incoming calls hunt through users in the order they appear in the list,
starting with the user following the last user to receive a call. When the search
reaches the end of the list, it loops back to the top and continues until it has
tried all users.

e  Regular: Incoming calls hunt through users in the order they appear in the list,

starting from the top one each time.

e  Simultaneous: Incoming calls alert all users at the same time. The call is
connected to the user who answers the call first.

e Uniform: Incoming calls hunt through all users in order, starting with the user

who most recently answered a call.

e  Weighted Call Distribution: Incoming calls are assigned to idle user based on
percentages you assign to the user. Users with a higher weight will be

assigned more incoming calls than users with lower weights.

6. Click Search to display all available users.
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7. Inthe Available Users box, select the desired user and click Add> to assign it to the

hunt group.

BR-ADSOFT Help -Home

Group Welcome [Logout
ugon> Hunt Group Add
Profile

Create a new hunt group.
Resources greup

Senvices OK Cancel
Service Scripts
AccbAuth Codes

Call Center * Hunt Group ID: HuntGrnum @ pbx.yealink.com ~

Calling Plan *Name: Huntgroup?

Meet-Me Conferencing

Utilities *Calling Line ID Last Name: Group * Calling Line ID First Name: Hunt
Department None « Language: English ~
Time Zone: (GMT+08:00) Asia/Shanghai -

[C] Allow Call Waiting on agents

Group Policy. ©) Circular @ Regular ) Simultaneous ) Uniform ) Weighted Call Distribution
r No Answer Settings
] Skip to nextagentafter 5 ~ Rings

[C] Forward call after waiting 0 seconds

Calls Forward to:

r Not Reachable Settings
[C] Enable Call Forwarding Mot Reachable

Calls Forward to

IMake Hunt Group busy when all available agents are not reachable

 Calling Line ID Settings
@ Use the system default CLID configuration (currently including the Hunt Group Name in the CLID)
() Customize the CLID for this Hunt Group:

Inciude the Hunt Group Name in the CLID

Enter search criteria below
User ID - Starts With ~
Available Users Assigned Users
12341,12341 (12341) - 4302,4302 {4302)

2413334621,2413334621 (2413334621) =1
2413334622,2413334622 (2413334622)

2413334623 2413334623 (2413334623)
2413334624,2413334624 (2413334624)

4301.4301 (4301)

4304 4304 (4304}

4303,4303 (4303)
4305,4305 {4308)

8
9
10. Click on Addresses.
1

Click OK to accept the change.

Select the hunt group added above and click Edit.

-

. Select the phone number from the Phone Number field.

12. Enter the extension in the Extension field.

BR:ADSOFT

Help -Home
Group =Hunt Groups : HuntGroup1 Welcome [Logoui

Hunt Group Addresses

Addresses allows you to view and maintain your phone number and other identities that are used to make and receive calls.
= T

Phone Number: 4615 « Aclivated

Calling Plans

Extension: 4615

Aliases : sip @ pbx.yealink.com -
sip: @ pbx.yealink.com -
sip @ Pbx.yealink.com

13. Click Apply to accept the change.

45



IP Phones Deployment Guide for BroadWorks Environment

To configure weighted call distribution:

You can configure this feature only if you mark the radio box of Weighted Call
Distribution in the Group policy field when adding the hunt group.

1. Log into the web portal as a group administrator.

2. Click on Services->Hunt Group.

3. Select the hunt group added above and click Edit.

4. Click on Profile->Weighted Call Distribution.
5

Enter the desired percentage values in the corresponding fields.

BRADSOFT Help -Home

Group =Hunt Groups : HuntGroup?1 Welcome [Logout

Weighted Call Distribution

Configure assigned users' weighted call distribution allocation. With weighted call distribution, any incoming calls to the Hunt Group are dispatched to the
agents randomly according to specified percentage weight of each agent.

= T

* 4302, 4302 (4302 3 %

Calling Plans

=4303, 4303 (4303); 33 %

= 4305, 4305 (4305); 34 %

Cancel

6. Click Apply to accept the change.

For more information on hunt group, refer to BroadWorks Web Interface Administrator
Guide.

Call Park

Call park allows a user to park a call against an extension and then retrieve it on
another phone. If a parked call is not retrieved after the pre-configured time, the
BroadWorks server will alert the designated user depending on how the server is
configured. Group call park hunts for the first available user in the call park group and

parks the call there.

WS52P IP DECT phones only support to park a call and retrieve the parked call by dialing

the FAC (feature access code).

Configuring the BroadSoft Server

To assign the call park service to the group:

1. Log into the web portal as a group administrator.

2. Click on Resources->Assign Group Services.
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3. Inthe Available Services box, select Call Park and click Add>.

BR-=ADSOFT

Group

Help - Home

Welcome  [Logoui
I

.
Assign Group Services

Assign or unassign group services for the group

. o

Joptions:

Serice Scripts
Acotifuth Codes

Available Services

Call Center

Calling Plan
Meet Me Canferencing
Utiliies

_ox B s |

4. Click Apply to accept the change.

To add a call park group:

Assigned Services

-~
T Account/Authorization Codes
Attendant

Add 11 )
Energency Zomes

Erhanced Outgoing Calling Plan
Group Paging

a1

1. Log into the web portal as a group administrator.

2. Click on Services->Call Park.

The call park parameters are described as below:

Parameter

Description

Settings for Call Park

Determines where the parked call is sent when

the recall timer expires.

Alert parking user only: Alerts the user who
parked the call only.

Alert parking user first, then alternate user:
Alerts the user who parked the call first, and
then alerts the alternate user if the parking

user does not answer the recall.

Alert alternate user only: Alerts the alternate

user only.

The setting is initially set to Alert parking user
only. You can only change the setting after you

assign an alternate recall user.

Settings for Group Call Park

Display Timer: Specifies how long the server
waits before automatically releasing the call. It

is used to park a call with Group Call Park.

Enable Parked Destination Announcement:
Determines whether to announce to the
parking user the extension of the destination
against which the call has been parked.

Settings for All Parked Calls

Ring Pattern for Recalled Calls: This allows
users to distinguish between new and recall

calls.
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Parameter Description

Recall Timer: Configures the time after which
the parked call is recalled.

Alert Alternate Recall User Wait Time:
Configures the time after which the alternate
user is called (if configured).

3. Make the desired change.

If you want alert alternate user, you need to first click Select Alternate Recall User to
select the desired hunt group when adding call park group.

*ADSOFT el -Home

Group Welcome [Logout
options:
L= Call Park

Profile

Create a new call park group and manage existing call park groups. Defining call park groups allows users in these groups to park calls on that group. Can also

Resources configure Call Park settings far your group's users.

» Services

Acct/Auth Codes

| =—— @@ | ~ Settings for Call Park

| CalingPlan | Alternate Recall User: Select Alternate Recall User

| Uestlle Conferencing | Recall To: @ Alert parking user only
LUtilities

Alert parking user first, then alternate user|

Alert alternate user only

 Settings for Group Call Park
Display Timer: & v seconds
Enable Parked Destination Announcement

~ Settings for All Parked Calls

Ring Pattern for Recalled Calls: Normal -
Recall Timer: 45 seconds
Alert Alternate Recall User Wait Time: 45 seconds
Group Call Park Name [&] Edit

Mo Entries Present

oK Apply Add Cancel

Click Add.
Enter the desired group name in the Group Name field.

Click Search to display all available users.

4.
5.
6.
7.

In the Available Users box, select the desired user and click Add> to assign the

user to the call park group.
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8.

Repeat the step 7 to add more users.

BR«+ADSOFT

Semvice Scripts

Help - Home
Group Welcome  [Logout
Options:
= Group Call Park Add
@ Create a new Group Call Park group.
» Services

Acct/Auth Codes

Call Center

Calling Plan
Meet-Me Conferencing
Utilities

Proﬂ\e Altemate Recall User

* Group Name: Park Group1

Recall To: @ Alert parking user only
Alert parking user first, then alternate user

Alert alternate user only

Enter search criteria below

User ID - Starts With ~

Assigned Users

Available Users

4604,4604 (4604)
4605,4605 (4605)
)
)

4602,4602 (4602)
46034603 (4603)

46064606 (4606
4609.4609 (4609

9. Click Apply to accept the change.

To assign alternate recall users for the call park group:

1. Log into the web portal as a group administrator.

AN T o

Select>.

Click on Services->Call Park.

Select the desired call park group and click Edit.
Click on the Alternate Recall User tab.

Click Search to display all available hunt groups.

In the Available Hunt Groups box, select the desired hunt group, and then click

Make sure at least one hunt group has been pre-configured on the BroadWorks

server.

BR:*ADSOFT

Help -Home

Group Welcome [Logout
Options: N

= Group Call Park Modify

Frofile
— ... ... W Selectahunt group as the alternate user to recall.

Resources
B Services

Senvice Scripts

Acct/Auth Codes
Call Center
Calling Plan

Meet-Me Conferencing

Utiliies

= T
Prof'lle A\Iernale Recall User

Enter search criteria below

‘Selected Hunt Group

Last Name [Rd Starts With ~

Available Hunt Groups

Candy (11111)
hunt group (4387)
my hunt group (4386)

Select>
Remove <

Huntgroup1 (HuntGroup1)

I T
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7. Click Apply to accept the change.
To check the Call Park and Call Park Retrieve FACs:

1. Log into the web portal as a group administrator.
Click on Utilities->Feature Access Codes.

Check the Call Park and Call Park Retrieve FACs.

> 0N

Select the desired FAC used by marking the desired radio box (Service Provider
FAC codes or Group FAC codes).

If Group FAC codes is selected, administrator can modify the code in the Main
(Required) field or enter an alternate code in the Alternate (Optional) field.

For more information on call park, refer to BroadWorks Web Interface Administrator
Guide.

Instant Group Call

Instant group call allows users to instantly call a pre-defined group of users for an ad
hoc conference call by dialing a phone number or an extension. The originators can be

part of the same group or external users.

Configuring the BroadSoft Server

To assign the instant group call service to the group:

1. Log into the web portal as a group administrator.
2. Click on Resource->Assign Group Services.

3. Inthe Available Services box, select Instant Group Call and then click Add>.

BR*ADSOFT e e
Group Welcome  [Logout
1

Options:
Froflle

Assign Group Services
Assign or unassign aroup senices for the group,

= Avallable Services Assigned Services
Call Center

Group Paging

Calling Plan 7]
I 1:

MeetMe Conferencing.
Utlifies e 7

3
On H

e
Muszic On Hold - Video

Renove AL Outgoing Calling Plan

Cancal

4. Click Apply to accept the change.
To add an instant group call:

1. Log into the web portal as a group administrator.
2. Click on Services->Instant Group Call.

3. Click Add.
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4, Setthe parameters of the instant group.

The following shows an example:
Instant Group Call ID: Instantgroup1
Name: Instant Group
Calling Line ID Last Name: Group
Calling Line ID First Name: Instant
Instant Group Call User List: 4602

4603

4605

Group Welcome [Logout

Options: Instant Group Call Add

Profile

Create a new instant group call
Resources

Senvices OK Cancel
Senvice Seripts
AcctiAuth Codes

Call Center *Instant Group Call ID: Instantgroup1 @ Ppbx.yealink.com =
Calling Plan *Name: Instant Group
leet-We Conferencing
Utilities *Calling Line ID LastName: Group *Calling Line 1D FirstName: Instant
Department None - Language: English -
Time Zone: (GMT+08:00) Asia/Shanghai -
[7] Enable Maximum Call Time for Unanswered Calls Minutes
 Instant Group Call User List
Specify Phone Number/SIP_URI
4602
4603
4605

Click OK to accept the change.
Select the instant group call added above and click Edit.
Click on Addresses.

Select the phone number from the pull-down list of Phone Number.

Y ©® N o o

Enter the extension in the Extension field.

Group =Instant Group Call : Instantgroup1 Welcome [Logout

‘:"':r";‘e Instant Group Call Addresses

Calling Plans Addresses allows you to view and maintain your phone number and other identities that are used to make and receive calls.
Lalling Flans

= I

Phone Number: 4611 -~ Aclivated

Extension: 4611

Aliases : sip @ pbx.yealink.com +
sip @ pbx.yealink.com +
sip @ pbx.yealink.com +

I T

10. Click Apply to accept the change.

For more information on instant group call, refer to BroadWorks Web Interface
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Administrator Guide.

Authentication

Authentication provides authentication of sessions for SIP IP phones to prevent
unauthorized access to the system. Authentication is performed on registrations (SIP
REGISTERs), redirections (SIP REFERs) as well as incoming calls (SIP INVITEs). Standard
MD5 digest authentication is used.

Configuring the BroadSoft Server

52

To use authentication service, make sure the authentication service is assigned to the

user, the user ID and password for authentication are configured.
To assign the authentication service to a user:

1. Log into the web portal as a group administrator.

2. Click on Profile->Users->Search to display all existing users.

3. Select the desired user (e.g., 4605).

4. Click on Assign Services.

5. Inthe Available Services box, select Authentication and then click Add>.

Group ~Users* 4605 Welcome (Logou

Options:

» Profile
ncoming Calls
Qutgoing Calls
Calling Plans
Client Applications
Messaaging
Senice Scripls
Utilities

Assign Services

Assign Services allows you to assign or unassign services and service packs for a user. If a service or service pack is unassigned the service data that has
been fillad outwill be lost.

Available Service Packs User Service Packs

Add >

Remove <

Add All ==

Available Services User Services
Basic Call Logs Add > Alternate Numbers -
Call Center - Premium Anonymous Call Rejection El
Remove < Authentication

Automatic Callback

Automatic Hold/Retrieve

Barge-in Exempt

BroadTouch Business Communicator Desktop - Video
BroadTouch Business Communicator Mobile - Video
BroadTouch MobileLink

BroadWorks Anywhere

BroadWorks Mability =

= 1

Add All ==

o o
@ @
] ]
2 2
& &
= =

6. Click Apply to accept the change.

To configure the user ID and password for a user:

1. Log into the web portal as a group administrator.

2. Click on Profile->Users->Search to display all existing users.
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3. Select the desired user (e.g., 4605), who has been assigned the authentication
service.

4, Click on Utilities->Authentication.
5. Enter the user ID in the Authentication User Name field.

6. Enter the password in the Type new authentication password and Re-type new
authentication password fields.

BRADSOFT belp -Home
Group =Users : 4605 Welcome [Logoug
Options: - .
— Authentication
—I Call Authentication allows you to use encryption to safely determine thatthe user at a given phone is who they say they are. This helps prevent hijacking of senice in
Incoming Calls r
% hosted communications netwaorks. The user name and password must match the user name and password configured on your phone, or in your phone's
Outgoing Calls configuration file.
Call Contral
TN | WS TR s

Client Applications
Messaging
Senice Scripts

» Utilities *Type new authentication password: ssesessss

* Authentication User Name: 4605

* Re-fype new authentication password

7. Click Apply to accept the change.

For more information on authentication, refer to BroadWorks Web Interface
Administrator Guide.

Authorization/Account Codes

Authorization/Account codes allow users to use authorization and account codes for
outgoing calls. Authorization code allows authorization of calls made outside the group
by prompting users for an authorization code. Calls are not connected unless a valid
code is entered. Account code allows tracking of calls made outside the group by
prompting users for an account code. Account codes have a fixed length, as configured
by the group administrator. When prompted for an account code, the user is informed of

the digits to enter, which match the length of the account codes.

Configuring the BroadSoft Server

To assign the authorization/account codes service to the group:

1. Log into the web portal as a group administrator.

2. Click on Resources->Assign Group Services.
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3.
Add>.

In the Available Services box, select Authorization/Account Codes and then click

BR+ADSOFT

joptions:

Profile
»

Mest-Me Conferencing
Utilfies

4.

Heln - Home
Welcome  [Logout

Assign Group Services

Assign or unassign group services for the aroup.

Available Services

Assigned Services

huto Attendant - Video

Call Caparity Nanagoment
Call Park
Call Pickup
Custom Ringback Group

Custom Ringback Group - Video
Emergency Zones

Enhanced Outgoing Calling Plan
Group Paging v

Click Apply to accept the change.

To configure the type of code for the group:

Log into the web portal as a group administrator.
Click on Acct/Auth Codes->Administration.

Set the parameters of account/authorization codes.

The following shows an example:

Type:

Authorization Code

Number of Digits: 4

Allow Local and Toll-Free Calls without Account/Authorization Code: Selected

Restricted Users:

4604
4605

4602

BR«+ADSOFT
Group

Options:

Profile
Resources

Semvices

Service Scripls
» AcctAuth Codes

Call Center

Calling Plan

Help - Home
Welcome [Logout

Administration

Set up the group and users to use authorization and account codes for outgoing calls

Using account codes enables the tracking of calls made outside the group by prompting users for an account code. However, codes are notvalidated. The
account codes you define are presented to the userin a read-only screen on their CommPilot Portal

Authorization codes are used to perform authorization of calls made outside the group by prompting users for an authorization code. Calls are not connected
unless a valid code is entered.

Meet-Me Conferencing

Utiliies

e ———

Type: |0 #ccount Code @ Authorization Code () Deactivated

Number of Digits: 4
Allow Local and Toll-Free Calls withaut Account’Authorization Code

Enter search criteria below

User ID - Starts With «

Restricted Users

Hon-restricted Users

4603,4603 (4603)
4606,4606 (4606)
4609,4609 (4609)

46024602 (4602)
4604.4604 (4604)
46054605 (4605)

Lin.Jin (4610}

=
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4. Click Apply to accept the change.
To configure the authentication code:

1. Log into the web portal as a group administrator.

2. Click on Acct/Auth Codes->Codes Management.

3. Click Add to add the authentication codes.

4. Enter the configured number of digits in the Account/Authentication Code field.
5

Enter the desired description in the Description field.

BR+ADSOFT v - s
Group Welcome  [Locout

joptions:
Profile

Codes Management Add

Add new aceount or autharization codes.

Senices o

Cancsl

» AcctAuth Codes
Call Center * Accountiuthorization Gode: 1111
Calling Plan Description: codel
Meel-hie Conferencing

Utlities

6. Click OK to accept the change.

For more information on authorization/account codes, refer to BroadWorks Web
Interface Administrator Guide.

Call Waiting

Call waiting allows users to receive another call while already engaged in a call. Call
waiting tone enables the IP phone to play a short tone when receiving another incoming

call during a call. Call waiting tone works only if call waiting is enabled.

Configuring the BroadSoft Server

To assign the call waiting service to a user:

1. Log into the web portal as a group administrator.
2. Click on Profile->Users->Search to display all existing users.

3. Select the desired user (e.g., 4605).
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4. In the Available Services box, select Call Waiting and then click Add>.

BR:ADSOFT

Call Transfer

Charge Number
Classmark

Client Call Control
CommPilot Call Manager

Add All ==

Help -Home
Group »Users : 4605 Welcome [Logouf
Options: = .
v pron Assign Services
rofile

. Call Assign Senices allows you to assign or Unassign senvices and service packs for a user. If a senice or senice packis Unassigned the service data that has

Incoming Calls
_ ncomnatals  Mobeenfilled outwill be lost

Outgoing Calls

Calling Plans

Client Applications Available Service Packs User Service Packs

Llient Applications

Messaging

S Add =

Senice Scripts itz

Utiliies

T

Add All ==
Available Services User Services
Basic Call Logs Add = Calling Number Delivery -
Call Center - Premium Calling Party Category
Call Me Now
Remave <
Gal Notty =
Call Return

Apply Cancel

5. Click Apply to accept the change.
To configure call waiting for the user:

Log into the web portal as a group administrator.
Click on Profile->Users->Search to display all existing users.
Select the desired user (e.g., 4605), who has been assigned the call waiting service.

Click on Call Control->Call Waiting.

o & 0N

Mark the On radio box in the Call Waiting field.

Group =Users : 4605

Options:

Profile
ncoming Calls

Cutqoing Calls

Help -Home

Welcome [Logout

Call Waiting

Call Waiting allows you to receive another call while you are on the phone. You can turn it on or off for all calls and then selectively turn it back on or off using the
feature access codes.

Call Control
Calling Plans

Client Applications
Messaging
Senice Scripts

Utiliies

=

Call Waiting: {® bn ©)

off
[] Disable Calling Line ID Delivery on Call Waiting

6. Click Apply to accept the change.

For more information on call waiting, refer to BroadWorks Web Interface Administrator
Guide.

Configuring Yealink IP Phones

Call waiting and call waiting tone are configurable using template configuration files,

via web user interface or phone user interface.
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To configure call waiting and call waiting tone using template configuration files:

1. Add/Edit call waiting and call waiting tone parameters in template configuration

files:

Parameter

Description

Value

call_waiting.enable

Enables or disables call
waiting.

0-Enabled

1-Disabled

The default value is 1.

%CALL_WAITING _
BINARY%

call_waiting.tone

Enables or disables call
waiting tone.
0-Enabled

1-Disabled

The default value is 1.

Boolean

The following shows an example of call waiting configurations in a template
configuration file (e.g., y000000000025.cfg):

call_waiting.enable = %CALL_WAITING_BINARY%

call_waiting.tone = 1

2. Customize the static tag on BroadWorks. The tag name is %

CALL_WAITING_BINARY % and the tag value is 1.

For more information, refer to Customizing a Static Tag on page 15.

3. Upload template configuration files.

For more information, refer to Uploading Device Template Configuration Files on

page 17.

After the above configurations, the tag in the template file will be replaced by the

actual parameter value. An example is shown as below:

call_waiting.enable = 1
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After successful update, user can find the web user interface of the IP phone is

similar to the one as shown below:

-
Yealink | ws»»
Account Network Contacts Security
General Information TE
Preference
Enabled -
Features clvEng L7 | Call waiting
- This call feature allows your
Gall watting Tone Enabled 0 phone to accept other incoming
Linel Emergency Numbers ,7 o calls during the conversation.
Line2 Return code when refuse 486 (Busy hera) - 9
Line3 Return Code When DND 480 (Temporarity not av - 0
Enable SemiAttend Transfer Enabled AN ]
Line4
Blind Transfer OnHook Disabled - @
Line5
e Attend Transfer OnHook Disabled - @
RFC 2543 Hold Disabled - 0
Upgrade
Use Qutbound Proxy in Dialog Enabled - 0
Auto Provision
180 Ringing Disabled - 0
Configuration Save Cal Log Enzbled - @
Dial Plan Suppress DTMF Display Disabled - 0
Suppress DTMF Display Dela Disabled -
(7Ts pp play Delay 7]
Login Timeout(1~1000)(Minutes) 3 0
Tones
Feature Synchronization Enabled - 0
L DHCP Hostname SP-w52P @
[ Confim |

Diversion Inhibitor

Diversion inhibitor prevents calls from being redirected by the callee. When receiving
the INVITE message sent by BroadWorks with “diversion-inhibited” in the diversion or
history-info header, the callee is forbidden to forward the call even if call forward is
enabled on the callee’s phone. The user can activate diversion inhibitor by dialing the
feature access code (FAC) as a dial prefix when making a call.

Configuring the BroadSoft Server

To assign the diversion inhibitor service to a user:

1. Log into the web portal as a group administrator.
Click on Profile->Users->Search to display all existing users.

Select the desired user (e.g., 4603).

> 0N

Click on Assign Services.
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5. In the Available Services box, select Diversion Inhibitor and then click Add>.

Group =Users : 4603 Welcome [Logout

Options: Assign Services

B Profile
Incoming Calls Assign Services allows you to assign or unassign services and service packs for a user. If a service or senvice pack is unassigned the service data that has
Incoming Calls ;

————— W been filled out will be lost

Qutgoing Calls
Calling Plans
Client Applications
Messaqing

Available Service Packs User Service Packs

Add =

Senice Scripts
Utilities

Remove <

Add All ==

Available Services User Services

Add = Custom Ringback User -
Custom Ringback User - Call Waiting

Custom Ringback User - Video

Directed Call Pickup

Directed Call Pickup with Barge-in -
T ——
Do Not Disturb

Enhanced Call Logs

External Calling Line ID Delivery

External Custom Ringback

Fax Messaging <2

Remave <

Add All ==

2l D
Ey o
3 3
g a
& s
z z

oK Apply Cancel

6. Click Apply to accept the change.
To check the Diversion Inhibitor FAC:

1. Log into the web portal as a group administrator.
Click on Utilities->Feature Access Codes.

Check the Diversion Inhibitor FAC.

> N

You can select the desired FAC used by marking the desired radio box (Service
Provider FAC codes or Group FAC codes).

If Group FAC codes is selected, administrator can modify the code in the Main
(Required) field or enter an alternate code in the Alternate (Optional) field.

For more information on diversion inhibitor, refer to BroadWorks Web Interface
Administrator Guide.

Do Not Disturb

Do Not Disturb (DND) allows all incoming calls to be rejected automatically. The
BroadWorks server provides an option to play a ring splash reminder on the IP phone

when the incoming call is rejected.

Configuring the BroadSoft Server

To assign the DND service to a user:

1. Log into the web portal as a group administrator.

2. Click on Profile->Users->Search to display all existing users.
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3. Select the desired user (e.g., 4604).
4. Click on Assign Services.

5. In the Available Services box, select Do Not Disturb and then click Add>.

Group =Users : 4604 Welcome [Logout

Options:

» Profile
Incoming Calls
Outgoing Calls
Calling Plans
Client Applications
Messaging
Service Scripls
Utilities

Assign Services

Assign Services allows you to assign or unassign services and service packs for a user. If a service or senvice pack is unassigned the service data that has
been filled out will be lost

Available Service Packs User Service Packs

Add =

Remove =

Add All ==

Available Services

User Services

Basic Call Logs Add > Connected Line Identification Restriction -
Customer Originated Trace

Custom Ringback User

Custom Ringback User - Call Waiting

Custom Ringback User - Video

Directed Call Pickup

Directed Call Pickup with Barge-in

Diversion Inhibitor

peoi
Enhanced Call Logs

External Calling Line ID Delivary =

Remove =

[

o Fil
B @
E E
2 2
5 &
z z

6. Click Apply to accept the change.
To configure DND for the user:

1. Log into the web portal as a group administrator.

Click on Profile->Users->Search to display all existing users.

Select the desired user (e.g., 4604), who has been assigned the DND service.
Click on Incoming Calls->Do Not Disturb.

Mark the On radio box in the Do Not Disturb field.

AN o

Check the Play Ring Reminder when a call is blocked checkbox.

Group ~Users : 4604 Welcome [Logou]
Options: N
= Do Not Disturb
rofile
Allows you to send your calls directly to your voice messaging box without ringing your phene. In addition, you can make your primary phone emit a short ring
» Incoming Calls burst ta infarm you when the call is being sent to voice messaging by using the Ring Reminder. This is important when you have forgotten the service is turned

Qutgoing Calls on and you are atyour phone waiting to receive calls.
Call Control
Client Applications
Messaaing Do Not Disturb: @ On ©) Of

Service Scripts -
Play Ring Reminder when a call is blocked
Utlies K

oK Apply Cancel

7. Click Apply to accept the change.

For more information on DND, refer to BroadWorks Web Interface Administrator Guide.
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Configuring Yealink IP Phones

The DND mode is configurable using the configuration files or via web user interface.
To configure DND using template configuration files:

1. Add/Edit DND parameters in template configuration files:

The “X” in the parameter is an integer which specifies the line number on the IP
phone. If the user (e.g., 4604) is the second user assigned to the device profile,
replace “X” by “2".

Parameter Description Value

Enables or disables DND on a

per-account basis for account

X.

0-Disabled

1-Enabled %BWDND-BINARY-
account.X.dnd.enable .

It takes effect only if the X%

parameter

“features.dnd_mode” is set to
1.

The default value is 0.

The following shows an example of DND configurations for account 2 in a template
configuration file (e.g., %BWMACADDRESS%.cfg):

account.2.dnd.enable = %BWDND-BINARY-2%
2. Upload template configuration files.

After the above configurations, the tags in the template file will be replaced by the

actual parameter values. An example is shown as below:

account.2.dnd.enable = 1
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After successful update, user can find the web user interface of the IP phone is similar to

the one as shown below:

-
Yealink | ws» S
Account Network
forward: @ NOTE
Preference
Always © on® o @ =]
Features This feature allows you to
Tt 0 forward an incoming call to
Linel - 5 another phone number.
Busy Toon@off @ ?
- Target
Line2 Target 0 The number to which the
. } incoming calls will be forwarded.
T No Answer Toon@off @ @t
After Ring Time(seconds) 0 A 0 The code that wil be sent to
Line4 PBX when it is switched On.
Target ,7 @ Off Cod
5 e
Line5 The code that wil be sent to
PBX when it is switched Off.
DND:
Upgrade
DHND ® on © off @
Auto Provision
Configuration Ancnymous Call:
Dial Plan Anonymous code © on @ off @
Anonymous rejection code ® ®
R v rej on @ off @
Voice Mail: [7]
Tones
TR0O69

Call Forward

Call forward allows users to redirect incoming calls to another destination. When an
incoming call is forwarded, the BroadWorks server sends the INVITE request containing
the Diversion or History-info header to the destination party. The following describes
three call forward behaviors:

e  Call Forwarding Always: Incoming calls are immediately forwarded.

e  Cdll Forwarding Busy: Incoming calls are immediately forwarded if the IP phone is

busy.

e  Cdll Forwarding No Answer: Incoming calls are forwarded if not answered after a

period of time.

Configuring the BroadSoft Server

To assign the call forward service to a user:

1. Log into the web portal as a group administrator.
Click on Profile->Users->Search to display all existing users.

Select the desired user (e.g., 4602).

> 0D

Click on Assign Services.
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5. In the Available Services box, select Call Forwarding Always, Call Forwarding Busy

and Call forwarding No Answer and then click Add>.

Group =Users : 4602

Options:

Help - Home
Welcome [Logout

B Profile

Outgoing Calls

Incoming Calls

Assign Services

Assign Services allows you to assign or unassign services and service packs for a user. If a senvice or senvice pack is unassigned the semvice data that has
been filled out will be lost

Call Control

= T

Calling Plans

Client Applications

Messaaing
Sevice Scripls
Utiliies

Available Service Packs User Service Packs

Add >

Remove <

Add All ==

Available Services User Services

Add >

Basic Call Logs
Call Center - Premium

BroadWorks Anywhere -
BroadWorks Mability

Remove <

Call Forwarding Mot Reachable

Call Forwarding Selective

Calling Line ID Blocking Qverride

Calling Line ID Delivery Blocking

Calling Mame Delivery >

1= 1

Add All ==

) o
F F
=l =l
E E
H &
z z

6. Click Apply to accept the change.

To configure call forwarding always for a user:

1. Log into the web portal as a group administrator.

2. Click on Profile->Users->Search to display all existing users.

3. Select the desired user (e.g., 4602), who has been assigned the call forward

service.

4. Click on Incoming Calls->Call Forwarding Always.

5. Mark the On radio box in the Call Forwarding Always field.

6. Enter the destination number or SIP-URI in the Calls Forward to phone number /

SIP-URI field.

7. Check the Play Ring Reminder when a call is forwarded checkbox.

Group =Users : 4602

Options:

Profile
B Incoming Calls
Outgoing Calls

Call Control
Calling Plans

Help - Home
Welcome [Logout

Call Forwarding Always

Call Forwarding Always allows you ta forward all your incoming calls to a different phone number or SIP-UR, such as your home office or cell phone. You can
also make your primary phone emit a short ring burst to inform you if you are next to your phone when the call is forwarded by using the Ring Reminder. This is
important when you have forgotten the service is turned on and you are at your primary phone waiting to receive calls. Note that the address (phone number or
SIP-URI) you forward your calls to must be permitted by your outgoing calling plan. You can also setthe phone number or SIP-URI to forward to using the voice
portal or on the phone using the feature access code

Client Applications

Messaging
Service Scripls

Utiliies

=

Call Forwarding Always: @ On () Off

*Calls Forward to phone number / SIP-URL. 4605

Play Ring Reminder when a call is forwarded

8. Click Apply to accept the change.
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To configure call forwarding busy for a user:

1. Log into the web portal as a group administrator.
2. Click on Profile->Users->Search to display all existing users.

3. Select the desired user (e.g., 4602), who has been assigned the call forward

service.
4. Click on Incoming Calls->Call Forwarding Busy.
5. Mark the On radio box in the Call Forwarding Busy field.

6. Enter the destination number or SIP-URI in the Calls Forward to phone number /
SIP-URI field.

BR«ADSOFT Help -Home

Group =Users : 4602 Welcome [Logout

Options:

Call Forwarding Busy

Profile

- Call Forwarding Busy allows you to forward all your incoming calls to a different phone number or SIP-URI if your phone is currently busy. Use this service
Incoming Calls when you would rather have a secretary or co-worker receive the call instead of the caller being sentte your voice messaging box. Mote that the address (phone|
Outqoing Calls number or SIP-URI) you forward your calls ta must be permitted by your outgoing calling plan. You can also setthe phane number or SIP-URI ta forward to
Call Control using the feature access code.

Calling PI,
Client Applications

Messaging
Senice Scripts Call Forwarding Busy: @) On () Off
Ulilities

* Calls Forward to phone number / SIP-URI: 4603

7. Click Apply to accept the change.

To configure call forwarding No Answer for a user:

1. Log into the web portal as a group administrator.
2. Click on Profile->Users->Search to display all existing users.

3. Select the desired user (e.g., 4602), who has been assigned the call forward

service.
4. Click on Incoming Calls->Call Forwarding No Answer.
5.  Mark the On radio box in the Call Forwarding No Answer field.

6. Enter the destination number or SIP-URI in the Calls Forward to phone number /
SIP-URI field.

7. Select the desired value from the pull-down list of Number of rings before

forwarding.

BRADSOFT Help - Home

Group =Users : 4602 Welcome [Logout

Options:
Profile
» Incoming Calls
Outgoing Calls
Call Control
Calling Plans
Client Applications
Messaging
Service Scripts
Utilities

Call Forwarding No Answer

Call Forwarding No Answer allows you to forward all your calls to a different phone number or SIP-URI when you do not answer your phone. Use this senvice
when you would rather have a secretary or co-worker receive the call instead of the caller being sent to your voice messaging box if you miss a call

= T

Call Forwarding No Answer: @ On () Off

* Calls Forward to phone number / SIP-URI: 4EUE|

Number of rings before forwarding: 3 -

Apply Cancel

8. Click Apply to accept the change.
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For more information on call forward, refer to BroadWorks Web Interface Administrator
Guide.

Configuring Yealink IP Phones

There are two call forward modes: Phone (default) and Custom. The call forward mode
and the presentation of diversion information are configurable using the configuration
files or via web user interface. Call forward is configurable using the configuration files,

via web user interface or phone user interface.
To configure call forward using template configuration files:

1. Add/Edit call forward parameters in template configuration files:

The “X" in the parameter is an integer which specifies the line number on the IP
phone. If the user (e.g., 4602) is the second user assigned to the device profile,
replace “X” by “2".

Parameter Description Value

Enables or disables always
call forward on a per-account
basis for account X.
0-Disabled

account.X.always_fwd.
- 1-Enabled Boolean

enable .
It takes effect only if the

parameter
“features.fwd_mode” is set to
1.

Configures the destination

number of always call
forward for account X.
account.X.always_fwd. | It takes effect only if the String within 32
target parameter characters
“features.fwd_mode” is set to
1.

The default value is blank.

Enables or disables busy call
forward on a per-account
basis for account X.
0-Disabled
account.X.busy_fwd.en | 1-Enabled

able It takes effect only if the Boolean
parameter
“features.fwd_mode” is set to
1.

The default value is 0.
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Parameter

Description

Value

account.X.busy_fwd.tar

Configures the destination
number of busy call forward
for account X.

It takes effect only if the

String within 32

get
parameter characters
“features.fwd_mode” is set to
1.
The default value is blank.
Enables or disables no
answer call forward on a
per-account basis for account
X.

) 0-Disabled

account.X.timeout_fwd.

1-Enabled Boolean

enable

It takes effect only if the
parameter
“features.fwd_mode” is set to
1.

The default value is 0.

account.X.timeout_fwd.

timeout

Configures ring times (N) to
wait before forwarding
incoming calls for account X
Incoming calls are forwarded
when not answered after N*6
seconds.

It takes effect only if the
parameter
“features.fwd_mode” is set to
1.

The default value is 2.

Integer from 0 to
20

account.X.timeout_fwd.

Configures the destination
number of no answer call
forward for account X.

It takes effect only if the

String within 32

target parameter characters
“features.fwd_mode” is set to
1.
The default value is blank.
Enables or disables the IP
features.fwd_diversion | phone to present the
- Boolean

_enable

diversion information when

the call is forwarded to your IP
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Parameter

Description

Value

phone.

0-Disabled
1-Enabled
The default value is 1.

The following shows an example of always call forward configurations for account 2

in a template configuration file (e.g., % BWMACADDRESS%.cfg):
account.2.always_fwd.enable = %BWFAC-CFA- BINARY-2%
account.2.always_fwd.target = 4606

2. Upload template configuration files.

For more information, refer to Uploading Device Template Configuration Files on

page 17.

After the above configurations, the tags in template configuration files will be replaced

by the actual parameter values. An example is shown as below:

account.2.always_fwd.enable = 1

After successful update, user can find the web user interface of the IP phone is similar to

the one as shown below:

Yealink | ws»

Preference

Features

Linel
Line2
Line3
Line4

Line5

Upgrade

Auto Provision
Configuration
Dial Plan

Voice

Tones

TROG9

Account Network

forward: @
Always © on @ off @
Target ’7
Busy @ on © off @
Target 4606
No Answer © on @ off @
After Ring Time(seconds) 0 -
Target
DHD:
DND ©on @ off @
Anonymous Call:
Anonymous code @ on © o @
Anonymous rejection code ©on @ off @
Voice Mail:

NOTE

Forward

This feature allows you to
forward an incoming call to
another phone number.

Target
The number ta which the
incoming calls will be forwarded.

On Code
The code that wil be sent to
PBX when it is switched On.

Off Code
The code that wil be sent to
PBX when it is switched Off.

Alternate Numbers

Alternate numbers allow a user to have up to ten alternate phone numbers or

extensions in addition to the main phone number or extension. The user can be reached

through any of the phone numbers or extensions. Calls to the main number result in the

normal ring pattern. Calls to an alternate number result in a distinctive ring pattern

configured for that number. One of four distinctive ring patterns can be assigned to
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Note

each alternate phone number or extension.

WS52P IP DECT phones do not support to play distinctive ring pattern for the alternate
number.

Configuring the BroadSoft Server
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To assign the alternate numbers service to a user:

1. Log into the web portal as a group administrator.

2. Click on Profile->Users->Search to display all existing users.

3. Select the desired user (e.g., 4605).

4. Click on Assign Services.

5. In the Available Services box, select Alternate Numbers and then click Add>.
Group ~Users : 4605 Welcome [Logout]

Options:

» Erofile
Incoming Calls
Quigoing Calls
Calling Plans

Client Applications

Messaging

Senvice Scripts

Utilities

Assign Services

Assign Services allows you to assign or unassign services and service packs for a user. If a service or service pack is unassigned the service data that has
been filled out will be lost

Available Service Packs User Service Packs

Add >

Remave <

Add All ==

Available Services User Services

Anonymous Call Rejection

Authentication

Automatic Callback

Automatic Hold/Retrieve

Barge-in Exempt

BroadTouch Business Communicator Desktop - Video
BroadTouch Business Communicator Mobile - Video
BroadTouch MobileLink

BroadWorks Anywhere

BroadWorks Mobility 52

Basic Call Logs Add >

Call Center - Premium

Remave <

Add All ==

F] a
@ @
3 2
a a
& &
z z

OK Apply Cancel

6. Click Apply to accept the change.
To assign alternate numbers and extensions to a user:

1. Log into the web portal as a group administrator.
2. Click on Profile->Users->Search to display all existing users.

3. Select the desired user (e.g., 4605), who has been assigned the alternate number

service.
4. Click on Incoming Calls->Alternate Numbers.
5. Mark the On radio box in the Distinctive Ring field.

6. Select the alternate number from the pull-down list of Phone Number.
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7. Enter the extension in the Extension field.

BR«ADSOFT betp - Hame
Group =Users : 4605 Welcome [Logout

Options:
Profile

Alternate Numbers

Alternate Numbers allows up to ten additional phone numbers or extensions to be assigned in addition to your primary number and extension. All additional
Incoming Calls numbers and extensions fing your phone(s) just like your primary phone. In addition, you can specify a distinctive ringing pattern for each number, if your phone
Cuigoing Calls supports it. Only your administratar can configure new numbers and extensions for you

Call Control

Client Applications

lessaging Distinctive Ring: @ On ) Off

Senvice Seripts

Ullilies Alternate Number ID Phone Number Activated Extension Ring Pattern
1 4607 ~ v 4607 Long-Lang -
2 4608 ~ v 4608 Short-Short-Long
3 4612 ~ v 4612 Short-Long-Short
4 None = Normal -
5 None = Normal -
6 None - Normal -
7 None - Normal -
8 None - Normal hd
9 None - Normal hd
10 None - Normal hd

OK Apply Cancel

8. Repeat steps 6 to 7 to assign more alternate numbers to the user.
9. Click Apply to accept the change.

For more information on alternate numbers, refer to BroadWorks Web Interface

Administrator Guide.

Sequential Ring

Sequential ring allows a user to have up to five secondary locations, which are alerted
sequentially upon receiving an incoming call that matches a set of criteria. Each
secondary location can be either a phone number or SIP-URI. This service attempts to
call the user by ringing the phone numbers or URIs in the sequential ring list (starting
with the user’s base location, if enabled) one after the other until the call is answered.
The enhancement, Answer Confirmation, allows sequential ring to prompt the callee to
enter a digit to confirm the acceptance of the call.

Configuring the BroadSoft Server

To assign the sequential ring service to a user:

1. Log into the web portal as a group administrator.
Click on Profile->Users->Search to display all existing users.

Select the desired user (e.g., 4605).

> 0N

Click on Assign Services.
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5. In the Available Services box, select Sequential Ring and then click Add>.

Group =Users : 4605

Options:

b Profile
Incoming Calls
Outgoing Calls
Call Control

Assign Services

Assign Services allows you to assign or unassign services and service packs for a user. If a service or service pack is unassigned the service data that has

been filled out will be lost

= T

Calling Plans
Client Applications
Messaging
Service Scripts
Utiliies

Available Service Packs

Available Services

Basic Call Logs
Call Center - Premium

Add >

Remove =

Add All ==

User Service Packs

Help - Home

Welcome [Logout

User Services

Add >

Remove =

Add All ==

il il
& @
Fl 3
2 3
& E
z z

Push to Talk
Remote Office
Selective Call Acceptance

Selective Call Rejection
Sequential Ring

Senvice Scripts User
Shared Call Appearance
Shared Call Appearance 10
Shared Call Appearance 15
Shared Call Appearance 20
Shared Call Appearance 25

[m]

6. Click Apply to accept the change.

To configure a sequential ring list for a user:

1. Log into the web portal as a group administrator.

el

service.

o »

Click on Incoming Calls->Sequential Ring.

Click Add to add a new sequential ring entry.

Click on Profile->Users->Search to display all existing users.

Select the desired user (e.g., 4605), who has been assigned the sequential ring
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6. Set the following parameters to add a sequential ring entry.

The following shows an example:
Description: Entry 1
Use sequential ring:

Selected Time Schedule:

Selected Holiday Schedule: None

Selected

Every Day All Day

Calls from: Any phone number
BR«&ADSOFT Help -Home
Group =Users : 4605 Welcome [Logou]

Options:
Profile
B Incoming Calls

Sequential Ring Add

Outqoing Calls create multiple sequential ring entries
Calling Plans OK Cancel

Client Applications

Allows you to add a sequential ring entry. Specify the time schedule andior holiday schedule you would like calls sequentially rung. Also, you can have the call
sequentially rung when only the specified numbers call or all numbers call. If you need more than 12 numbers or more distinct time or holiday periods, you can

Wessaging
Senvice Scripts
Utilities

* Description: Entry 1

Selected Time Schedule:

Selected Holiday Schedule: None

@ Use sequential ring

Every Day All Day ~

() Da not use sequential ring

[ Calls from

@ Any phone number

() Following phone numbers:
[] Any private number
[] Any unavailable number
Specific phone numbers

7. Click OK to accept the change.

8. Configure the following parameters for sequential ring.

Parameter

Description

Use Base Location first

Specifies whether to alert the base

location when receiving an incoming call.

Number of rings for Base Location

Configures the number of rings for the
base location.

Continue the search process if the
base location is busy

Specifies whether to continue the search
process if the base location is busy.

Enable caller to skip search
process. Assumes forwarding or

messaging is enabled

Specifies whether to skip the search
process when the forwarding or voice

messaging is activated.

Phone Number / SIP-URI

Specifies the phone number or SIP URI of
the secondary location.

Number of rings

Configures the number of rings for the
secondary location.

Answer confirmation required

Allows sequential ring to prompt the
secondary location to enter a digit to
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Parameter Description

confirm the acceptance of the call

The following shows an example:

Use Base Location first: Selected

Number of rings for Base Location: 3

Continue the search process if the base location is busy: Selected
Enable caller to skip search process: Selected

Phone Number / SIP-URI: 4602 4603

Number of rings: 3

Answer confirmation required: Selected

Group =Users : 4605 Welcome  [Logou]
Options: . -
— Sequential Ring
rofile
Seguential Ring allows you to sequentially ring up to 5 locations in addition to the base location for a specified number of rings. The 5 locations can be eithera
» Incoming Calls phone number or a SIP-URI. The feature applies to calls matching your pre-defined criteria. Use this senvice to ring calls fram your manager, a family member,
Quigoing Calls or an important customer on your cell phone, alternate business phone, or home phone. The criteria for each Sequential Ring entry can be a listof up to 12
Call Control phone numbers or digit patterns, a specified ime schedule, and a specified holiday schedule. Al criteria for an entry must be satisfied for the call to enter
Sequential Ring (phone number and day of week and time of day). If the criteria do not match, the call continues as if this service was notturned on
Calling Plans
Messagin:
Senvice Scripts
Utilities Use Base Location first

MNumber of rings for Base Location: 3 -
Continue the search process ifthe base location is busy.

Enable callerto skip search process. Assumes forwarding or messaging is enabled,

Location Phone Number / SIP-URI Number of rings Answer confirmation required

1 4602 3~

2 4603 3 -

3 3 -

4 3 -

5 3 - (]

Active Description Ring Sequentially Calls from Edit
Entry 1 Yes Al calls Edit

e N 1 R
9. Click Apply to accept the change.

For more information on sequential ring, refer to BroadWorks Web Interface

Administrator Guide.

Call Transfer

72

Call transfer allows a user to transfer an existing call to another party. IP phones support
call transfer using the REFER method specified in RFC 3515. The following describes
three call transfer behaviors:

e  Blind Transfer: Transfer a call directly to another party without consulting. There is
no dialog between the user and the transfer-to party before transfer. Blind transfer
is implemented by a simple REFER method without Replaces in the REFER-TO
header.

e Attended Transfer After Answer: Transfer a call with consulting. There is a

confirmed dialog between the user and the transfer-to party before transfer.
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Attended transfer after answer is implemented by a REFER method with Replaces
in the REFER-TO header.

e  Attended Transfer Before Answer: Transfer a call after hearing the ringback tone.
The transfer-to party has been called by the user, but the transfer-to party has not
answered yet before transfer. Attended transfer before answer is implemented by
a REFER method with Replaces in the REFER-TO header.

BroadWorks provides two options for call transfer: Busy Camp On and Call Transfer
Recall. Busy Camp On allows users to camp the call against a busy destination. Call
Transfer Recall allows users to be recalled if the transferred call is not answered for any

reason. Busy Camp On only applies to the blind call transfer.

Configuring the BroadSoft Server

To assign the call transfer service to a user:

1. Log into the web portal as a group administrator.

2. Click on Profile->Users->Search to display all existing users.
3. Select the desired user (e.g., 4605).
4. Click on Assign Services.
5. Inthe Available Services box, select Call Transfer and then click Add>.
Group =Users - 4605 Welcome  [Logout
egen Assign Services
¥ Profile Assign Services allows you to assign or unassign semvices and service packs for a user. If a senvice or senvice pack is unassigned the senvice data that has
_ lncominoCalls W peenfiled out will be lost
Outgoing Calls
| Colmafens Available Service Packs User Service Packs
Client Applications
Messaqing Add =
Sevice Scripls
Utilities

Remave <

Add All ==

Available Services

User Services

Basic Call Logs A
Call Center - Premium

Calling Name Delivery -
Calling Name Retrieval

Calling Number Delivery

Calling Party Category

Call Me Now

Call Notify

Call Return

ek Al 22 Call Waiting

Charge Number

Classmark 2

=

Remove <

m

el a
: :
= =

6. Click Apply to accept the change.
To configure call transfer for a user:

1. Log into the web portal as a group administrator.

2. Click on Profile->Users->Search to display all existing users.
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Select the desired user (e.g., 4605), who has been assigned the call transfer

service.

Click on Call Control->Call Transfer.

Configure the following parameters of call transfer.

Parameter

Description

Call Transfer Recall

This option allows a transferred call to be
reconnected to the transferring party if it

reaches a failure or no-answer condition

after transfer.

Enables or disables Call Transfer Recall.

Number of rings before recall

Specifies the number of rings before Call

Transfer Recall is automatically triggered.

Enable Busy Camp On seconds

This option allows users to camp the call
against a busy destination and recall the
transferring user after the specified time.
Enables or disables Busy Camp On and
specifies the time after which the

transferring user should be recalled.

Use Diversion Inhibitor for Blind
Transfer

This option allows users to prevent blind
transferred calls from being redirected.

Enables or disables the use of diversion

inhibitor for blind transferred calls.

Use Diversion Inhibitor for
Consultative Calls

This option allows users to prevent
attended transferred calls from being

redirected.

Enables or disables the use of diversion
inhibitor for calls transferred with

consultation.




Configuring BroadSoft UC-One Integrated Features

The following shows an example:

Call Transfer Recall: Selected

Number of rings before recall: 4

Enable Busy Camp On seconds: Selected 120

Use Diversion Inhibitor for Blind Transfer: On

Use Diversion Inhibitor for Consultative Calls: On

Group =Users - 4605

Options:

Profile
Incoming Calls
Outgoing Calls

» Call Control
Calling Plans
Client Applications

Messaaing
Sevice Scripls
Utiliies

Help - Home

Welcome [Logout,

Call Transfer

Call Transfer allows you to transfer a call to another phone using your phone or the CommPilot Call Manager.
= T

Call Transfer Recall: @ on () Off

Configure Call Transfer Recall
Number of rings before recall: 4 ~

[T] Enable Busy Camp On 120 seconds

Use Diversion Inhibitor for Blind Transfer. @ On ) Off

Use Diversion Inhibitor for Consultative Calls: |

6. Click Apply to accept the change.

For more information on call transfer, refer to BroadWorks Web Interface Administrator

Guide.

Feature Key Synchronization

Feature key synchronization provides the capability to synchronize the status of the

following features between the IP phone and the BroadWorks server:

e Do Not Disturb

e Call Forwarding Always (CFA)

e Cadll Forwarding Busy (CFB)

e Cadll Forwarding No Answer (CFNA)

If feature key synchronization is enabled, and a user changes the status of one of these

features on BroadWorks, the BroadWorks server will notify the phone of synchronizing

the status. Conversely, if the user changes the feature status on the phone, the IP phone

will notify the BroadWorks server of synchronizing the status.

Configuring Yealink IP Phones

Feature key synchronization is configurable using template configuration files or via

web user interface.

75



IP Phones Deployment Guide for BroadWorks Environment

76

To configure feature key synchronization using template configuration files:

1. Add/Edit feature key synchronization parameters in template configuration files:

Parameter Description Value

Enables or disables feature key

synchronization.
%FEATURE_KEY S

bw.feature_key_sync | 0-Disabled
- - YN%

1-Enabled
The default value is 1.

2. Customize the static tag on BroadWorks. The tag name is % FEATURE_KEY_SYN %
and the tag value is 1.

For more information, refer to Customizing a Static Tag on page 15.
3. Upload template configuration files.

For more information, refer to Uploading Device Template Configuration Files on

page 17.

After the above configurations, the tag in the template file will be replaced by the

actual parameter value. An example is shown as below:

bw.feature key sync = 1

After successful update, user can find the web user interface of the IP phone is similar to

the one as shown below:

-
Yealink | wsx» PR
Account Network
General Information NOTE
Preference
Call waiting Enabled - 0 Call Waiting
Features : This call feature allows your
Calla oy e Enabled T 0 phone t_o accept other incoming
Linel Emergency Numbers ’7 @ calls during the conversation.
Line2 Return code when refuse 486 (Busy here) - 0
Line3 Return Code When DND 480 (Temporariy notav ~ @
Enable SemiAttend Transfer Enabled M 7}
Line4
Blind Transfer OnHook Disabled AN ]
Line5 -
Attend Transfer OnHook Disabled - @
RFC 2543 Hold Disabled - 0
Upgrade
Use Qutbound Proxy in Dialog Enabled - 0
Auto Provision
180 Ringing Disabled - 0
Configuration Save Call Log Enabled AR ]
pial Plan Suppress DTMF Display Disabled - @
N Suppress DTMF Display Delay Disabled -
Voice @
Login Timeout(1~1000)(Minutes) 5 o
Tones
| Feature Synchronization Enabled - OJ
LTS DHCP Hostname SIPV/52P )
__Conﬁrm __Cance\
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Call Pickup

IP phones support two call pickup behaviors: Directed Call Pickup and Group Call
Pickup. Directed call pickup allows users to pick up an incoming call on a specific
extension. Group call pickup allows users to pick up an incoming call within a
pre-defined group. W52P IP DECT phones only support to pick up a call by dialing the
FAC (feature access code).

BroadWorks also provides two enhanced services: Directed Call Pickup with Barge-in
(DPUBI) and Barge-in Exempt.

DPUBI allows users to dial a FAC followed by an extension to pick up a call directed to
another user, or barge in the call if it was already answered. When a barge-in occurs, a

three-way call is established between the parties with the DPUBI user as the controller.

Barge-in exempt allows users to block barge-in attempts from other users with DPUBI.

Barge-in exempt does not block pickup attempts.

Configuring the BroadSoft Server

To assign the call pickup service to the group:

1. Log into the web portal as a group administrator.
2. Click on Resource->Assign Group Services.

3. Inthe Available Services box, select Call Pickup and then click Add>.

BR:ADSOFT by - iome
Group Welcome [Lagout
. —

Joptions:

Profie Assign Group Services

Asgigh or unassign group semices for the group.

» Resources

Available Services. Assigned Services

Utilities

En: =
Enhanced Outgoing Calling Plan
Group Paging v

4, Click Apply to accept the change.

To add a call pickup group and assign users to the call pickup group:

1. Log into the web portal as a group administrator.
2. Click on Services->Call Pickup.

3. Click Add.

4. Enter a name in the Group Name field.

5

Click Search to display all available users.
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6. Inthe Available Users box, select the desired user and then click Add> to assign
the user to the call pickup group.

BRwADSOFT

Group

Options:

Help -Home

Welcome [Logout

Profile

Resources

Call Pickup Add

Create a new call pickup group.

Services
Senice Scripts

OK Cancel

Accl/Auth Codes

Calling Plan

Utilities

Call Center

Meet-Me Conferencing

*Group Name: Group1

Enter search criteria below

User ID - Starts With ~

Assigned Users

Available Users

4604,4604 (4604) e 4602 4602 (4602)
4506.4606 (4606) 46034603 (4603)
46094609 (4609) 4605.4605 (4605)
Lin.Jin (4610)

7.

Click OK to accept the change.

8. Repeat steps 6 to 7 to assign more users to the call pickup group.

To assign the directed call pickup and directed call pickup with barge-in services to a

user:

1. Log into the web portal as a group administrator.

o & NN

Click on Profile->Users->Search to display all existing users.
Select the desired user (e.g., 4605).
Click on Assign Services.

In the Available Services box, select Directed Call Pickup and Directed Call Pickup

with Barge-in, and then click Add>.

Group =Users - 4605

Options:

B Profile

Outqoing Calls

Incoming Calls

Help -Home

Welcome [Logouf

Assign Services

Assign Senices allows you to assign or Unassign senvices and service packs for a user. If a senice or senice packis Unassigned the service data that has
beenfilled outwill be lost

Calling Plans
5 o Available Service Packs User Service Packs
Client Applications
Messaging
S— Add =
Senice Scripts ;J
Utiliies
Add All ==
Available Services User Services
Basic Call Logs Add = Customer Originated Trace -

Call Center - Premium

Custom Ringback User

Custom Ringback User - Call Waiting
Custom Ringback User - Video
Directed Call Pickup

Remave <

n

Directed Call Pickup with Barge-in
Diversion Inhibitor

Do Not Disturb

Enhanced Call Logs

External Calling Line 1D Delivery
External Custom Ringback =

Add All ==

1 1
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6. Click Apply to accept the change.
To configure directed call pickup with barge-in for a user:

1. Log into the web portal as a group administrator.
2. Click on Profile->Users->Search to display all existing users.

3. Select the desired user (e.g., 4605), who has been assigned the directed call pickup
with barge-in service.

4. Click on Call Control->Directed Call Pickup with Barge-in.

5. Configure the following parameters for directed call pickup with barge-in.

Parameter Description

Specifies whether a warning tone is
. . played to the picked up user when a
Barge-in Warning Tone .
barge-in occurs.

The default state is “On”.

Enables or disables the user with DPUBI

service to initiate a pickup or barge-in by
dialing the DPBUI FAC without an
extension.

Automatic Target Selection When this option is enabled, the user can
initiate a pickup or barge-in by dialing
the FAC alone if only one user is active
(on a call or ringing).

The default state is “Off"”.

Silent monitoring is the ability for a
supervisor to listen into calls being

handled by their agents.

Silent Monitoring Warning Tone This option specifies whether to play a
warning tone to inform the agents that

they are being monitored.

The default state is “Off".
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The following shows an example:

Simultaneous Ring Personal: On

Automatic Target Selection: On

Silent Monitoring Warning Tone: On

Group =Users : 4605

Erofile

B Call Control
Calling Plans

Wessaaqing

Utilities

o

BR«ADSOFT
I ——

Options:

Incoming Calls
Outgoing Calls

Client Applications

Service Scripts

Help - Home

Welcome [Logout

Directed Call Pickup with Barge-in

Directed Call Pickup with Barge-in allows you te dial a feature access code followed by an extension to pick up or barge-in on a call to another group member.
Ifthe call has not been answered, then it is picked up. Ifthe call has been answered, then barge-in occurs. A barge-in results in a three-way call being created
between you, the group member being barged-in on, and the other party the group member is connected 10, You are the controller of the barge-in three-way
call

= T

Barge-in Warning Tone: @ On () Off

Automatic Target Selection: (©) On @ Off

. Click Apply to accept the change.

To assign the barge-in exempt service to a user:

-

oA N

Log into the web portal as a group administrator.

Click on Profile->Users->Search to display all existing users.
Select the desired user (e.g., 4605).

Click on Assign Services.

In the Available Services box, select Barge-in Exempt and then click Add>.

BRADSOFT

Group =Users : 4605

Options:

B Profile

Outgoing Calls

Incoming Calls

Help -Home

Welcome [Logout

Assign Services

Assign Services allows you to assign or unassign services and service packs for a user. If a service or service pack is unassigned the service data that has
been filled out will be lost

Call Control

= T

Calling Plans

Client Applications

Messaging
Sevice Scripls
Utilities

Available Service Packs User Service Packs

Add >

Remove <

Add All ==

Available Services

User Services

Basic Call Logs Add >
Call Center - Premium

Automatic Callback

Automatic Hold/Retrieve

Remove < BroadTouch Business Communicator Desktop - Video
BroadTouch Business Communicator Mobile - Video
BroadTouch MabileLink

BroadWorks Anywhere

BroadWorks Mobility

Busy Lamp Field

Call Forwarding Always

Call Forwarding Busy =

Add All ==

@ @
& E
2 2
2 S
3 ]
= z

6. Click Apply to accept the change.

To configure barge-in exempt for a user:

1. Log into the web portal as a group administrator.
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2. Click on Profile->Users->Search to display all existing users.

3. Select the desired user (e.g., 4605), who has been assigned the barge-in exempt

service.

4. Click on Cdll Control->Barge-in Exempt.

5. Mark the On radio box in the Barge-in Exempt field.

Group =Users : 4605

’ﬁnmnsom

Options:

I —

Help -Home

Welcome [Logout

Barge-in Exempt

Profile

ncoming Calls

Barge-in Exempt allows you to block barge-in attempts from other users with Directed Call Pickup with Barge-in.

B Call Control
Calling Plans

Cutqoing Calls

= -

Messaging

Client Applications

Barge-in Exempt: @ On ) Off

Senice Scripts
P

= 1=

6. Click Apply to accept the change.

To check the Call Pickup, Directed Call Pickup and Directed Call Pickup with Barge-in

FACs:

1. Log into the web portal as a group administrator.

2. Click on Utilities->Feature Access Codes.

3. Check the Call Pickup, Directed Call Pickup and Directed Call Pickup with Barge-in

FACs.

4. Select the desired FAC used by marking the desired radio box (Service Provider
FAC codes or Group FAC codes).

If Group FAC codes is selected, administrator can modify the code in the Main
(Required) field or enter an alternate code in the Alternate (Optional) field.

For more information on call pickup, refer to BroadWorks Web Interface Administrator

Guide.

Network Conference

Note

Network conference allows a user to conduct a conference with more than three

participants. The maximum number of the participants depends on the BroadWorks

server. The network conference is implemented using a conference URI, which is used to

identify a request for a BroadWorks conference resource. IP phones support network
conference using the REFER method as specified in RFC 4579.

The conference

URI can be configured on the BroadWorks server via the command line

interface. The command line interface access may be restricted on the BroadWorks

server. Contact

your BroadSoft reseller for the conference URI.
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Configuring Yealink IP Phones

To use network conference, you need to configure the conference type and conference
URI on IP phones in advance. Network conference is configurable using template

configuration files or web user interface.
To configure network conference using template configuration files:

1. Add/Edit network conference parameters in template configuration files:

The “x” in the parameter is an integer which specifies the line number on the IP
phone. If the user (e.g., 2413333505) is the first user assigned to the device profile,

u 111 "

replace the “x” by

Parameter Description Value

Configures the conference type
for account X.
account.X.conf_type | 0-Local Conference Integer
2-Network Conference
The default value is 0.

Configures the URI of the

%BWNETWORK-C
. network conference for account
account.X.conf_uri ONFERENCE-SIPU

X.
) RI-X%
The default value is blank.

The following shows an example of network conference configurations in a
template configuration file (e.g., %BWMACADDRESS%.cfg):

account.1.conf_type = 2
account.1.conf_uri = %BWNETWORK-CONFERENCE-SIPURI-1%
2. Upload template configuration files.

For more information, refer to Uploading Device Template Configuration Files on

page 17.

After the above configurations, the tag in the template file will be replaced by the

actual parameter value. An example is shown as below:

account.l.conf uri = Conference0Ol@pbx.yealink.com
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After successful update, user can find the web user interface of the IP phone is
similar to the one shown as below:

Yealink | ws»

Account Network (

Basic Accountl [~ NOTE
Keep Alive Type Default El 0
Advanced Advanced
UDP Keep Alive Interval(seconds) 30 0 The Advanced parameters for
administrator.
Codec Local SIP Port 5062 @
Number RPort Disabled = @
Assignment
SIP Session Timer T1({seconds) 0.5 0
Handset Name SIP Session Timer T2(seconds) 4 (7]
SIP Session Timer T4(seconds) 5 0
DTMF Type RFC2833 = @
How to INFO DTMF DTMF-Relay o
DTMF Payload(26~127) 101 0

SIP Registration Retry Timer(0~1800)

(seconds) 30 0
Subscribe MWI To Voice Mail Disabled [+] Q
Conference Type Network Conference El 0
Conference URI Conference0l@pbx.yealink. 0

Calling Line ID Presentation

Calling Line ID Presentation (CLIP) allows the IP phone to display the caller’s identity,
derived from a SIP header carried in the INVITE request, when receiving an incoming
call. The caller’s identity consists of the calling line ID last name, calling line ID first name
and phone number. The BroadWorks server provides external calling line ID delivery
and internal calling line ID delivery services. External calling line ID delivery allows the
calling line ID for callers from outside your group or enterprise to be displayed. Internal
calling line ID delivery allows the calling line ID for callers from inside your group to be

displayed.

Cadlling Name Presentation

Calling Name Presentation allows the IP phone to display the caller’s name, derived
from a SIP header contained in the INVITE request when receiving an incoming call. The
caller’s name consists of the calling line ID last name and calling line ID first name. The
BroadWorks server provides external calling name delivery and Internal calling name
delivery services. External calling name delivery allows the name for callers from
outside your group or enterprise to be displayed. Internal calling name delivery allows
the name for callers from inside your group to be displayed.

Calling Number Presentation

Calling Number Presentation allows the IP phone to display the caller’s phone number,

derived from a SIP header contained in the INVITE request, when receiving an incoming
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call. The BroadWorks server provides external calling number delivery and internal
calling number delivery services. External calling number delivery allows the number
for callers from outside your group or enterprise to be displayed. Internal calling
number delivery allows the number for callers from inside your group to be displayed.

Note The internal calling line ID delivery and external calling line ID delivery services have

precedence over calling name/number delivery service. If you have either the internal
calling line ID delivery or external calling line ID delivery service assigned, the
assignment and configuration of the calling name/number delivery service has no
effect.

Configuring the BroadSoft Server

To assign the calling line ID delivery service to a user:

1. Log into the web portal as a group administrator.

2. Click on Profile->Users->Search to display all existing users.

3. Select the desired user (e.g., 4605).

4. Click on Assign Services.

5. In the Available Services box, select External Calling Line ID Delivery and Internal
Calling Line ID Delivery, and then click Add>.

Group ~users - 4605 Welcome  [Logou

Options:

» Profile
Incoming Calls
Outgoing Calls

Assign Services

Assign Services allows you o assign or unassign services and service packs for a user. If 2 service or service packis unassigned the senice data that has been
filled out will be lost.
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Call Conirol

= L

Calling Plans

Client Applications
Messaging

Scripts
Utilities

Available Service Packs

-

Available Services

User Service Packs

-

User Services

3
External Custom Ringback
Fax Messaging

Flash Call Hold

Group Night Forwarding
Hoteling Guest

Hoteling Host

In-Call Service Activation
Integrated IM&P

Intercept User
Internal Calling Line ID Delivel 2

Basic Call Logs
Call Center - Premium

Remove <

m

(oo <]
(asanizs |

Add All ==

= 1

6. Click Apply to accept the change.

To configure calling line ID presentation for the user:

1. Log into the web portal as a group administrator.

2. Click on Profile->Users->Search to display all existing users.
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3. Select the desired user (e.g., 4605) who has been assigned the calling line ID
delivery service.

4. Click on Incoming Calls->External Calling Line ID Delivery.

5. Mark the On radio box in the Enable External Calling Line ID Delivery field.

Group =Users : 4605

Options:

Help -Home
Welcome  [Logou]

Erofile

®» Incoming Calls
Outgoing Calls
Call Control

External Calling Line ID Delivery

External Calling Line ID Delivery allows the Calling Line name and number for callers from outside your group or enterprise to be displayed. On assignment the
Connected Line Identification Presentation senvice acts as overlay service for the External Calling Line ID Delivery. The Connected Line Identification Presentation
allows you to see the connected line identity of the called party. The on/eff setting for External Calling Line ID Delivery alse controls the Connected Line Identification
Presentation semice.

Calling Plans

Senice Scripts
Utilities

Client Applications
Messaging

= T

Enable External Calling Line ID Delivery: a ion © off

Note: Since Connected Line Identification Presentation is assigned, the on/off flag controls when the Connected Line Identification is presented.

= I

6. Click OK to accept the change.

7. Click on Incoming Calls->Internal Calling Line ID Delivery.

8. Mark the On radio box in the Enable Internal Calling Line ID Delivery field.

Group =Users - 4605

Options:

Profile

B Incoming Calls

Call Control

Calling Plans
Client Applications
Messaging
Service Scripts
Utiliies

Outgoing Calls

Help - Home
Welcome [Logout]

Internal Calling Line ID Delivery

Internal Calling Line ID Delivery allows the Calling Line name and number for callers from inside your group to be displayed. On assignment the Connected Line
Identification Presentation senvice acts as overlay semvice for the Internal Calling Line ID Delivery. The Connected Line 1 Pri allows you to see

the connected line identity of the called party. The onioff setting for Internal Calling Line ID Delivery also controls the Connected Line Identification Presentation
sevice

e L

Enable Interal Calling Line ID Delivery: { @ ‘on ) o

Note: Since Connected Line ldentification Presentation is assigned, the on/off fiag controls when the Connected Line ldentification is presented

oK Apply Cancel

9. Click Apply to accept the change.

To assign the calling name delivery and calling number delivery services to a user:

1. Log into the web portal as a group administrator.

> N

Click on Profile->Users->Search to display all existing users.
Select the desired user (e.g., 4605).

Click on Assign Services.

85



IP Phones Deployment Guide for BroadWorks Environment

86

5. In the Available Services box, select Calling Name Delivery and Calling Number
Delivery, and then click Add>.

BR:ADSOFT

Group =Users : 4605

Options:

Help -Home

Welcome  [Logou]

» Profile
Incoming Calls
Outgoing Calls
Call Control

Assign Services

Assign Services allows you to assign or unassign services and service packs for a user. If a service or service pack is unassigned the service data that has been
filled out will be lost

= T

Calling Plans

Messaging

Utilities

Client Applications

Senice Scripts

Available Service Packs User Service Packs
Add >
Remove <
Add All ==
Available Services User Services

Basic Call Logs Add =
Call Center - Premium

>

Call Forwarding Mot Reachable
Call Forwarding Selective
Calling Line ID Blocking Qverride

Calling Line ID Delivery Blocking
Calling Name Retrieval

Calling Party Category

Call Me Now

Call Netify
Call Return =

Remove <

[m

Add All ==

o o
i i
= =
3 3
s s
z z

6. Click Apply to accept the change.

To configure calling name presentation for the user:

1. Log into the web portal as a group administrator.

2. Click on Profile->Users->Search to display all existing users.

3. Select the desired user (e.g., 4605), who has been assigned the calling name

delivery service.

4. Click on Incoming Calls->Calling Name Delivery.

5. Mark the On radio box in the Enable External Calling Name Delivery field.

6. Mark the On radio box in the Enable Internal Calling Name Delivery field.

Group ~Users : 4605

Options:

Help - Home

Welcome [Logoui

Calling Name Delivery

Profile
B Incoming Calls
Outgoing Calls

Calling Name Delivery allows the Calling Line name for callers from inside your group or enterprise (Internal) and/or callers from outside your group or enterprise
(External) o be displayed. On assignment the Connected Line Identification Presentation service acls as a overlay senice for Calling Name Delivery. The
Connected Line Identification Presentation allows you to see the connected line identity ofthe called party. The sefting for Calling Name Delivery also controls the

Call Control

Messaging
Senice Scripts
Utilities

Calling Plans
Client Applications

Connected Line Identification Presentation sernvice.
= =

Enable External Calling Name Delivery: @ On ) Off

Enable Internal Calling Name Delivery: @ on ) Off

= 1

7. Click Apply to accept the change.

To configure calling number presentation for the user:

1. Log into the web portal as a group administrator.

2. Click on Profile->Users->Search to display all existing users.
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3. Select the desired user (e.g., 4605), who has been assigned the calling number

delivery service.
4. Click on Incoming Calls->Calling Number Delivery.
5. Mark the On radio box in the Enable External Calling Number Delivery field.

6. Mark the On radio box in the Enable Internal Calling Number Delivery field.

BR«ADSOFT Help - Home
Group >Users : 4605 Welcome  [Logou]
Options: N N
"Pmme Calling Number Delivery
>0 call Calling Number Delivery allows the Calling Line number for callers from inside your group or enterprise (Internal) andior callers from outside your group or
incoming Calls enterprise (External) to be displayed. On assignment the Connected Line Identification Presentation service acls as a overlay senvice for Calling Number Delivery.
Qutgoing Calls The Connected Line Identification Presentation allows you to see the connected line identity of the called party. The setting for Calling Number Delivery also
Call Control contrals the Connected Line Identification Presentation senvice
Calling Pl
Client Applications
Messaging
Service Scripts Enable External Calling Number Delivery. @ Qn ) Off
LUtilities Enable Internal Calling Number Delivery: @ On ) Of

L 1

7. Click Apply to accept the change.

For more information on CLIP refer to BroadWorks Web Interface Administrator Guide.

Configuring Yealink IP Phones

IP phones support to derive calling line ID from the FROM and P-Asserted-Identity SIP
headers in the INVITE request. The calling line ID source is configurable using template

configuration files or via web user interface.
To configure the calling line ID source using template configuration files:

1. Add/Edit calling line ID source parameters in template configuration files:

The “X” in the parameter is an integer which specifies the line number on the IP

phone. X ranges from 1 to 5.

Parameter Description Valid Value

Configures the calling
line ID source for account
X.

0-FROM (Derives the
name and number of the
caller from the “From”
account.X.cid_source header). Oor1
- 1-PAI (Derives the name
and number of the caller
from the “PAl” header. If
the server does not send
the “PAI” header,

displays “anonymity” on

the callee’s phone).
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Parameter

Description

Valid Value

The default value is 0.

The following shows an example of the calling line ID source configuration in a

template configuration file (e.g., %BWMACADDRESS%.cfg):

account.1.cid.source = 1

Upload template configuration files.

For more information, refer to Uploading Device Template Configuration Files on

page 17.

After successful update, user can find the web user interface of the IP phone is

similar to the one as shown below:

Yealink | ws»»

Basic
Advanced
Codec

Number
Assignment

Handset Name

Status Account

Network

7
Keep Alive Type Default - o
UDP Keep Alive Interval(seconds) ’307 e
Local SIP Port ez @
RPort Disabled - o
SIP Session Timer T1(seconds) ’057 e
SIP Session Timer T2(seconds) ’47 e
SIP Session Timer T4(seconds) ’57 e
DTMF Type RFC2833 - o
How to INFO DTMF DTMF-Rely 0
DTMF Payload(96~127) r @
100 Reliable Retransmission Disabled Al ]
Subscribe Register Disabled - 0
Subscribe for MWI Disabled - @
Fl\:v(loil[g;cript\on Period(0~84600) ’35007 (7]
Caller ID Header PAIL - u
Use Session Timer Disabled AN 7 ]
Session Timer(seconds) ’7 e

NOTE

Advanced
The Advanced parameters for
administrator.

Calling Line ID Blocking Override

Calling Line ID Blocking Override allows the IP phone to always display the caller’s

identity, regardless of whether it is blocked by the caller.

Configuring the BroadSoft Server

To assign the calling line ID blocking override service to a user:

1.

2
3.
4
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Select the desired user (e.g., 4603).

Click on Assign Services.

Log into the web portal as a group administrator.

Click on Profile->Users->Search to display all existing users.



Configuring BroadSoft UC-One Integrated Features

5.
click Add>.

In the Available Services box, select Calling Line ID Blocking Override and then

BR:ADSOFT

Group =Users : 4603

Options:

B Profile
Incoming Calls
Outgoing Calls

Help -Home
Welcome [Logout

Assign Services

Assign Services allows you to assign or unassign services and service packs for a user. If a service or senvice pack is unassigned the senvice data that has been
filled out will be lost

Call Contral

= T

Calling Plans
Client Applications
Messaging
Sevice Scripts

Utilities

Available Service Packs User Service Packs
Add >
Remove <
Add All ==
Available Services User Services

Add >

»

Busy Lamp Field

Call Center - Premium

Call Forwarding Always

Call Forwarding Busy

Call Forwarding Mo Answer

Call Forwarding Mot Reachable
Call Forwarding Selective
Calling Line 1D Delivery Blacking
Calling Name Delivery

Calling Name Retrieval

= 1

[

Remove <

Add All ==

o @
@ i
2 2
z 2
5 s
z =

6. Click Apply to accept the change.

To configure calling line ID blocking override for the user:

Log into the

web portal as a group administrator.

Click on Profile->Users->Search to display all existing users.

Select the desired user (e.g., 4603), who has been assigned the calling line ID

blocking override service.

5.

Click on Incoming Calls->Calling Line ID Blocking Override.

Mark the On radio box in the Enable Calling Line ID Blocking Override field.

Group -Users - 4603

Options:
Profile

B Incoming Calls
Qutgoing Calls
Call Control
Calling Plans
Client Applications
Messaging
Sevice Scripts

Help -Home
Welcome [Logoui

Calling Line ID Blocking Override

Calling Line ID Blocking Override (CLIO) allows a user to override calling line identity presentation restrictions and always receive the calling line identity, if available
= L

Enable Calling Line 1D Blocking Qverride: @ On ) Off

I =

6. Click Apply to accept the change.

For more information on calling line ID blocking override, refer to BroadWorks Web

Interface Administrator Guide.
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Connected Line Identification Presentation

Note

Connected Line Identification Presentation (COLP) allows the IP phone to display the
callee’s identity specified for outgoing calls. The callee’s identity consists of the calling

line ID last name, calling line ID first name and phone number.

Before configuring the COLP feature, make sure the necessary calling line ID delivery
service for a call is set to “On” on the BroadWorks server.

Configuring the BroadSoft Server

To assign the connected line identification presentation service to a user:

1. Log into the web portal as a group administrator.

2. Click on Profile->Users->Search to display all existing users.
3. Select the desired user (e.g., 4602).
4. Click on Assign Services.
5. Inthe Available Services box, select Connected Line Identification Presentation and
then click Add>.
BR:ADSOFT setp - oma
Group >Users : 4602 Welcome  [Logou]
Options: : .
"’ ‘:": Assign Services
rofile
Assign Senvices allows you to assign or unassign senvices and service packs for a user. If a service or service pack is unassigned the serice data that has been
Incoming Cals filled out will be lost
Outgoing Calls
Calling PI
I Available Service Packs User Service Packs
Client Applications
Messaqging
Add =
Senvice Scripts ;]
Utilities
i
Available Services User Services
Basic Call Logs Add = Call Waiting
Call Center - Premium Charge Mumber
Classmark
Client Call Control =
CommPilot Call Manager =
CommPilot Express
Communication Barring User-Control
Connected Line Identification Presentation
Connected Line Identification Restriction
Customer Originated Trace
Custom Ringback User -

6. Click Apply to accept the change.

For more information on COLP refer to BroadWorks Web Interface Administrator Guide.

Configuring Yealink IP Phones

90

IP phones support to display the dialed digits, or the identity from a SIP header
(Remote-Party-ID or P-Asserted-ldentity) carried in the 18x or 200 OK response, or the
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identity from the From header carried in the UPDATE message as described in RFC 4916.
The connected line identification source is configurable using template configuration
files.

To configure the connected line identification source using template configuration files:

1. Add/Edit connected line identification source parameters in template configuration
files:

The “X” in the parameter is an integer which specifies the line number on the IP

phone. X ranges from 1 to 5.

Parameter Description Valid Value

Configures the connected
line identification source

for account X.

0-PAI-RPID (Derives the
name and number of the
callee from the “PAI” header
preferentially. If the server
does not send the “PAI"”
header, it will derive from
the “RPID” header).

1-Dialed Digits
(Preferentially displays the
dialed digits on the caller’s

phone).
2-RFC4916 (Derives the

name and number of the

account.X.cp_source Integer from 0 to 2

callee from “From” header

in the Update message).

When the RFC 4916 is
enabled on the IP phone,
the caller sends the SIP
request message which
contains the from-change
tag in the Supported
header. The caller then
receives an UPDATE
message from the callee,
and displays the identity in

the From header.

The default value is 0.

The following shows an example of the connected line identification source

configuration in a template configuration file (e.g., % BWMACADDRESS%.cfg):
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account.1.cp.source = 2
2. Upload template configuration files.

For more information, refer to Uploading Device Template Configuration Files on
page 17.

Connected Line Identification Restriction

Connected Line Identification Restriction (COLR) allows a user to block his identity from
showing up when receiving a call. When placing a call to the user with COLR enabled,
the 18x response from BroadWorks to the caller contains a Privacy header set to “id”.
The caller’s phone LCD screen updates the callee’s identity and displays “anonymous”.
This feature does not apply to calls between the same group users.

Configuring the BroadSoft Server

To assign the connected line identification restriction service to a user:

1. Log into the web portal as a group administrator.

2. Click on Profile->Users->Search to display all existing users.
3. Select the desired user (e.g., 4603).
4. Click on Assign Services.
5. Inthe Available Services box, select Connected Line Identification Restriction and
then click Add>.
Group =Users : 4603 Welcome  [Logout
oo Assign Services
¥ Profile Assign Services allows you to assign orunassign services and service packs for a user. If 3 senice or service pack is unassigned the service data thathas been
% filled out will e lost
utgoing Calls
Colnaflons Available Service Packs User Service Packs
Client Applications
Messaging =
Senvice Scripts
Utilities

Remove <

Add All ==

Available Services User Services

Add = CommPilot Call Manager -
CommPilot Express

Communication Barring User-Control

Connected Line Identification Presentation

[Connected Line Identification Restriction ______Hl|
Customer Originated Trace

Custom Ringback User

Custom Ringback User - Call Waiting

Custom Ringback User - Video

Directed Call Pickup

Directed Call Pickup with Barge-in 52

= 1

6. Click Apply to accept the change.

Remove <

Add All ==

E1 @
Ey 2
B ]
3 3
& 3
z z

To configure the connected line identification restriction for a user:
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1. Log into the web portal as a group administrator.

2. Click on Profile->Users->Search to display all existing users.
3. Select the desired user (e.g., 4603).
4. Click on Incoming Calls->Connected Line Identification Restriction.
5. Mark the On radio box in the Enable Connected Line Identification Restriction field.
BR->ADSOFT Help -Home
Group =Users - 4603 Welcome [Logout
D"‘:f“: Connected Line Identification Restriction
T Connecied Line Identification Restriclion allows you to block your number from being shown when receiving a call. Members of your group can still see your
L4 MM number when they call you. You have the choice of turning it on or off for all calls and then selectively turning it right back on or off using the feature access codes.
Outgoing Calls
Calling Plans
Client foplications Enable Connecled Line Identification Restriction: @ 'on () of
Messaging S
Service Scripts
- 1= 1

6. Click Apply to accept the change.

For more information on COLR, refer to BroadWorks Web Interface Administrator Guide.

Shared Call Appearance

Shared Call Appearance (SCA) allows users to share a SIP line on several IP phones.
Any IP phone can be used to originate or receive calls on the shared line. An incoming
call can be presented to multiple phones simultaneously. The incoming call can be
answered on any IP phone but not all. A call that is active on one IP phone will be
presented visually to other IP phones that share the call appearance. All SCA phones
can also be notified about calls being parked/no longer parked against any SCA

phone’s extension.

IP phones support SCA using a SUBSCRIBE/NOTIFY mechanism as specified in RFC 3265.
The events used are:

e  “call-info” for call appearance state notification
e "line-seize” for the IP phone to ask to seize the line

SCA feature also has private hold capability. When putting a shared line call on private
hold, the user can retrieve it on the hold phone only. Retrieve attempts on other phones

are rejected.

Configuring the BroadSoft Server

To assign the SCA service to a user:

1. Log into the web portal as a group administrator.

2. Click on Profile->Users->Search to display all existing users.
3. Select the desired user (e.g., 4605).
4

Click on Assign Services.
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5. Inthe Available Services box, select Shared Call Appearance and then click Add>.

Group =Users : 4605 Welcome [Logout

Options:

» Profile

ncoming Calls

| outocingcals |

| calingPlans |
Client Applications
Messaging
Senvice Scripts
Utilities

Assign Services

Assign Senvices allows you to assign or unassign senvices and senice packs for a user. If 3 senice or senice packis unassigned the senice data that has been
filled out will be lost

Available Service Packs User Service Packs

Add >

Remave <

Add All ==

Remove All <

Available Services User Semvices

Add > Push to Talk -
Remote Office

Selective Call Acceptance

Selective Call Rejection

Sequential Ring

Service Scripts User

Shared Call Appearance 10

Basic Call Logs
Call Center - Premium

Remave <

Add All == Shared Call Appearance 15 n

Shared Call Appearance 20
Shared Call Appearance 25 52

6. Click Apply to accept the change.

E1
Ey
B
3
&
z

To configure SCA for the user:

1. Log into the web portal as a group administrator.

N

Click on Profile->Users->Search to display all existing users.

o

Select the desired user (e.g., 4605), who has been assigned the Shared Call

Appearance service.
4. Click on Call Control->Shared Call Appearance.

The main SCA parameters are described as below:

Parameter Description

Allows alerting all the locations sharing

Alert all appearances for the call appearance when a location
Click-to-Dial calls places a call from the CommPilot Call
Manager.

. Allows the other location sharing the call
Allow Call Retrieve from another . L
appearance to retrieve a call by dialing a

location .

call retrieve FAC.

Provides the ability for multiple calls to be
Multiple Call Arrangement handled concurrently on different SCA

locations for a user.

L . Allows SCA locations to barge in on an
Allow bridging between locations . . . .
active call involving another location.

e . Alerts all shared call appearance
Enable Call Park notification PP

locations when a call is parked against
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Parameter Description

the user’s extension.

Determines whether to play a warning
tone when a shared location barges in on

an active call.
None: disables warning tone feature.

B -i ly: bles th i
Bridge Warning tone arge-in only: enables the warning tone

feature.

Barge-in and repeat every 30 seconds:
enables warning tone feature and the
warning tone is repeated periodically
every 30 seconds.

The following shows an example:

Alert all appearances for Click-to-Dial calls: Selected
Alert all appearances for Group Paging calls: Selected
Allow Call Retrieve from another location: Selected
Multiple Call Arrangement: On

Allow bridging between locations: Selected

Enable Call Park notification: Selected

Bridge Warning tone: Barge-in only

BR:=ADSOFT

Help -Home
Group =Users : 4605 Welcome [Logout

Options:
ool Shared Call Appearance
\ncoming Calls Shared Call Appearance allows administrators to allocate additional devices or lines to you. These devices or lines also ring just like your primary phone. Define
Incoming Calls
the line policy on Device Policies page.
Outgoing Calls
Calling Plans

Client Applications

Messaging
Senice Scripts
Utilities

Alert all appearances for Click-to-Dial calls
Alert 2ll appearances for Group Paging calls

Allow Call Retrieve from another location

Muttiple Call Arrangement. @ On ) Off
Allow bridging between locations
Enable Call Park notification
Bridge Waming tone: ) none

Barge-in only

(0 Barge-in and repeat every 30 seconds
Device Palicies: Configure device policies

Delete Identity/Device Profile Type (4] Identity/Device Profile Name Line/Port Edit
No Entries Present
[Page 10f1]
Identity/Device Profile Type = Starts With ~ Find  Find All

e ———

5. Click Apply to accept the change.
6. Click Add.

7. Select the desired device profile name (e.g., Test_ W52P) from the pull-down list of
Identity/Device Profile Name. Make sure the selected device profile has been

created and note this device profile.

8. Enter the alternate phone number (e.g., 4604) in the *Line/Port field.
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9. Select the domain name (e.g., pbx.yealink.com) from the pull-down list after the

sigh @.

BR«ADSOFT Halp oo
Group >Users : 4605 Welcome [Logout
Options
= Shared Call Appearance Add
Allows to allocate additional devices or lines to you
Incoming Calls
Outgoing Calls oK Cancel
» Call Control
Calling Plans
Client Applications Identity/Device Profile Name: Test_\W52P (Group) -
Messaaing *Line/Port: 4604| @ pbx yealink com ~
Sevice Scripts
Utilities Enable this location
Allow Origination from this location
Allow Termination to this location

10. Click OK to accept the change.
11. Repeat steps 6 to 10 to configure more alternate locations.

For more information on SCA, refer to BroadWorks Web Interface Administrator Guide.

Configuring Yealink IP Phones
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SCA is configurable using template configuration files or via web user interface.

To register the primary account and configure SCA on the primary phone using

template configuration files:

1. Add/Edit primary account parameters in template configuration files:
The “X” in the parameter is an integer which specifies the line number on the IP
phone. If the primary account (e.g., 4605) is the third user assigned to the device

profile, replace “X" by “3".

Parameter Description Value

Enables or disables the line
X.

account.X.enable 0-Disabled %BWLINE-BINARY-X%
1-Enabled

The default value is 0.

Configures the label to be
displayed on the phone for
account.X.label account X when the phone | %BWEXTENSION-X%
is idle.

The default value is blank.

Configures the name to be
) displayed on the callee’s

account.X.display_name %BWCLID-X%
- phone for account X.

The default value is blank.

Configures authentication
account.X.auth_name %BWAUTHUSER-X%

ID for account X.
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Parameter Description Value

The default value is blank.

Configures authentication
%BWAUTHPASSWOR

account.X.password password for account X. D.X%
= (o]

The default value is blank.

Configures the user ID for
account.X.user_name account X. %BWLINEPORT-X%
The default value is blank.

Configures the IP address
of SIP server Y for account
X. %BWHOST-X%

Y ranges from 1 to 2.

account.X.sip_server.Y.addr
ess

The default value is blank.

Configures the port of SIP
. server Y for account X.

account.X.sip_server.Y.port 5060
Y ranges from 1 to 2.

The default value is 5060.

Enables or disables the

outbound proxy server for

account.X.outbound_proxy_ | account X. %USE_SBC_BOOLEA
enable 0-Disabled N%
1-Enabled

The default value is 0.

Configures the outbound
proxy server address for
account.X.outbound_host %SBC_ADDRESS%
account X.

The default value is blank.

Configures the outbound
proxy server port for

account.X.outbound_port %SBC_PORT%
account X.

The default value is 5060.

Add/Edit SCA parameters in template configuration files:

The “X” in the parameter is an integer which specifies the line number on the phone.
If the primary account (e.g., 4605) is the third user assigned to the device profile,
replace “X” by “3".

Parameter Description Value

Enables or disables BroadSoft

shared call appearance

feature. %BWSHAREDLINE-BIN

account.X.shared line
- 0-Disabled ARY-X%

1-BroadSoft_SCA

The default value is 0.
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The following shows an example of the SCA configuration in a template
configuration file (e.g., %BWMACADDRESS%.cfg):

account.3.shared line = $BWSHAREDLINE-BINARY-3%
Upload template configuration files.

For more information, refer to Uploading Device Template Configuration Files on

page 17.

After the above configurations, the tags in the template file will be replaced by the

actual parameter values. An example is shown as below:

account.3.enable =1

account.3.label = 4605

account.3.display name = 4605 yealink
account.3.auth name = 4605

account.3.password = yealink
account.3.user name = 4605

account.3.sip server.l.address= pbx.yealink.com
account.3.sip server.l.port= 5060

account.3.outbound proxy enable = 1

account.3.outbound host 192.168.1.225

5060

account.3.outbound port

account.3.shared line =1


http://199.19.193.15/Group/DeviceInventory/Modify/Files/Modify/index.jsp?key=%25BWMACADDRESS%25.cfg
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After successful update, user can find the third line of the phone is registered the

account 4605 as shown below:

Yealink | ws»»

Basic
Advanced
Codec

Number
Assignment

Handset Name

Account

Register Status

Line Active

Label

Display Name

Register Name

User Name

Passwaord

Enable Qutbound Proxy_Server
Qutbound Proxy Server
Transport

NAT Traversal

STUNM Server

Proxy Require
Anonymous Call
Anonymous Call Rejection
SIP Server 1 @)
Server Host

Server Expires

Server Retry Counts
SIP Server2 @)
Server Host

Server Expires

Server Retry Counts

Network Phone

Contacts

Registered
Enabled A 7}
fos @
G @
hes @
es @
[seeeesss @
Enabled - o
[192.168.1.225 Port |5060
uDP - o
Diszbled - @
[ port [2478
@
Disabled AN ]
Disabled v @
[pbx.yealink.com Port |5060
oo @
B e
[ Port [5060
Bew @
B e

Cancel

Security

Display Name

SIP service subscriber's name
which will be used for Caller ID
display.

Register Name
SIP service subscriber's ID used
for authentication.

User Name
User account, provided by VoIP
service DfDVIdEH’.

NAT Traversal

Defines the STUN server wil be
active or not.

o Proxy Require
A special parameter just for
Nortel server. If you login to
Nortel server, the value should
be: com.nortelnetworks.frewall

@

(2]

@

To register the alternate accounts and configure SCA on the alternate phones using

template configuration files:

1. Add/Edit the alternate account parameters in template configuration files:

The “x” in the parameter is an integer which specifies the line number on the IP

phone. If the user is the second user assigned to the device profile, replace the “x”

by 1/2".

account.2.enable = %BWLINE-BINARY-2%
account.2.label = %BWEXTENSION-2%

account.2.display_name =%BWCLID-2%
account.2.auth_name = %BWAUTHUSER-2%
account.2.password = %BWAUTHPASSWORD-2%
account.2.user_name = %BWLINEPORT-2%

account.2.sip server.l.address= %BWHOST-2%

account.2.sip server.l.port= 5060

account.2.outbound_proxy_enable = %USE_SBC_BOOLEAN%

account.2.outbound_host = %SBC_ADDRESS%

account.2.outbound_port = %SBC_PORT%
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2. Add/Edit SCA parameters in template configuration files:

The “Xx” in the parameter is an integer which specifies the line number on the IP
phone. If the user is the second user assigned to the device profile, replace the “x”
by IIZ"_

account.2.shared_line = %BWSHAREDLINE-BINARY-2%

3. Upload template configuration files.

For more information, refer to Uploading Device Template Configuration Files on

page 17.

After the above configurations, the tags in the template file will be replaced by the

actual parameter values. An example is shown as below:
account.2.enable = 1

account.2.label = 4604

account.2.display_name = 4604 yealink
account.2.auth_name = 4605

account.2.password = yealink

account.2.user_name = 4604

account.2.sip server.l.address= pbx.yealink.com
account.2.sip_server.1.port= 5060
account.2.outbound_proxy_enable = 1
account.2.outbound_host = 192.168.1.225
account.2.outbound_port = 5060

account.2.shared_line = 1
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After successful update, user can find the second line of the alternate IP phone is

registered with account 4604 as shown below:

-
Yealink | ws»
Status Network Contacts Security
NoTE
Basic
Register Status Registered
Display Name
Advanced Line Active Enabled M 7] SIP service subscriber's name
which wil be used for Caller ID
Codec Label 4604 Q display.
Display N 4604 yealink Register Nai
Number Py ame i @ SIP service subscriber's ID used
Assignment Register Name 2605 0 for authentication.
l— User Name
Handset Name User Name 4604 Q User account, provided by VoIP
service provider.
Password seassess 2]
NAT Traversal
Enable Qutbound Proxy_Server Enabled A 7} Defines the STUN server will be
active or not.
Outhound Proxy Server [192.168.1.225 port [5060 @
Proxy Require
Transport upp - e A special parameter just for
Mortel server. If you login to
NAT Ti | Disabled Mortel server, the value should
fevers T @ be: com.nortelnetworks.frewal
STUN Server | port 3478 @
Proxy Require (7]
Anonymous Call Disabled - o
‘Anonymous Call Rejection Disabled - e
SIP Server 1
Server Host |pbx.yea||nk.cum Port |5EIBEI [}
Server Expires 3600 0
Server Retry Counts 3 o
SIP Server2 @)
Server Host | port |5060 @
Server Expires 3600 o
Server Retry Counts 3 0
__Cuﬂﬁrm __Caﬂ(el

SCA feature is configurable via web user interface at the path Account->Advanced.

Music on Hold

Music on Hold allows an audio source to be played to held parties in various scenarios
(Call Park, Call Hold, and Busy Camp On). W52P IP DECT phones do not support to play

a video source.

Configuring the BroadSoft Server

To assign the Music on Hold service to the group:

1. Log into the web portal as a group administrator.

2. Click on Resources->Assign Group Services.
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3. In the Available Services box, select Music On Hold, and then click Add>.

BR<ADSOFT s -
Group Welcome  [Logoutl

[Options:
Profile

P Resources
Service Scripts
Acctifuth Codes

Assign Group Services

Assign or Unassign group services for the group

Available Services Assigned Services

Calling Plan Inventory Report -
MesEhe Conferencing L2
cete Conferenciy
Utilities Remove < -
Music On Hold - Video
Outgoing Calling Flan
Preferred Carrier Group
[T Series Conpletion
Serwice Scripts Group
Towk Group
Toser Rossaging Group =

=1
4. Click Apply to accept the change.

To configure Music on Hold for a department:

1. Log into the web portal as a group administrator.

2. Click on Services->Music/Video On Hold.

3. Click Add.

4, Select the desired department from the pull-down list of Department.
5

Configure the Music on/Video on Hold for individual services:

e Enable music/video during Call Hold: Checking this checkbox enables the IP
phone to play an audio for held callers.

e Enable music/video during Call Park: Checking this checkbox enables the IP
phone to play an audio for parked callers.

¢  Enable music/video during Busy Camp On: Checking this checkbox enables

the IP phone to play an audio for camped callers.

6. Configure the source of the Music/Video on Hold message to play.

e  System Defined Music/Video: Marking this radio box enables the IP phone to

play the system defined music.

e  External Source: Marking this radio box enables the IP phone to play the

external audio source. An identity/device needs to be configured.

o  Custom Music/Video File: Marking this radio box enables the IP phone to play
the custom music file. A custom music file needs to be loaded to the system.

7. Click Apply to accept the change.
To modify Music on Hold for a group/department:

1. Log into the web portal as a group administrator.
2. Click on Services->Music/Video On Hold.
3. Select the desired group/department and click Edit.
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4. Make the desired change.

Group

Help - Home

Welcome [Loout
—

options:

Frofile

Resources

Music/Video On Hold Modify

Madify the selected Musicividen Gn Hold source.

v

Senvices
Service Seripts

Call Center

Accifuth Codes

Meet Me Canfe

Calling Plan

Utilities

0% Apply Cancel

General Seftings Internal Calls Settings

Enable musichideo during Call Hold
Enable musichideo during Call Park
Enable musichideo during Busy Gamp On
Music/Video On Hold messages

Prefetted Audin Codec:

© system Defined Musicivideo

O Exteral Source

OldentityDevice Prafile © None

O Custom Musiciides File

Load Custom Music File: | ]

Load Custor Videa File: | ]

5. Click Apply to accept the change.

To assign the Music on Hold User service to a user:

1.

2.
3,
4.
5.

Log into the web portal as a group administrator.

Click on Profile->Users->Search to display all existing users.
Select the desired user (e.g., 4605).

Click on Assign Services.

In the Available Services box, select Music On Hold User and then click Add>.

BR«ADSOFT

Group >Users : 4605

Options:

» Profile
Incoming Calls

Call Control

Outgoing Calls

Calling Plans

Client Applications

Messaging
Semice Scripts
Utilities

Help -Home
Welcome [Logout]

Assign Services

Assign Services allows you to assign orunassign services and service packs for a user. If 3 senvice or service pack is unassigned the service data that has been
filled out will be lost

= 1

Available Service Packs User Service Packs
Add >
Remove <
Add All ==
Available Services User Services

Basic Call Lags Add>

Call Center - Premium

Internal Calling Line 1D Delivery
Last Number Redial

Location-Based Calling Restrictions

Multiple Call Arrangement

MWI Delivery to Mobile Endpoint

N-Way Call =
Qutlook Integration
Physical Lacation
Polycom Phene Senvices
Pre-alerting Announcement

Remove <

Add All ==

E1 @
Ey 2
B ]
3 3
@ @
z z

Apply Cancal

6. Click Apply to accept the change.

To configure Music on Hold for the user:

1.
2.

Log into the web portal as a group administrator.

Click on Profile->Users->Search to display all existing users.
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3. Select the desired user (e.g., 4605), who has been assigned the Music on Hold User

service.
4. Click on Call Control->Music/Video On Hold.
5. Mark the On radio box in the Music On Hold field.
6. Configure the source of the Music/Video on Hold message to play.
e  Group Defined Music/Video: Marking this radio box enables the IP phone to

play the group defined music.

e  Custom Music/Video File: Marking this radio box enables the IP phone to play
the user custom audio source. A custom music file needs to be loaded to the

BR«*ADSOFT Helo - Home
Group ~Users : 4605 Welcome [Logou
(Options: . .

e Music/Video On Hold
" nommocais [l MusicOn Hold allows you to turn on music for all calls when the remote party is neld or parked

[T . | e e eew |
» Call Control

Calling Plans

Music On Hold: @ Qn ) Off

Client Applications

Messaqing
R | General Settings Internal Calls Settings

Semvice Scripts

Utilities

Music/Video On Hold message:
© Group Defined Musichideo
©) Custom Musicivideo File

Load Custom Music File. Browse

Load Custom Video File Browse

=1
7. Click Apply to accept the change.

For more information on Music/Video on Hold, refer to BroadWorks Web Interface
Administrator Guide.

Voice Messaging

Voice messaging service allows users to record messages from callers for calls that are
not answered within a specified number of rings, or for calls that receive a busy
condition. BroadWorks also provides two options for voice messaging: Distribution List
and Voice Portal Calling. Distribution List allows users to send voice messages to the
pre-defined list of numbers in bulk. Voice Portal Calling allows users to originate calls

from the voice portal.

Configuring the BroadSoft Server
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To assign the voice messaging and voice portal calling services to a user:

1. Log into the web portal as a group administrator.

2. Click on Profile->Users->Search to display all existing users.
3. Select the desired user (e.g., 4605).
4

Click on Assign Services.
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5. Inthe Available Services box, select Voice Messaging User and Voice Portal Calling,

and then click Add>.

Group =Users - 4605

Options:

» Profile
Incoming Calls

Qutgoing Calls

Help - Home

Welcome [Logoui
Assign Services

Assign Senvices allows you to assign or unassign services and service packs for a user. If a senice or senvice pack is unassigned the service data that has been
filled outwill be lost

Call Contral

= 1

Calling Plans
Client Applications
Messaging
Semvice Scripts

Utilities

Available Service Packs User Service Packs

Add =

Remave <

Add All ==

Available Services User Services
Basic Call Logs Add = Third-Party MW Control -
Call Center - Premium Third-Party Voice Mail Support
Three-Way Call
Remowe < Tuwo-Stage Dialing
Video Add-On

Video On Hold User

Virtual On-Net Enterprise Extensions
Voice Messaging User - Video

Voice Portal Calling
Zone Calling Restrictions

Add Al ==

@ @
@ @
] 3
3 =
S &
z z

OK Apply Cancel

6. Click Apply to accept the change.

To add a distribution list for the user:

1. Log into the web portal as a group administrator.

2. Click on Profile->Users->Search to display all existing users.

o

service.

N o~ o

Select the desired user (e.g., 4605), who has been assigned the voice messaging

Click on Messaging->Distribution Lists.
Click the desired distribution list number.
Enter the description of the distribution list in the Description field.

Enter the number or the SIP-URI in the Phone Number / SIP-URI field and click Add.

Group =Users - 4605

Options:

Profile
Incoming Calls
Qutgoing Calls

Call Control
Calling Plans
Client Applications
Messaqging
Senvice Scripts
Utilities

Help - Home
Welcome  [Logout

Distribution Lists

Distribution Lists allows you to create lists of numbers to send voice messages in bulk.

= T

Distribution List Numbers:
0 1 2 3 4 5 6 7 8 9 10 11 12 13 14

Description: List 1

Di List
Phone Number | SIP-URI: 4608|

Add

Delete Phone Number / SIP-URI
D 4602
(=] 4603

EwE——

8. Repeat the step 7 to add more numbers.

9. Click Apply to accept the change.
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To configure voice messaging for the user:

1. Log into the web portal as a group administrator.
2. Click on Profile->Users->Search to display all existing users.

3. Select the desired user (e.g., 4605), who has been assigned the voice messaging

service.
4. Click on Messaging->Voice Management.
5. Set the parameters of voice messaging.
The following shows an example:
Voice Messaging: On
Send Busy Calls to Voice Mail: Selected
Send Unanswered Calls to Voice Mail: Selected
Use unified Messaging: Selected

Use Phone Message Waiting Indicator: Selected

Group =Users : 4605 Welcome [Logout
Options:

Voice Management

Profile

e o Voice allows you to specify how to handle your messages. Use Unified messaging if you want to use your phone to refrieve messages. You can also

Incoming Calls i
—————— W justchoose to send the message to your e-mail and notuse the phone for messaging. Note that the message seftings here also apply to other types of

Qutgoing Calls messaging such as fax if enabled.

Call Conirol
Client Applications
Messaging Voice Messaging (@ on ©) Off
Senice Scripts b
Utilities

[] Send Al Calls to Voice Mail
Send Busy Calls to Voice Mail

Send Unanswered Calls to Voice Mail

When a message arrives..
@ Use unified messaging Advanced Sefiings (Also saves curent screen data

Use Phone Message Waiting Indicator

©) Forward itto this e-mail address;

Additionally.
[] Notify me by e-mail of the new message at this address
[C] E-mail a carbon copy of the message to

[] Transfer on "0’ to Phone Number

6. Click Apply to accept the change.
To configure voice portal calling for the user:

1. Log into the web portal as a group administrator.
2. Click on Profile->Users->Search to display all existing users.

3. Select the desired user (e.g., 4605), who has been assigned the voice messaging

service.

4. Click on Messaging->Voice Portal Calling.
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5. Mark the On radio box in the Voice Portal Calling field.

BR&ADSOFT el -Home
Group =Users : 4605 Welcome [Logout
I —
Soncrs Voice Portal Calling

Profile

" peomnecals | Voice Portal Calling allows you 1o originate calls from the Voice Portal. Once you have dialed in to the Voice Portal and authenticated yourself, select the Make Call
Incoming Calls
— menu option and enter the destination digits

Outgoing Calls

Calling Plans

Client Applications
» Messaqing

Service Scripts

e e—
L ——

Vaice Portal Calling: @ lon ©) off

6. Click Apply to accept the change.

For more information on voice messaging, refer to BroadWorks Web Interface
Administrator Guide.

Configuring Yealink IP Phones

Voice messaging is configurable using template configuration files.
To configure voice messaging using template configuration files:

1. Add/Edit voice messaging parameters in template configuration files:

The “X" in the parameter is an integer which specifies the line number on the IP

phone. If the user (e.g., 4605) is the first user assigned to the device profile, replace
IIXII by II1 II'

Parameter Description Value

Configures the voice
%BWVOICE-PORTAL-

NUMBER-X%

voice_mail.number.X | number for account X.

The default value is blank.

The following shows an example of the voice messaging configuration in a
template configuration file (e.g., %BWMACADDRESS%.cfg):

voice_mail.number.1 = %BWVOICE-PORTAL-NUMBER-1%
2. Upload template configuration files.

For more information, refer to Uploading Device Template Configuration Files on page
17.

After the above configurations, the tag in the template file will be replaced by the

actual parameter values. An example is shown as below:

voice mail.number.l = 2413333588

#The number”2413333588”1is the voice portal number provided on the

BroadWorks server.
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Upgrading Firmware

To upgrade firmware using template configuration files:

1.

Add/Edit firmware URL in template configuration files (e.g., y000000000025.cfg):

firmware.url=http://%BWDEVICEACCESSFQDN%:%BWDEVICEACCESSPORT%/%BW
DMSCONTEXT%/%BWDEVICEACCESSURI%%FIRMWARE_VERSION%

Customize the static tag on BroadWorks. The tag name is %FIRMWARE_VERSION%
and the tag value is the firmware version (e.g., 25.73.0.1.rom).

For more information, refer to Customizing a Static Tag on page 15.
Upload the firmware (e.g., 25.73.0.1.rom).

For more information, refer to Uploading Static Files on page 21.
Upload template configuration files.

For more information, refer to Uploading Device Template Configuration Files on

page 17.

After the above configurations, the tags in the template file will be replaced by the

actual parameter values. An example is shown as below:

firmware.url = http://xsp.iop1.broadworks.net:80/dms/Yealink_W52P/25.73.0.1.rom

You can also upgrade the firmware via web user interface at the path Phone->Upgrade.

For more information on how to upgrade the firmware, refer to
Yealink_ W52P_IP_DECT Phones_Auto_Provisioning Guide.
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Downloading and Verifying Configurations

Downloading Configuration Files

Once obtaining the access URL, the phone will connect to the BroadWorks server and
download the configuration files. You should check the BroadWorks server settings and
configure IP phones in advance.

To check the BroadWorks server settings:

1. Log into the web portal as a group administrator.
2. Click on Resources->ldentity/Device Profiles.

3. Click Search to display all existing device profiles (Click Next to turn to the next

page).
BR«ADSOFT Help - Home
Group Welcome [Logouf]
Options: - .
z - Identity/Device Profiles
rofile
> Resources Add or modify group level identity/device profiles. Displays all the identitydevice profiles defined at group level
et e Y
Senvice Scripts =
—AEL‘UAUIH Codes Enter search criteria below
Call Center Identity/Device Profile Name Jid Starts With +
Calling Plan
West-Me Conferendn jice Profile Name [&]  Identity/Device Profile Type  Available Ports  Host NamellP Address  MAC Address Status  Version Edit
Liget-he Conferencing
T omes | 4601 Yealink T28P Unlimited 00156565461E  Online  Yealink SI.. Edit
4602 Yealink T28P Unlimited Online  Yealink 81 Edit
4603 Yealink T28P Unlimited Online Edit
Test_W52P Yealink_W52P & 0015655F8CTD  Online Edit
W52P_SCA Yealink_W52P 4 10.3.6.155 00156540AD50 Online  Yealink SI Edit
[Page 1of1]

OK Cancal

4. Select the desired device profile (e.g., Test. W52P) to edit.

5. Click on the Profile tab.
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6. Check the parameters: URL, MAC address, user name and password in the
corresponding fields.

BR«+ADSOFT Help - Home

Group Welcome [Logou
Options: . . .

p:f,';‘e Identity/Device Profile Modify
> Resouces [ Mo0in or delete an existing aroup idenity/device profile

Semvice Scripts

Acct/Auth Codes

Profile Users Files Custom Tags
Call Center
Calling Plan
Meet-Me Conferencing Identity/Device Profile Name: Test_W52P
Utilities IdentityDevice Profile Type: Yealink_W52P

[ Device Type URL: http:fixsp.iop.broadworks.net 80/dmsiYealink_W52P! |

Protocol: SIP20 ~
HostName/IP Address: Port
Transport: Unspecified ~
Serial Number:
Description:
Outbound Proxy Server:
STUN Server:

Physical Location:

Lines/Ports: &

Assigned Lines/Ports: 1

Unassigned Lines/Ports: 4
Version: Yealink SIP-W52P 2573.0.1

Al

(0 Use Identity/Device Profile Type Credentials

(@ Use Custom Credentials

* Device Access User Name: testuser

* Device Access Password: sesssssss

" Re-type Device Access Password: esessssse

=1 1

To configure the IP phone via web user interface:

1. Log into the web user interface as an administrator.
2. Click on Phone->Auto Provision.

3. Enter the URL, user name and password in the corresponding fields.
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4. Mark the On radio box in the Power On field.

-
Yealink | wsz
Status Account Network Contacts Security
Auto Provision 0 NOTE
Preference
@
FHe @ on O off @ Auto Provision
Features _ _
DHCP Option @ on O off @
tnet Custom Option(128~254)
Line2 DHCP Option 60 yealink [7]
Line3 Provisioning Server |http:ffxsp1.mpl.bruadwarks.net:eufdr e
User Name testuser
Line4 I \
Password [ss0essee [
Line5
Common AES Key (2]
MAC-Oriented AES Ke sssssese
Upgrade i @
Check New Config @ on © off e
Auto Provision . _
Repeatedly ©on @ off @
Configuration Interval(Minutes) 60 ]
Dial Plan Weekly ©on @ off @
o Tme @ 02 oo —IEI3 :IEII]
oice
[¥] sunday
Tones [ monday
[¥] Tuesday
TR0G9 Day of Week @ [¥] Wednesday
[¥] Thursday
[¥] Friday
[¥] saturday
@

5. Click Confirm to accept the change.

After the above configurations, reboot the IP phone. The IP phone will try to
download the configuration files from the BroadWorks server.

Verifying Configurations

After auto provisioning, the IP phone reboots in some cases. You can verify the
configurations via phone user interface or web user interface of the phone. During the
auto provisioning process, you can monitor the downloading request and response
message by a WinPcap tool.

Example: The W52P IP DECT phone downloads configuration files by HTTP

Time Source Destination Protocol Info

. 902918000 GET /dms/Yealink_w52P/y000000000025.cfg HTTP/1.1
44.914558000 10.1.8.16 10.3.6.103 HTTP HTTP/1.1 401 unauthorized
44.938439000 10.3.6.103 10.1.8.16 HTTP GET /dms/vealink_w52P/y000000000025.cfg HTTP/1.1
45.054135000 10.1.8.16 10.3.6.103 HTTP HTTP/1.1 200 OK (text/plain)
45.734782000 10.3.6.103 10.1.8.16 HTTP GET /dms/vealink_w52p/0015655Ff9c7d. cfg HTTRP/1.1
45.744243000 10.1.8.16 10.3.6.103 HTTP HTTP/1.1 401 Unauthorized
45.759333000 10.3.6.103 10.1.8.16 HTTP GET /dms/vealink_w52P/0015655f9c7d. cfg HTTP/1.1
45.951109000 10.1.8.16 10.3.6.103 HTTP HTTP/1.1 200 ok (text/plain)
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Troubleshooting

Troubleshooting

This chapter provides general troubleshooting information to help to solve the problems
you might encounter when you deploy Yealink W52P IP DECT phones in the BroadWorks
environment.

Why does the phone fail to download configuration files of the specified device profile?

Do the following:

1.  Ensure that the configuration of the device profile is correct.
2. Check the way of download configuration files:

- If the phone downloads configuration files via auto provisioning, ensure that

the URL, user name and password configured on the phone are correct.

- If the phone downloads configuration files via remote restart (BroadWorks
sends a NOTIFY request to the phone to restart), ensure that the phone’s MAC
address is configured for the Device Profile.

Why can't | view the device-specific file?

Ensure that the MAC address of the phone is configured when creating a Device Profile.
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