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LDAP Phonebook on Yealink IP Phones

Introduction

LDAP stands for Lightweight Directory Access Protocol, which is a client-server protocol
for accessing a directory service. LDAP is a directory service protocol that runs over
TCP/IP. The nitty-gritty details of LDAP are defined in RFC 1777 "Lightweight Directory
Access Protocol".

The following gives an overview of LDAP from a user's perspective.
What kind of information can be stored in the directory?

The LDAP information model is based on entries. An entry is a collection of attributes
that has a globally-unique Distinguished Name (DN). The DN is used to refer to the entry
unambiguously. Each of the entry's attributes has a type and one or more values. The
types are typically mnemonic strings, like "cn" for common name, or "mail" for email
address. The syntax of values depends on the attribute type. For example, a cn
attribute might contain the value “Babs Jensen”. A mail attribute might contain the

value "babs@example.com".
How is the information arranged?

In LDAP directory entries are arranged in a hierarchical tree-like structure. Traditionally,
this structure reflected the geographic and/or organizational boundaries. Entries
representing countries appear at the top of the tree. Below them are entries
representing states and national organizations. Below them might be entries
representing organizational units, people, printers, documents, or just about anything
else you can think of. The following shows an example of LDAP directory tree using

traditional naming.

st=California

o=Acme

The Organisation

Organisation Unit

ou=Sales ou=Marketing

cn=Barbara Jenson




Introduction

LDAP enables you to locate organizations, individuals, and other resources such as files
and devices in a network, whether on the Internet or on a corporate intranet, and
whether or not you know the domain name, IP address, or geographic whereabouts. An
LDAP directory can be distributed among many servers on a network, then replicated
and synchronized regularly. LDAP is particularly useful for storing information that you

wish to read from many locations, but update infrequently.

This guide provides configurations on the LDAP server and IP phones, and applies to
Yealink SIP-T28P SIP-T26P SIP-T22P, SIP-T21P, SIP-T46G, SIP-T42G and SIP-T41P IP phones

running firmware version 72 or later.
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Installing and Configuring the LDAP Server

An LDAP server is essentially a bit like an SQL server, which is mainly used for
storing/retrieving information about people (such as contacts). The configuration
settings on the phone will be altered depending on how the LDAP server is configured.

Before using LDAP feature on IP phones, you must make sure the LDAP server is
prepared properly, otherwise you need to install and configure an LDAP server. This
chapter shows you how to install and configure an LDAP server. We recommend you to
use the OpenLDAP or Microsoft Active Directory on Windows system.

OpenLDAP

Installing the OpenLDAP Server

This section shows you how to install an OpenLDAP server on Microsoft Windows XP
system. The OpenlLDAP server software is available for free. You can download it from

http://www.openldap.org/software/download)/.
To install the OpenLDAP server:
1. Double click the OpenLDAP application to start the installation. Follow the default

settings and click Next.

2. Click Browse to locate the installation path from local computer system and then
click Next.

You need to remember the installation path (e.g., C:\OpenlLDAP) located here.

The screenshot for reference is shown as below:

{8 Setup - OpenLDAP P i 3

=
Select Destination Location
“where should OpenlDAP be installed?

'J Setup wil install DpenLDAP inta the fallawing folder.

To continue, click Mest. |f you would like to select a different folder, click Browse.

Browse..

At least 0.7 ME of free disk space is required.

< Back I Mext > I Cancel
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3. Select Full installation, the screenshot for reference is shown as below:

5! Setup - Dpenl DAP =101x]
=

Select Components
“w'hich components should be installed?

Select the components you want ta install; clear the components you do not want to
install. Click Next when you are ready to continue.

[ install OpenLDAP-slurpd as MT service

Current selection requires at least 11.4 MB of disk space.

< Back I Meut > I Cancel

4. Follow the default settings and click Next.

5. Click Finish to finish the installation.

Configuring the OpenLDAP Server

Editing the slapd.conf File

Access the slapd.conf file at the OpenLDAP installation path. Open and edit the

slapd.conf file using your favorite text editor.
1. Add the schema commands.

Find the command include ./schema/core.schema and add the following

commands below it.
These two commands must be added:
include ./schema/cosine.schema
include ./schema/inetorgperson.schema
These commands can be added optionally:
include ./schema/corba.schema
include ./schema/dyngroup.schema
include ./schema/java.schema
include ./schema/misc.schema
include ./schema/nis.schema
include ./schema/openldap.schema
2. Edit the manager information for LDAP phonebook.
Find the commands
Suffix "dc=my-domain, dc=com"
Rootdn "cn=manager,dc=my-domain,dc=com"

Rootpw secret
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Suffix defines the components of the domain name.
Rootdn defines the manager as a management user for accessing the LDAP server.
Rootpw defines the user password for the management user.
For example:
Suffix "dc=yealink,dc=cn"
Rootdn "cn=manager,dc=yealink,dc=cn"
Rootpw secret

The suffix line means that the domain name of the LDAP phonebook is yealink.cn.
The Rootdn line defines a management user named as manager. The Rootpw line

defines the password “secret” for the management user.

If the domain name contains additional components, for example, yealink.com.cn,

the suffix line will be edited as below:
Suffix "dc=yealink,dc=com,dc=cn"
Rootdn "cn=manager,dc=yealink,dc=com,dc=cn"

Rootpw secret

Starting the Slapd Service

To start the slapd service:

1. Click Start->Run.

2. Enter cmd in the pop-up dialogue box and click OK to enter the command line

interface.

3. Execute the cd command to locate the server installation path. For example,

execute cd ¢:\OpenLDAP to locate the server installation path at c:\OpenLDAP.

E BES: G\Windows\system32\cmd.exe

Microsoft Windows [ 6.1.768081
_ﬁ {e? 2889 Microsoft Corporation,

C:\lsers \ylB33dl>cd c:“OpenLDAP

c = “0penLDAP>

4. Execute the command slapd —-d 1 to start the slapd service.

B BEER: C\Windows\system32\cmd.exe [ =] 3]
icrosoft Windows [RR 6.1.76881
soft Corporation. ¥

C:\serssylB331>cd c:~0penLDAP

c :“OpenLDAP>slapd —d 1
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If the service runs successfully, you can find the prompt “slapd starting”.

The screenshot for reference is shown as below:

= BEES: C\Windows\system32\cmd.exe - slapd -d 1 EI@
iceBox % postalCode % businessCategory % description % title % ou % o § street S|E
st $ 1% ¢ % serialMumber % sn % knowledgeInformation 5 labeledURI % cn % name
5 ref § vendorlVersion 5 vendorMame § supportedSASLMechanisms > >

2.5.13.1 <{distinguizhedMameMatch): matchingRulellse: ¢ 2.5.13.1 NAME ‘disting|
uishedMameMatch’ APPLIES ¢ dITRedirect $& associatedMame & = etary 5 documentfAu
thor $ manager % seefilso % roleOccupant % owner % member % distinguishedMame % a
liasedOhjectName % namingContexts % subschemaSubentry % modifiersMame § creators
Name > »

2.5.13.8 <objectldentifierMatch?: matchingRulelse: ( 2.5.13.8 NAME ‘ohjectId

entif ierMatch’ APPLIES ¢ supportedApplicationContext % supportedFeatures § suppo
rtedExtension § supportedControl > >

lzlapd startup: initiated.

hackend_startup: starting "dc=yealink.dc=cn"

hdb_db_open: dhenv_open<.sdatad

klapd starting

Please do not close this window to make sure the LDAP server keeps running.

Adding the Initial Entry to the LDAP Directory

You can add the initial entry to the LDAP directory by using the LDIF file. Create a new
text document, then modify the filename extension as Idif and place the document to
the OpenlLDAP installation path. For example, create a text document named as test.txt,
right click the test.txt document and then select to rename it, modify the filename
extension as Idif. Open the LDIF file with your favorite text editor and input the

corresponding content. The following shows an example of the content of the LDIF file:

dn: dc=yealink,dc=cn
objectclass: dcobject
objectclass: organization
o: xmyealink

dc: yealink

dn: cn=manager,dc=yealink,dc=cn
dc=yealink

objectclass: dcobject

objectclass: organization
cn=manager

Sn: sumer

To add the initial entry using the test.Idif file:

1. Click Start->Run.

2. Execute cmd in the pop-up dialogue box and click OK to enter the command line

interface.
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3. Execute the command cd c:\OpenLDAP to access the OpenLDAP installation path at
c:\OpenLDAP.

4. Execute the command Idapadd -x -D "cn=manager,dc=yealink,dc=cn" -w secret -f
test.ldif to add the initial entry.

The screenshot for reference is shown as below:

= BEE: C\Windows\system32\cmd.exe

rosoft Windous -1.768081
Y f‘[_ﬁ {c> 2889 Microsoft Corporation.

C:“lsers\ylB3il>cd c:“OpenLDAP

c = “OpenLDAP>1dapadd -x -D "cn=manager.dc=yealink.dc=cn" -w secret —f test.ldif
ladding new entry "“dc=yealink.dc=cn"

c = “OpenLDAP>

Configuring the LDAPExploreTool2

The LDAPExploreTool2 application supports running on Windows system. The
application is a graphical LDAP tool that enables you to browse, modify and manage
contact entry on LDAP server.

If you have an LDAPExploreTool2 application installed on your computer, open it now,
otherwise, download the application from http://Idaptool.sourceforge.net/. And then

complete the installation following the wizard.

Creating a Configuration

To create a configuration:

1. Double click the LDAPExploreTool2.exe to run the application.

2. Click File->Configurations.

r—
I LDAPExplorerTool 2
File BCTIRS

Open last configuration

Buit |

3. Click New to create a new configuration.
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4,

5.

Enter a name in the Configuration name field under the Configuration tab.

=
Configuration

Configuration name

Configuration | server | Connection | Option | ssL/TLS |

LDAP|

X

Ok

] Cancel l

Enter the domain name or IP address of the LDAP server in the Server name or IP
field under the Server tab. Check the checkbox of Use default port for the Server

port and Server SSL port.

=
Configuration

Configuratio!

Server name or IP

Server port 389
Server SSL port 636
Version

Connection | Option | SSL/TLS |

10.2.11.162

W Use default port

W Use default port

G302

Test connection

X

0ok ] Cancel |

Enter the user DN and password in the User DN and Password field under the

Connection tab.

The user DN and password correspond with the Rootdn and Rootpw defined in the

slapd.conf file.
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For example, according to the manager information defined in the slapd.conf file:
Rootdn “"cn=manager,dc=yealink,dc=cn"
Rootpw secret

Enter cn=manager,dc=yealink,dc=cn in the User DN field and secret in the
Password field under the Connection tab.

7

Configuration @

Option | sSL/TLS | B

Configuration | Serv

User DN cn=manager,dc= ™ Anonymous login

Password W Store password

Use SSL port
" Yes & No

Use TLS
(TLS is only used

on non SSL ports)

Base DN de=yealink,dc=c Guess value

" Yes & No

Ok | Cancel |

7. Click Guess value to fill the Base DN automatically.

8. Click Test connection to test the connection to the LDAP server. If you encounter an
error or warning during the test, you need to resolve the error or warning first
according to the prompt, and then retry to test the connection.

9. Click OK to accept the change.

Adding Entries

To add entries:

1.

Click File->Configurations, select the configuration created above, and then click
Open.

The screenshot for reference is shown as below:

BER|

+-Root-de=yealink, de=en +/- de=yealink, de=en
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2.

Right click the root entry, and then select Add to add a new entry.

=

Il LDAPExplorerTool 2

File Tools

Copy lo.g

Rename. ..
Delete. ..

Search. ..

=

EEX

+- de=yealink, de=cn

Enter the desired values in the corresponding fields.

Parent DN: It will be automatically generated according to the server configuration.

Entry RDN: The format is cn=XXX. This is a unique identifier for each entry.

Object Class (from schema): Select the structure class which the entry belongs to.

Each structure class has its own must attributes and may attributes. For example,

we select person from the pull-down list of Object class (from schema).

Select the desired attributes for object class.

Must attributes: Double click attributes to add them to the entry node. All attributes

listed in the Must attributes field must be added and each value of the attribute

must be set.

May attributes: Double click the desired attributes to add them to the entry node.

The attributes listed in the May attributes field are optional.

Common attributes are listed in the following table:

Attribute Name Description
cn commonName Full name of the entry.
. First name also called Christian
gn givenName
name.
Surname, last name or family
sn surname

name.

telephoneNumber

telephoneNumber

Office phone number.

homePhone homeTelephoneNumber | Home phone number.
. . Mobile or cellular phone
mobile mobileTelephoneNumber
number.
pager pagerTelephoneNumber | Pager telephone number.
company company Company name.
o organizationName Organization name.

10
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Attribute Name Description
o . Usual department or any sub
ou organizationlUnitName . .
entity of larger entity.

5. Right click the selected attribute and then select Add value.

The screenshot of adding a new entry is shown as below:

Parent DN

Entry RDN

Object class {manual)

-l cn=Hebe,dc=yesli
= sn
Tian
cn
= objectClass

Object class (from schema)

Enter a new value

de=yealink,dc=a
cn=Hebe

[person L]
|i

The value of cn here must be the
same as that of cn configured in the
Entry RDN field.

OK Cancel |

MUST attributes

MAY attributes

SN

objectClass

userPassword
telephoneNumber

description

Attribute( when schema Add

is unavailzble)

Save I Cancel

6. Click Save to confirm the configuration.

7. Repeat steps 2 to 6 to add more contact entries.

You can find the added entries at the left of the LDAP catalogue.

3

Il LDAPExplorerTool 2

=

EEX

File Tools

- Root-de=yealink, de=cn = en=Hebe, de=yealink, de=cn
en=Jacky + telephoneNumber
en=Jonn subschemaSubentry
cn=Ella modi fyTimestamp
structuralObjectClass

+

+

+
+-modifiersName
+ sSn

+ entryCSH
+ creatorsName

+ objectClass

+ hasSub&dinales
4 en

+
+

createTimestamp
entryUUID

11
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Microsoft Active Directory

Installing the Microsoft Active Directory Domain Services

This section shows you how to install an active directory on Microsoft Windows Server
2008 R2 Enterprise 64-bit system.

To install the Microsoft Active Directory Domain Services:

1. Click Start->Run.
2. Enter dcpromo in the pop-up dialogue box and click OK.

3. The Active Directory Domain Services Installation Wizard will appear after a short
while, click Next.

o/ Active Directory Domain Services Installation Wizard |

Welcome to the Active Directory
Domain Services Installation
Wizard

This wizard helps you install Active Directory Domain
Services (AD DS) on this server, making the server an
Active Directony domain controller. To continue, click Mest.

[ Use advanced mode installation

Leam more about the additional options that are
available in advanced mode installation.

More about Active Directory Domain Services

< Back Mex = Cancel

12



Installing and Configuring the LDAP Server

4,

5.

Read the provided information and click Next.

@ Active Directory Domain Services Installation Wizard

Operating System Compatibility
Improved securty settings in Windows Server 2008 and Windows Server 2008 R2 L= =1
affect older versions of Windows

Windows Server 2008 and "Windows Server 2008 R2" domain controllers have a
new more secure default for the security setting named "Allow cryptography algorithms
compatible with Windows NT 4.0." This setting prevents Microsoft Windows and
non-Microsoft SMB "clients” from using weaker NT 4.0 style cryptography algorithms
when establishing securty channel sessions against Windows Server 2008 or
"Windows Server 2008 R2" domain controllers. As a result of this new defautt,
operations or applications that require a security channel serviced by Windows Server
2008 or "Windows Server 2008 R2" domain controllers might fail.

Platforms impacted by this change include Windows NT 4.0, as well a5 non-Microsoft
SMB "clients" and network-attached storage (MAS) devices that do not support
stronger cryptography algonthms. Some operations on clients running versions of
Windows earier than Windows Vista with Service Pack 1 are also impacted. including
domain join operations peformed by the Active Directory Migration Tool or Windows
Deployment Services.

For more information about this setting, see Knowledge Base article 342564
(http://go microsoft. com Awlink /?LinkId=104751).

< Back Next > Cancel |

Mark the Create a new domain in a new forest radio box and click Next.

@! Active Directory Domain Services Installation Wizard

Choose a Deployment Configuration

You can create a domain controller for an existing forest or for a new forest.

" Bxisting forest

| sdda domain contoller to an existing domain

" Create a new domait in &t existing forest
Thiz server will become the first darmain cantrallen in the new domain

%' Create a new domain in a new forest

More about possible deployment configurations

< Back Mext = Cancel

13
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6.

7.

Enter an appropriate domain name for the forest root domain and click Next.

@! Active Directory Domain Services Installation Wizard

Name the Forest Root Domain

The first domain in the forest is the forest root domain. s name is also the name of
the forest.

Type the fully qualified domain name (FQDN) of the new forest root domain.

FQDN of the forest roct domain:

|dap yealink.com

Example: comp .contoso.com

< Back Mext >

Cancel |

The wizard will check if the domain name is in use on the local network.

©! Active Directory Domain Servi
Mame the Forest Roct Domain

The first domain in the forest is the forest roct domain. fts name is also the name of
the forest.

Type the fully qualified domain name (FQDN) of the new forest root domain.

FQDM of the forest root domain:

Idap yealink .

Example: comg
Verifying NetBIOS name...

<Back | MNe> |

Cancel |

Select the desired forest functional level from the pull-down list of Forest functional

level, and click Next.

14
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For more information, click domain and forest functional levels.

@! Active Directory Domain Services Installation Wizard

Set Forest Functional Level
Select the forest functional level.

Forest functional lewvel:
Windows Server 2003 j

Details:

The Windows Server 2003 forest functional level provides all features that are -
available in Windows 2000 forest functional level, and the following addtional
features:
- Linked-value replication, which improves the replication of
changes to group memberships.
- More efficient generation of complex replication topologies
by the KICC.

- Forest trust, which allows organizations to easily share LI
i You will be able to add only domain controllers that are running
- Windows Server 2003 or later to this forest.
More about domain and forest functional levels
< Back Next > Cancel |

8. Select the desired domain functional level from the pull-down list of Domain
functional level, and click Next.

For more information, click domain and forest functional levels.

@! Active Directory Domain Services Installation Wizard

Set Domain Functional Level
Select the domain functional level.

Domain functional level:

Details:

e features available at the Windows Server 2003 domain functional level include a
Il features available at the Windows Server 2000 domain functional level and the
ollowing additional features:
- Constrained delegation. which an application can use to take
advantage of the secure delegation of user credentials by
means of the Kerberos authentication protocal.
- lastLogon Timestamp updates: The lastLogonTimestamp attribute is
updated with the last logon time of the user or computer, and it is LI

' You will be able to add only domain controllers that are runining
Windows Server 2003 or later to this domain.

More about domain and forest functional levels

< Back Mext > Cancel

If you select Windows Server 2008 R2 for the forest functional level, you will not be
prompted to select a domain functional level.

15



Installing and Configuring the LDAP Server

The wizard will check if the DNS is properly configured on the local network.

@1 Active Directory Domain Servi

Set Domain Functional Level
Select the domain functional level.

Domain functional level:

Windows Server 2003 j

elinclude o
Examining DNS corfiguration ... and the

& is
3 -
| | L
Mare about domain and forest functional levels
< Back Next > Cancel |

Select additional options for this domain controller if required, and click Next.

! Active Directory Domain Services Installation Wizard

Additional Domain Controller Options

Select additional options for this domain controller.
¥ DNS server
¥ Global catalog

= Fead-only domain contraller (FODE]
Additional information:

The first domain controller in a forest must be a global catalog server and ;I
cannot be an RODC.

We recommend that you install the DNS Server service on the first domain
controller.

I
More about additional domain controller options
< Back Next > Cancel

You may get a warning telling you that the server has one or more dynamic IP
addresses. We recommend assigning a static IP address to the server.

16
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10. The wizard will prompt a warning about DNS delegation. Since no DNS has been

configured yet, you can ignore the message and click Yes.

@ Active Directory Domain Services Installation Wiz x|

A delegation for this DMS server cannot be created because the
l % authoritative parent zone cannot be found or it does not run
— Windows DNS server, If you are integrating with an existing DNS
infrastructure, you should manually create a delegation to this
DMS server in the parent zone to ensure reliable name resolution
from outside the domain petrilab.local. Otherwise, no action is
reguired.

Do you want to continue?

vy ]

11. Specify the desired paths for the database, log files and SYSVOL folders, and click

Next.

For more information, click placing Active Directory Domain Services files.

@! Active Directory Domain Services Installation Wizard

Location for Database. Log Fles. and SYSVOL
Specify the folders that will contain the Active Directory domain controller
database, log files, and SYSVOL.

For better pefformance and recoverability, store the database and log files on separate

volumes.

Database folder:

Log files folder:

IC:\"-"Iﬁndows\NTDS Browse... |
SYSVOL folder:

IC:Wﬁndows\SYS\u"OL Browse... |

More about placing Active Directory Domain Services files

< Back Net = Cancel

17
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12. Configure the password for the active directory recovery mode, and click Next.
For more information, click Directory Services Restore Mode password.

The password should be complex and at least 7 characters long.

@ Active Directory Domain Services Installation Wizard

Directory Services Restore Mode Administrator Password

The Directory Services Restore Mode Administrator account iz different from the domain
Administrator account.

Assign a password for the Administrator account that will be used when this domain
controller is startted in Directory Services Restore Mode. We recommend that you
choose a strong password.

Password: I.o.o.o.o.

Confirm password: quuuo

More about Directory Services Restore Mode password

< Back Mext = Cancel

13. Review your selection and click Next.

@! Active Directory Domain Services Installation Wizard

Summary

Review your selections:
Configure this server as the first Active Directory domain controller in a new forest. &

The new domain name is "ldap yealink.com”. This is also the name of the new
forest.

The NetBIOS name of the domain is "LDAP".
Forest Functional Level: Windows Server 2003
Domain Functional Level: Windows Server 2003
\Site: Default-First-Site-Name

I]

Ta change an option, click Back. To begin the operation, click Mext.

These settings can be exported to an answer file for use with Tiosieoe |
other unattended operations. Ee =

Mare about using an answer file

< Back Mext > Cancel

18
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The wizard will prompt that the system begins to create the Active Directory Domain
Services.

Active Directory Domain Services Installation Wizard

The wizard is configuring Active Directory Domain Services. This process can take
from & few minutes to several hours, depending an your environment and the options

that you selected.
i'—‘

Securing Kerberos Policy

Cancel |

[ Reboot on completion

14. Click Finish to complete and exit the wizard.

@ Active Directory Domain Services Installation Wizard x|

Completing the Active Directory
Domain Services Installation
Wizard

ctive Directory Domain Services is now installed an thisd
computer for the domain “ldap yealink.com”.

This Active Directony domain controller is assigned to the
site "Default-First-Site-Name". You can manage stes

ith the Active Directory Sites and Services
dministrative tool.

To cloge this wizard, click Finish.

< Back I Finish I Catcel

Installing Active Directory Lightweight Directory Services Role

You should also install the Active Directory Lightweight Directory Services role on
Windows Server 2008 system.

To install the Active Directory Lightweight Directory Services role:

1. Click Start->Administrative Tools->Server Manager.

19



Installing and Configuring the LDAP Server

2. Right click Roles, and then select Add Roles.

3. The Add Roles Wizard will pop up, click Next.

Server Roles

Confirmation
Progress

Results

This wizard helps you install roles on this server. You determine which roles to install based on the tasks you
want this server to perform, such as sharing documents or hosting a Web site.

Before you continue, verify that:

+The Administrator account has & strong password

+ Network settings, such as static IP addresses, are configured
» The latest security updates from Windows Update are installed

If you have to complete any of the preceding steps, cancel the wizard, complete the steps, and then run the
wizard again.

To continue, dick Next.

I™ skip this page by default

cerevovs [ hexts |

| e |

4. Check the Active Directory Lightweight Directory Services checkbox and click Next.

Add Roles Wizard

Before You Begin

ADLDS
Confirmation
Progress

Results

ﬁ Select Server Roles

Select one or more roles to install on this server.
Roles: Description:

Active Directory Certificate Services
[AD C5) is used to create certification
authorities and related role services

[] Active Directory Federation Services that allow you to issue and manage
[¥] Active Directory Lightweight Directory Services certificates used in @ varicty of
[[] Active Directory Rights Management Services applications.

[] application Server

["] DHCP Server

[] DNS Server

[] Fax Server

[] File Services

[] Hyperv

[] Metwork Policy and Access Services
[] Print and Document Services

[] Remote Desktop Services

[] web Server (115)

[] windows Deployment Services
[] windows Server Update Services

More about server roles

<previous |[ next> | el Cancel

x|

5. Follow the default settings and click Next.

6. When the installation is completed, click Close.

20
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After the installation succeeds, you will find the Active Directory Lightweight

Directory Services role listed in roles of the server manager.

E. Server Manager

=

File Action View Help

0 Diagnostics

b
| Configuration ) Roles Summary

~) Roles: 2 of 17installed Fa AddRoles

/i Active Directory Domain Services

(@ Active Directory Lightweight Directory
Services

~) Active Directory Domain Services AD DS Help

logon processes, authentication, and directory searches.

&) Role Status Services
Messages: 1
System Services: 9 Running, 1Stopped
4 |

£} LastRefresh: Today at 13:00 Configure refresh

e sl ol

B3
&AE‘]VE Directory Domain Services the health of the rol led dadd
Active Directory Lightweight Directory Services ) View the heslth of the roles installed n your server and add or remove
3 = roles and features.

il Features bd

Roles Summary Help

52 Remove Roles

Stores directory data and manages communication between users and domains, indud

Go to Active Directory Dor

il

Configuring the Microsoft Active Directory Server

Adding an Entry to the Active Directory

You can add entries to the active directory one by one in this way.

To add an entry to the Active Directory:

1. Click Start->Administrative Tools->Server Manager.

2. Double click Roles->Active Directory Domain Services->Active Directory Users and

Computers.

3. Right click the domain name created above (e.g., [dap.yealink.com), and then

select New->Organizational Unit.

R
Fie Acton View Hebp
s 2m| 0|0 o= HEm
T Server Manager (1L0215)
3 B Roles
= TF Active Drectory Domain Services
= ] Active Drectory Users and Computers [ yi0215.kdag
s & —
BIF Active Drec ';‘“f”h 2
FF Active Drectory
. 51 Features Change Domain...
* j§a Dagnostics Change Domain Controller.
@ J" Configuration Raize domain functonal level...
® Lﬁ'_d;sw,* Operations Masters...
Al Tasks
View
Refresh
Export List...
Properties.
Hebp
<« J 2l | 2
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4. Enter the desired name of the organizational unit.

New Object - Organizational Unit x|

--;5 Cregtein:  Idap yealink.com/

MName:

Iyealink|

¥ Protect container from accidertal deletion

oK |  Cancel Help

5. Click OK to accept the change.

6. Right click the organizational unit created above, and then select New->Contact.

[ serermomoer T
Fle Acton  View e
e 2im & 0(RD LB
s Server Manager (YL0215)
=P

= T Active Drectory Doman Services

= 3 Actve Drectory Users and Computers [ y0215 dag There are o Rems £ show i this view, More Actors »
= 33 dap.yesink com
@ ] Bultn
i Computers
% ) Domain Controlers
ForegnSeartyPrncpals
Managed Service Accounts
! Users
4 Acove ore Dslegate Contrel..
F actve Orectos  MOVE--:
+ g§i Featwres And...
] T cmose
i Confraton g ey »
¥ I Storage
View “ Gop
InetOrgPerson
Qs mlmagng PSP
Delete MIMQ Queue Alas
Rename Organizational Unt
Refresh Printer
Export Ust. User
Shared Folder
Propertes
4 Heb il | L3}
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7. Enter the desired values in the corresponding fields.

x
8) Create in:  |dap yealink com, ealink
First name: Isan Initials: |52
Last name: Irhang
Full name: Isan sz. zhang
Display name: ||
oK I Cancel
8. Click OK to accept the change.
9. Double click the contact created above.
10. Configure more properties of the contact.
san sz. zhang Properties ed |

General |Addr&as| T&Iephon&al Drganizationl MemberDFI

& =an sz.

zhang

First name: Initials: Isz—
Last name: Iﬂ"lang

Digplay name: I

Description: I

Office: I

Telephone number: I Cther... |
E-mail: I

Web page: I Cther... |

11. Click OK to accept the change.
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Adding Entries to the Active Directory Using the Idifde Tool

You can use a LDIF file to perform a batch import of all entries to the active directory.

Create a new text document and then modify the filename extension as Idif. For

example, create a text document named as test.txt, right click the test.txt document and

then select to rename it, modify the filename extension as Idif. Open the LDIF file with

your favorite text editor and input the corresponding content. The following shows an

example of the content of the LDIF file:

##Create a new organizational unit##

changetype: add

objectClass: top

objectClass: organizationalUnit
ou: yealink

name: yealink

##create a new contact##

changetype: add
objectClass: top
objectClass: person
objectClass: organizationalPerson
objectClass: contact
cn: san zhang

sn: zhang
givenName: san
initials: zs

name: san zhang
ipPhone: 2336
mobile: 15557107369

dn: OU=yealink,DC=Idap,DC=yealink,DC=com

dn: CN=san zhang,OU=yealink,DC=I|dap,DC=yealink,DC=com

To import the test.Idif file:

1. Click Start->Run.

2. Enter cmd in the pop-up dialogue box and click OK to enter the command line

interface.
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3.

4.

Execute the command cd to access the path of the test.ldif file. For example,

execute cd c:\Windows to access the path of the test.Idif file at c:\Windows.

[z+] Administrator: G:\Windows\system32\cmd.exe = | Ellﬂ
Microsoft Windows [Version 6.1.768081]
Copyright <c> 288? Microsoft Corporation.

C:Users“dmninistrator?cd c:~Windows

c:“Mindows>

Execute the command Idifde -i -f

All rights reserved.

test.Idif to import the file.

If the entries are added successfully, you can find the prompt “n entries modified

successfully” ("n" indicates the number of the added entries).

The screenshot for reference is shown as below:

[5+] Administrator: G\Windows\system32\cmd.exe

Microsoft Windows [Uersion 6.1.76881
Copyright <c> 2BA? Microsoft Corporation.

C:\lsers“Administrator>cd c:“Windows

c:“\Mindows>1difde -i —f test.ldif
Connecting to “ylB215.1dap.yealink.com"

Logging in as current user using S8PI
Importing directory from file "test.ldif™
Loading entries...

2 entries modified successfully.

The command has completed successfully

c:“Windows>

All rights reserved.

You can also export the existing entries on the active directory into a *.1dif file first,
modify the file, and then import the modified file into the active directory. For more
information, refer to the network resource.
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Adding Entries to the Active Directory Using the Csvde Tool

You can also use a CSV file to perform a batch import of all entries to the active directory.
Create a new document using a spreadsheet application (e.g., Microsoft Excel) and
then save the document to your local computer using “Save as” in the format “*.csv”.
For example, create a document named as test.xls, click “Save as” to save the
document as test.csv. Open the CSV file with the spreadsheet application and input the
corresponding content. The following shows an example of the CSV file content:

E]  test.esv & X

A E c D E F G H I I
initial
s

i DN objectClass ou name cn sn givenName ipPhone mobile

OU=yealink, DC=1dap, organizationallni
> DC=yealink,DC=com t
CN=san

:i‘z:?ggi;z:};ﬁ’gg contact san zhang san zhang san zhang sZ 1111 123456789001

yealink yealink

3 =com

CN=si

1i, OU=yealink, DC=1d contact
ap, DC=yeal ink, DC=co

CN=wu

TZ’;ﬁSEﬁ;Z:}ﬁEEE contact wu wang Wi wang wang  wu ww 3333 123456789003

si 1i si 1i 1i si sl 2222 123456789002

5 com

The first line lists the attributes of the entries.

The second line lists the values of an organizational unit in the corresponding attribute
columns.

The other lines list the values of contacts in the corresponding attribute columns.

To import the test.csv file:

1. Click Start->Run.

2. Enter cmd in the pop-up dialogue box and click OK to enter the command line
interface.

3. Execute the command cd to access the path of the test.csv file. For example,

execute cd c:\Windows to access the path of the test.csv file at c:\Windows.

[z+] Administrator: G:\Windows\system32\cmd.exe

Microsoft Windows [Version 6.1.768681
Copyright <c> 28B8? Microsoft Corporation. All rights reserved.

C:\lsers“Administrator>cd c:“Windows

c: Windows >

4, Execute the command csvde -i -f test.csvto import the file.
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If the entries are added successfully, you can find the prompt “n entries modified

successfully” ("n" indicates the number of the added entries).

The screenshot for reference is shown as below:

Windows\system32\cmd.exe

rsion 6.1.76801]1
Copyright <c> 288? Microsoft Corporation.

C:sUserssAdministrator?ed c:ixWindows

c:“\Windows>csvde —i —f test.csv
Connecting to "(null>"

Logging in as current user using S8PI
Importing directory from file "test.cse'
Loading entries.....

4 entries modified successfully.

The command has completed successfully

c:sWindows >

All rights reserved.

The csvde tool cannot edit or delete the existing entries on the active directory.

You can also export the existing entries on the active directory into a *.csv file first,
modify the file, and then import the modified file into the active directory. For more
information, refer to the network resource.

Creating User Accounts

You can create user accounts to allow access to resources on the active directory. User

accounts are very important and useful.
To create a user account:

1. Click Start->Administrative Tools->Server Manager.

2. Double click Server Manager->Roles->Active Directory Domain Services->Active

Directory Users and Computers.
3. Select the domain name created above (e.g., Idap.yealink.com).

4. Right click Users, and then select New->User.

(T R
Fle Acton  Vew Heb
- | £ 0 X % H

Users 15 objects [Fiter Actvated] Actions
I | 1

Buiten account foe admied,

Members in the group can.
Members of ths group are
Members In ths group can.
o ad

Members in th group can.

Buit-n account for guest
Servers n s group can
Members of ths group are
Desgrated admest atirs.

q 2

Create a new object..
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5.

6.

Enter desired values in the corresponding fields and click Next.

New Dbject - User

z) Create in:  |dap yealink.com/Users

User logon name:

First name: Isan Initials: Isz
Last name: Izhang
Full name: Isan sz. zhang

IIdapuser‘l

User logon name (pre-Windows 2000):

I @ldap yealink .com j

ILDAF‘\ Ildapuser‘l

< Back

Mead = Cancel

Enter the password for the user, select the appropriate options and click Next.

The password should be a combination of upper case letters, lower case letters,

numbers and special characters.

&) Create in:  |dap yealink.com/Users

Mew Object - User x|

Password: Iii----ooo---

Confimm password:

v User must change password at next logon
[ User cannot change password

[~ Password never expires

[ Accourt is disabled

< Back

MNex > Cancel
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7. Click Finish to complete the creation of the user account.

New Object - User |

& Create in:  Idap yealink com/Users

When you click Finish, the following object will be created:

Full name: san sz. zhang :l
User logon name: Idapuser] @ldap yealink.com

The user must change the password at next logon.
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Configuring Yealink IP Phones

LDAP is disabled on IP phones by default. You can configure LDAP via web user

interface or using configuration files. The followings take configurations of a SIP-T28P IP

phone running firmware version 72 as examples.

To configure LDAP feature via web user interface:

1.
2.

Press the OK key on the phone when it is idle to obtain the IP address.

Enter the IP address (e.g., http://192.168.0.10 or 192.168.0.10) in the address bar of

web browser on your PC and then press Enter.

Enter the user name and password in the login page.

The default login user name is admin (case-sensitive) and the password is admin

(case-sensitive).

Click on Directory->LDAP.

Select Enabled from the pull-down list of Enable LDAP.

Enter the desired values in the corresponding fields.

The screenshot for reference is shown as below:

Yealink | s

Local Directory

Remote Phone
Book

Phone Call Info
LDAP
Multicast IP

Setting

‘ Status H Account H Network

Enable LDAP

LDAP Name Filter

LDAP Number Fitter
Server Address

Port

Base

Username

Password

Max Hits (1~32000)
LDAP Name Attributes
LDAP Number Attributes
LDAP Display Name
Protocol

LDAP Lookup For Incoming Call

LDAP Sorting Results

Enabled Ad
[(iten=e)sn=2e))
(|(telephoneNumber=%)(m
[to29250
Beo
[oosees
]
[
[telephonenumber mobike ipi
o

Version 3 v
Enabled v

Enabled v

| DSSKey || Features || Settings

QOO OOOOOOOO®O®O®®

Directory ] Security ‘

NOTE

LDAP
The LDAP parameters for
administrator.

7.

Click Confirm to accept the change.
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LDAP Attributes on Web User Interface

Enable LDAP

Description This parameter enables LDAP feature on the IP phone.

Valid Value Enabled or Disabled

Default Value | Disabled

LDAP Name Filter

Description This parameter specifies the name attributes for LDAP searching.
The format of the search filter is compliant to the standard string
representations of LDAP search filters (RFC 2254). The “*” symbol in
the filter stands for any character. The “%"” symbol in the filter stands
for the entering string used as the prefix of the filter condition.

Example o (|(cn=%)(sn=%))
When the name prefix of the cn or sn of the contact record
matches the search criteria, the record will be displayed on the
phone LCD screen.

e (&(cn=%*)(sn=%))
When the name prefix of the sn of the contact record matches
the search criteria, the record will be displayed on the phone
LCD screen.

e ({(cn=%))
When the name prefix of the cn of the contact record does not

match the search criteria, the record will be displayed on the
phone LCD screen.

LDAP Number Filter

Description This parameter specifies the number attributes for LDAP searching.
The format of the search filter is compliant to the standard string
representations of LDAP search filters (RFC 2254). The “*” symbol in
the filter stands for any number. The “%" symbol in the filter stands
for the entering number used as the prefix of the filter condition.

Examples e (|(telephoneNumber=%)(Mobile=%)(ipPhone=%))

When the number prefix of the telephoneNumber, Mobile or
ipPhone of the contact record matches the search criteria, the

record will be displayed on the phone LCD screen.
o (&(telephoneNumber=*)(Mobile=%))

When the number prefix of the Mobile of the contact record

matches the search criteria, the record will be displayed on the

phone LCD screen.
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es

Server Address

Description This parameter specifies the domain name or IP address of the LDAP
server.

Default Value | Blank

Example e 192.168.1.100
e |dap.company.com

Port

Description This parameter specifies the LDAP server port.

Default Value | 389

Base

Description This parameter specifies the LDAP search base which corresponds
to the location in the LDAP phonebook. The search base narrows the
search scope and decreases directory search time.

Example e dc=yealink,dc=cn

Username

Description This parameter specifies the user name to login the LDAP server. If
the LDAP server allows anonymous to login, this parameter can be
left blank. Otherwise you need to provide the user name to access
the LDAP server.

Password

Description This parameter specifies the password to login the LDAP server. If

the LDAP server allows anonymous to login, this parameter can be
left blank. Otherwise you need to provide the password to access
the LDAP server.

Max Hits (1~32000)

Description

This parameter specifies the maximum number of the search results
to be returned by the LDAP server. If the value of the “Max.Hits” is
blank, the LDAP server will return all searched results. Please note
that a very large value of the “Max. Hits” will slow down the LDAP
search speed, therefore the parameter should be configured
according to the available bandwidth.

Default Value

50

LDAP Name Attributes

Description

This parameter specifies the name attributes of each record to be
returned by the LDAP server. This parameter compresses the search
results. The user can configure multiple name attributes separated
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by space.
Example e cnsndisplayName
This requires the “cn”, “sn” and “displayName” attributes set
for each contact record on the LDAP server.
e givenName
This requires the “givenName” attribute set for each contact
record on the LDAP server.
LDAP Number Attributes
Description This parameter specifies the number attributes of each record to be
returned by the LDAP server. This parameter compresses the search
results. The user can configure multiple number attributes separated
by space.
Example e  Mobile telephoneNumber ipPhone
This requires the “Mobile”, “telephoneNumber” and “ipPhone”
attributes set for each contact record on the LDAP server.
LDAP Display Name
Description This parameter specifies the display name of the contact record
displayed on the LCD screen. This parameter value must start with
“%" symbol.
Example e  %cn
The desired display name of the contact record is the cn
attribute.
Protocol
Description This parameter specifies the LDAP protocol version supported on the
phone. Make sure the protocol value corresponds with the version
assigned on the LDAP server.
Valid Value Version 2 or 3
Default Value | Version 3
LDAP Lookup For Incoming Call
Description This parameter enables the phone to perform an LDAP search when
receiving an incoming call.
Valid Value Enabled or Disabled
Default Value | Disabled
LDAP Sorting Results
Description This parameter enables the phone to sort the search results in
alphabetical order or numerical order.
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Valid Value Enabled or Disabled

Default Value | Disabled

Example for Configuration

You can use the following settings as a starting point and adjust the filter and display
attributes according to your requirements.

Enable LDAP: Enabled

LDAP Name Filter: (| (cn=%)(sn=%))

LDAP Number Filter: (| (telephoneNumber=%)(Mobile=%)(ipPhone=%))
Server Address: 192.168.1.30

Port: 389

Base: dc=yedlink,dc=cn

Username: cn=manager,dc=yealink,dc=cn

Password: secret

Max Hits (1~32000): 50

LDAP Name Attributes: cn sn

LDAP Number Attributes: Mobile telephoneNumber ipPhone
LDAP Display Name: %cn

Protocol: Version 3

LDAP Lookup For Incoming Call: Enabled

LDAP Sorting Results: Enabled

To use LDAP feature, you need to configure a DSS key as an LDAP key.
To configure an LDAP key via web user interface:

1. Log into the web user interface of the phone.
2. Click on DSSKey->Memory Key (or Line Key).
SIP-T22P/T21P[T46G[T42G/T41P IP phones only support line keys.
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3. Inthe desired memory key (or line key) field, select LDAP from the pull-down list of

Type.

Yealink |

Memory Key
Line Key
Programable Key

Ext Key

Status Account Network DSSKey

o
Log Out

Features Settings Directory Security

Key Tvpe Walue Line Extension
Memary 1 |LDAP v [ |
Key Type
Memory2  [Nja ] || The free function key ‘Types'
Speed Dial, Key Event,
Memory 3 [N/ v [ | Intercarm.
Memory 4 | MA v [ | Key Event
Key events are predefined
Memory 5 | MA v [ | shortcuts to phone and call
functions.
Memary 6 | MfA v [ |
Intercom
Memory 7| MiA v | | Enable the 'Tntercom’ mode and
it is useful in an office
Memory 8 MNfA v | | environment as a guick access
to connect to the operator or
Memory 9 | MfA v [ | the secretary.
Mernary 10 | NjA v |

4. Click Confirm to accept the change.

To configure LDAP feature using configuration files:

1. Add/Edit LDAP parameters in configuration files.

The following table shows the information of parameters:

Parameter Descriptions

Web Setting Path

Idap.enable

Idap.name_filter

Idap.number _filter

Idap.host
specify the LDAP
Idap.port attributes.
Refer to the
Idap.base introduction above
for more
Idap.user information.

Idap.password

Idap.max_hits

Idap.name_attr

Idap.numb_attr

These parameters

Contacts->LDAP->Enable
LDAP

Directory->LDAP->LDAP

Name Filter

Directory->LDAP->LDAP

Number Filter

Directory->LDAP->Server
Address

Directory->LDAP->Port

Directory->LDAP->Base

Directory->LDAP->Username

Directory->LDAP->Password

Directory->LDAP->Max Hits
(1~32000)

Directory->LDAP->LDAP
Name Attributes

Directory->LDAP->LDAP
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Parameter

Descriptions

Web Setting Path

Idap.display_name

Idap.version

Idap.call_in_lookup

Idap.ldap_sort

Number Attributes

Directory->LDAP->LDAP
Display Name

Directory->LDAP->Protocol

Directory->LDAP->LDAP

Lookup For Incoming Call

Directory->LDAP->LDAP

Sorting Results

Upload configuration files to the root directory of the provisioning server and trigger

IP phones to perform an auto provisioning for configuration update.

For more information on auto provisioning, refer to Yealink IP Phones Auto

Provisioning Guide.

To configure an LDAP key using configuration files:

Add/Edit the LDAP key parameters in configuration files.

You can configure either a memory key or a line key as an LDAP key. The following

table shows the information of parameters:

Parameter

Description

Value

memorykey.x.type
(not applicable to
SIP-T22P, SIP-T21P
SIPT46G, SIP-T42G
and SIP-T41P IP
phones)
(SIP-T26P/T28P: X

ranges from 1 to 10)

Configures a memory key as an
LDAP key on the IP phone.

38

linekey.x.type
(SIP-T21P: X ranges
from 1 to 2.
SIP-T22P/T26P: X
ranges from 1 to 3.
SIP-T28P: X ranges
from 1to 6
SIP-T46G: X ranges
from 1 to 27

SIPT42G/T41P: X
ranges from 1 to 15)

Configures a line key as an
LDAP key on the IP phone.
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Upload configuration files to the root directory of the provisioning server and trigger
IP phones to perform an auto provisioning for configuration update.

For more information on auto provisioning, refer to Yealink IP Phones Auto
Provisioning Guide.
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Using LDAP Phonebook on Yealink IP Phones

You can press the LDAP key to access the LDAP phonebook. Enter the search criteria to
search a contact from LDAP phonebook, add local contacts from LDAP phonebook, and
dial a contact from LDAP phonebook. You can also enable the phone to perform an

LDAP search when dialing out or receiving an incoming call.
To search a contact from the LDAP phonebook:

1. Pressthe LDAP key to access the LDAP search screen.
The LCD screen prompts “None”.

(%] 0/0 )

None

Back ]f Abc ]f Delete]

2. Enter a few continuous characters of the contact name or continuous digits of the
contact phone number using the keypad.

(& H 0/1 |

Hebe 123456

Back ]f Abc ]f Delete]

The contacts whose name or phone number matches the characters entered will

appear on the LCD screen.

3. Press @ or @ to select the desired contact.

4. Do one of the following:

- Press the Option soft key and then select Detail to view the detail information

of the contact.

- Press the Option soft key and then select Add to Contacts to add the contact to
local.

- Press the dial soft key to dial out.

If the LDAP Lookup For Incoming Call parameter is enabled on the phone, the phone will
perform an LDAP search when receiving an incoming call. If there is a contact record
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which matches the caller ID, the contact name will be displayed on the phone LCD
screen as the calling line identification.

The screenshot of the LCD screen for reference is shown as below:

=528
Hebe
123456
nun 3
/
Answer ]f Furward” Silence ]f Reject

The Search Source List In Dialing feature enables the phone to perform an LDAP search
when you enter the digits using the keypad in the dialing interface. For more
information on the configuration of the Search Source List In Dialing feature, refer to

Yealink phone-specific user guide.

If there are contact records matching the search criteria, the contact records will be
listed on the phone LCD screen. You can select the desired contact record to dial out.
The contact name will be displayed on the phone LCD screen during the call.

The screenshot of the LCD screen for reference is shown as below:

L 2828: R 2628
1
Hebe{123456)
/
Send ]f 123 ]f Delete ]f Cancel
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Customer Feedback

We are striving to improve our documentation quality and we appreciate your feedback. Email

your opinions and comments to DocsFeedback@yealink.com.
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