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LDAP Directory  on Yealink IP Phones 

LDAP stands for Lightweight Directory Access Protocol, which is a client-server protocol for 

accessing a directory service. LDAP is a directory service protocol that runs over TCP/IP. The 

nitty -gritty details of LDAP are defined in RFC 1777 "Lightweight Directory Access Protocol". 

The following gives an overview of LDAP from a user's perspective. 

What kind of information can be stored in  the directory?  

The LDAP information model is based on entries. An entry is a collection of attributes that has a 

globally-unique Distinguished Name (DN). The DN is used to refer to the entry unambiguously. 

Each of the entry's attributes has a type and one or more values. The types are typically 

mnemonic strings, like "cn" for common name, or "mail" for email address. The syntax of values 

depends on the attribute type. For example, a cn attribute might contain the value ǰBabs 

JensenǱ. A mail attribute might contain the value "babs@example.com". 

How is the information arranged?  

In LDAP, directory entries are arranged in a hierarchical tree-like structure. Traditionally, this 

structure reflected the geographic and/or organizational boundaries. Entries representing 

countries appear at the top of the tree. Below them are entries representing states and national 

organizations. Below them might be entries representing organizational units, people, printers, 

documents, or just about anything else you can think of. The following  shows an example of 

LDAP directory tree using traditional naming. 

 

LDAP enables you to locate organizations, individuals, and other resources such as files and 

devices in a network, whether on the Internet or on a corporate intranet , and whether or not you 

know the domain name, IP address, or geographic whereabouts. An LDAP directory can be 
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distributed among many servers on a network, then replicated and synchronized regularly. LDAP 

is particularly useful for storing information that y ou wish to read from many locations, but 

update infrequently.  

This guide provides configurations on the LDAP server and IP phones, and applies to the 

following Yealink IP phones: 

 ̧ CP860 IP phones running firmware version 71 or later 

 ̧ SIP-T48G, SIP-T46G, SIP-T42G and SIP-T41P IP phones running firmware version 73 or later 

 ̧ SIP-T58V/A, SIP-T56A, SIP VP-T49G, SIP-T40P, SIP-T29G, SIP-T27P, SIP-T23P/G, SIP-T21(P) 

E2 and W56P IP phones running firmware version 80 or later 

 ̧ SIP-T48S, SIP-T46S, SIP-T42S, SIP-T41S, SIP-T40G, SIP-T27G and SIP-T19(P) E2 and W52P IP 

phones running firmware version 81 or later 
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An LDAP server is essentially a bit like an SQL server, which is mainly used for storing/retriev ing 

information about people  (such as contacts). The configuration settings on the phone will be 

altered depending on how the LDAP server is configured. 

Before using LDAP feature on IP phones, you must make sure the LDAP server is prepared 

properly, otherwise you need to install and configure an LDAP server. This chapter shows you 

how to install and configure an LDAP server. We recommend you to use the OpenLDAP, 

Microsoft Active Directory , Microsoft  Active Directory Application Mode (ADAM)  or Sun One 

Directory Server on Windows system. 

OpenLDAP 

Installing the OpenLDAP Server 

This section shows you how to install an OpenLDAP server on Microsoft Windows 2007 system. 

The OpenLDAP server software is available for free. You can download it from 

http://www.userbooster.de/en/download/openldap -for-windows.aspx?l=en. 

To install the OpenLDAP server:  

1. Double click the OpenLDAP application to start the installation. You will be prompted for 

the installation. 

 

2. Click Yes to continue the installation. 

3. Follow the default settings and click Next  until  the Destination Folder  screen appears. 

  

http://www.userbooster.de/en/download/openldap-for-windows.aspx?l=en
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4. Click Change to locate the installation path from local computer system and then click 

Next . 

You need to remember the installation path (e.g., D:\OpenLDAP) located here. 

The screenshot for reference is shown as below: 

 

5. Follow the default settings and click Next  until  the Ready to install  OpenLDAP for 

Windows screen appears. 

 

6. Click Install  to start the installation.  

7. Click Close to exit the Setup Wizard. 

For more information on how to install the OpenLDAP server for windows, refer to the website 

online: 

http://www.userbooster.de/en/support/feature -articles/openldap-for-windows-installation.aspx

. 

  

http://www.userbooster.de/en/support/feature-articles/openldap-for-windows-installation.aspx
http://www.userbooster.de/en/support/feature-articles/openldap-for-windows-installation.aspx
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Configuring the OpenLDAP Server 

Editing the slapd.conf File  

Access the OpenLDAP installation path. Edit the manager information for LDAP. 

1. Open and edit the slapd.conf file using your favorite text editor . 

Find the commands  

Suffix   "dc= maxcrc , dc=com"  

Rootdn   "cn= Manager,dc= maxcrc ,dc=com"  

Suffix defines the components of the domain name. 

Rootdn defines the manager as a management user for accessing the LDAP server. 

For example: 

Suffix   "dc=yealink,dc=c om "  

Rootdn   "cn= Manager,dc=yealink,dc= com  "  

The suffix line means that the domain name of the LDAP directory is yealink.com. The 

Rootdn line defines a management user named as Manager.  

If the domain name contains additional components, for example, yealink.com.cn, the suffix 

line will be edited as below: 

Suffix   "dc=yealink, dc=com, dc=cn"  

Rootdn   "cn= Manager,dc=yealink, dc=com, dc=cn"  

2. Double click slappasswd.exe to modify the user password for the management user. Type 

the new password twice. 

 

Starting the Slapd Serv ice 

To start the slapd  service: 

1. Click Start ->Run. 

2. Enter cmd  in the pop -up dialogue box and click OK to enter the command line interface. 

3. Access the server installation path. For example, execute the following commands to access 
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the server installation path at D:\ OpenLDAP. 

 

4. Execute the command slapd.exe -d 1 -f ./slapd.conf  to start the slapd service. 

 

If the service runs successfully, you can find the prompt ǰslapd starting Ǳ. 

The screenshot for reference is shown as below: 

  

Please do not close this window to make sure the LDAP server keeps running. 

Add ing  the I nitial Entr y to the LDAP Directory  

You can add the initial entry to the LDAP directory by using the LDIF file. Create a new text 

document, then modify the filename extension as ldif  and place the document to the OpenLDAP 

installation path . For example, create a text document named as test.txt, right click the test.txt 

document and then select to rename it, modify the filename extension as ldif. Open the LDIF file 

with your favorite text editor and input the  corresponding content. The following shows an 

example of the content of the LDIF file: 

dn: dc=yealink,dc=com  

objectClass: top  

objectClass: dcObject  

objectClass: domain  

dc: yealink  
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dn: ou=roles,dc=yealink,dc=com  

objectClass: top  

objectClass: organizationalUnit  

ou: roles  

 

dn: ou=people,dc=yealink,dc=com  

objectClass: top  

objectClass: organizationalUnit  

ou: people  

 

dn: cn=Test Users,ou=roles,dc=yealink,dc=com  

objectClass: groupOfUniqueNames  

cn: Test Users 

uniqueMember: 

uid=sspecial,ou=people,dc=yealink,dc=com  

uniqueMember: 

uid=jbloggs,ou=people,dc=yealink,dc=com  

 

dn: cn=Special Users,ou=roles,dc=yealink,dc=com  

objectClass: groupOfUniqueNames  

cn: Special Users 

uniqueMember: 

uid=sspecial,ou=people,dc=yealink,dc=com  

 

dn: cn=Admin Users,ou=roles,dc=yealink,dc=com  

objectClass: groupOfUniqueNames  

cn: Admin Users  

uniqueMember: 

uid=admin,ou=people,dc=yealink,dc=com  

 

dn: uid=admin,ou=people,dc=yealink,dc=com  

objectClass: person  

objectClass: inetOrgPerson  

cn: State App  

displayName: App Admin  

givenName: App  

mail: admin@fake.org  
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sn: Admin  

uid: admin  

userPassword: adminpassword  

 

dn: uid=jbloggs,ou=people,dc=yealink,dc=com  

objectClass: person  

objectClass: inetOrgPerson  

cn: Joe Bloggs  

displayName: Joe Bloggs  

givenName: Joe  

mail: jbloggs@fake.org  

sn: Bloggs  

uid: jbloggs  

userPassword: password  

 

dn: uid=sspecial,ou=people,dc=yealink,dc=com  

objectClass: person  

objectClass: inetOrgPerson  

cn: Super Special  

displayName: Super Special  

givenName: Super  

mail: sspecial@fake.org  

sn: Special 

uid: sspecial  

userPassword: password</span>  

To add the initial entry using the test .ldif file:  

1. Click Start ->Run. 

2. Execute cmd  in the pop -up dialogue box and click OK to enter the command line interface. 

3. Access the server installation path. For example, execute the following commands to access 

the server installation path at D:\ OpenLDAP. 
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4. Execute the command slapadd -v -l ./test.ldif  to add the initial entry . 

The screenshot for reference is shown as below: 

 

Configuring the  LDAPExploreTool2  

The LDAPExploreTool2 application supports running on Windows system. The application is a 

graphical LDAP tool that enables you to browse, modify and manage contact entry on LDAP 

server. 

If you have an LDAPExploreTool2 application installed on your computer, open it now , otherwise, 

download the application from http://ldaptool.sourceforge.net/ . And then complete the 

installation following the wizard . 

Creating a Configuration  

To create a configuration:  

1. Double click the LDAPExploreTool2.exe to run the application. 

2. Click File->Configurations . 

 

3. Click New  to create a new configuration . 
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4. Enter a name in the Configuration name field under the Configuration  tab. 

 

5. Enter the domain name or IP address of the LDAP server in the Server name or IP  field 

under the Server tab. Check the checkbox of Use default port  for the Server port  and 

Server SSL port. 

 

6. Enter the user DN and password in the User DN and Password field under the Connection  

tab.  

The user DN and password correspond with the Rootdn and Rootpw defined in the 

slapd.conf file. 

For example, according to the manager information defined in the slapd.conf file: 

Rootdn   "cn= Manager,dc=yealink,dc=c om "  

Rootpw   secret 
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Enter cn= Manager,dc=yealink,dc=c om  in the User DN field and secret in the Password 

field under the Connection  tab. 

  

7. Click Guess value to fill the Base DN automatically. 

8. Click Test connection  to test the connection to the LDAP server. If you encounter an error 

or warning during the test, you need to resolve the error or warning first according to the 

prompt, and then ret ry to test the connection.  

9. Click OK to accept the change. 

Adding Entries  

To add entries:  

1. Click File->Configurations , select the configuration created above, and then click Open. 

The screenshot for reference is shown as below: 
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2. Right click the root entry , and then select Add to add a new entry. 

 

3. Enter the desired values in the corresponding fields. 

Parent DN:  It will be automatically generated according to the server configuration . 

Entry RDN:  The format is cn=XXX. This is a unique identifier for each entry. 

Object Class (from schema):  Select the structure class which the entry belongs to . Each 

structure class has its own must attributes and may attributes. For example, we select 

person  from the pull -down list of Object class (from schema) . 

4. Select the desired attributes for object class. 

Must attributes:  Double click attribute s to add them to the entry node.  All attributes listed 

in the Must attributes  field must be added and each value of the attribute must be set.  

May attributes:  Double click the desired attribute s to add them to the entry node.  The 

attributes listed in the May attributes field are optional.  

Common attributes are listed in the following table:  

Attribute  Name Description  

cn commonName Full name of the entry. 

gn givenName 
First name also called Christian 

name. 

sn surname 
Surname, last name or family 

name. 

telephoneNumber  telephoneNumber  Office phone number. 

homePhone homeTelephoneNumber Home phone number. 

mobile mobileTelephoneNumber Mobile or cellular phone number.  

pager pagerTelephoneNumber Pager telephone number. 

company company Company name. 

o organizationName Organization name. 

ou organizationlUnitName  
Usual department or any sub 

entity of larger entity.  

5. Right click the selected attribute and then select Add value . 
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The screenshot of adding a new entry is shown as below: 

  

6. Click Save to confirm the configuration.  

7. Repeat steps 2 to 6 to add more contact entries. 

You can find the added entr ies at the left of the LDAP catalogue. 

 

Microsoft Active Directory  

Installing the Microsoft Active Directory Domain Services 

This section shows you how to install an active directory on Microsoft Windows Server 2008 R2 

Enterprise 64-bit  system. 

To install the Microsoft Active Directory Domain S ervices: 

1. Click Start ->Run. 

2. Enter dcpromo  in the pop -up dialogue box and click OK. 

The value of cn here must be the same 

as that of cn  configured in the Entry 

RDN field. 
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3. The Active Directory Domain Services Installation Wizard will appear after a short while, 

click Next . 

 

4. Read the provided information and click Next . 
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5. Mark the Create a new domain in a new forest  radio box and click Next . 

 

6. Enter an appropriate domain name for the forest root domain and click Next . 
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The wizard will check if the domain name is in use on the local network. 

 

7. Select the desired forest functional level from the pull -down list of Forest function al level, 

and click Next . 

For more information , click domain and forest functional level s. 

 

8. Select the desired domain functional level from the pull -down list of Domain function al 

level, and click Next . 
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For more information, click domain and forest functional level s. 

 

  

The wizard will check if the DNS is properly configured on the local network. 

 

  

If you select Windows Server 2008  R2 for the forest function al level, you will not  be 

prompted to select a domain function al level. 
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9. Select additional options for this domain controller if required, and c lick Next . 

 

 

 

10. The wizard will prompt a warning about DNS delegation. Since no DNS has been 

configured yet, you can ignore the message and click Yes. 

 

11. Specify the desired paths for the database, log files and SYSVOL folders, and click Next . 

  

You may get a warning telling you that the server has one or more dynamic IP addresses. We 

recommend assigning a static IP address to the server. 
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For more information , click placing Active Directory Domain Services files . 

 

12. Configure the password for the active directory recovery mode, and click Next . 

For more information , click Directory Services Restore Mode password . 

The password should be complex and at least 7 characters long. 
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13. Review your selection and click Next . 

 

The wizard will prompt that the system begins to create the Active Directory Domain 

Services. 
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14. Click Finish to complete the installation and exit the wizard. 

 

Installing Active Directory Lightweight Directory Services Role 

You should also install the Active Directory Lightweight Directory Services role on Windows 

Server 2008 system. 

To install the Active Directory Lightweight Directory Services role:  

1. Click Start ->Administrative Tools ->Server Manager . 

2. Right click Roles, and then select Add Roles . 

3. The Add Roles Wizard will pop up , click Next . 
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4. Check the Active Directory Lightweight Directory Services  checkbox and click Next . 

 

5. Follow the default settings and click Next . 

6. When the installation is completed, click Close. 

After the installation succeeds, you will find the Active Directory Lightweight Directory 

Services role listed in roles of the server manager. 

 

Configuring the Microsoft Active Directory Server  

Add ing  an Entry  to the Active Directory  

You can add entries to the active directory one by one in this way. 

To add an entry  to the Active Directory : 

1. Click Start ->Administrative Tools ->Server Manager . 

2. Double click Roles->Active Directory Domain Services ->Active Directory Users and 
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Computers . 

3. Right click the domain name created above (e.g., ldap.yealink.com), and then select 

New ->Organizational Unit . 

 

 

4. Enter the desired name of the organizational unit . 

 

5. Click OK to accept the change. 
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6. Right click the organizational unit created above, and then select New ->Contact . 

 

7. Enter the desired values in the corresponding fields. 

 

8. Click OK to accept the change. 

9. Double click the contact created above. 
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10. Configure more propert ies of the contact. 

 

11. Click OK to accept the change. 
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Adding Entries to the Active Directory Using the  ldifde Tool  

You can use a LDIF file to perform a batch import of all entries  to the active directory.  

To create the LDIF  file:  

Create a new text document and then modify the filename extension as ldif. For example, create 

a text document named as test.txt, right click the test.txt document and then select to rename it, 

modify the filename extension as ldif. Open the LDIF file with your favorite text editor and input 

the corresponding content. The following shows an example of the content of the LDIF file: 

 

To import the test .ldif file:  

1. Click Start ->Run. 

2. Enter cmd  in the pop -up dialogue box and click OK to enter the command line interface. 

  

##Create a new organizational unit##  

dn: OU=yealink,DC=ldap,DC=yealink,DC=com  

changetype: add  

objectClass: top  

objectClass: organizationalUnit  

ou: yealink  

name: yealink  

 

##create a new contact##  

dn: CN=san zhang,OU=yealink,DC=ldap,DC=yealink,DC=com  

changetype: add  

objectClass: top  

objectClass: person  

objectClass: organizationalPerson  

objectClass: contact  

cn: san zhang 

sn: zhang 

givenName: san  

initials: zs  

name: san zhang  

ipPhone: 2336  

mobile: 15557107369  
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3. Execute the command cd to access the path of the test.ldif file. For example, execute cd 

c:\ Windows  to access the path of the test.ldif file at c:\ Windows . 

 

4. Execute the command ldifde  -i  -f  test .ldif to import the file. 

If the entries are added successfully, you can find the prompt ǰn entries modified 

successfullyǱ ("n" indicates the number of the added entries). 

The screenshot for reference is shown as below: 

 

 

Adding Entries to the Active Directory Using the  Csvde Tool  

You can also use a CSV file to perform a batch import of all entries to the active directory.  Create 

a new document using a spreadsheet application (e.g., Microsoft Excel) and then save the 

document to your local computer using ǰSave asǱ in the format ǰ*.csvǱ. For example, create a 

document named as test.xls, click ǰSave asǱ to save the document as test.csv. Open the CSV file 

with the spreadsheet application and input the corresponding content . The following shows an 

example of the CSV file content: 

 

You can also export the existing entries on the active directory into a *.ldif file first, modify the 

file, and then import the modified file into the active directory. For more information, refer to 

the network resource. 
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To import the test .csv file:  

1. Click Start ->Run. 

2. Enter cmd  in the pop -up dialogue box and click OK to enter the command line interface. 

3. Execute the command cd to access the path of the test.csv file. For example, execute cd 

c:\ Windows  to access the path of the test.csv file at c:\ Windows . 

 

4. Execute the command csvde  -i  -f  test. csv to import the file. 

If the entries are added successfully, you can find the prompt ǰn entries modified 

successfullyǱ ("n" indicates the number of the added entries). 

The screenshot for reference is shown as below: 

 

 

Creating  User Account s 

You can create user accounts to allow access to resources on the active directory. User accounts 

are very important and useful.  

To create a user account : 

1. Click Start ->Administrative Tools ->Server Manager . 

2. Double click Server Manager ->Roles->Active Directory Domain Services ->Active 

The csvde tool cannot edit or delete the existing entries on the active directory. 

You can also export the existing entries on the active directory into a *.csv file first, modify the 

file, and then import the modified file into the active directory. For more information, refer to 

the network resource. 

The first line lists the attributes of the entries. 

The second line lists the values of an organizational unit  in the corresponding attribute columns.  

The other lines list the values of contacts in the corresponding attribute columns.  



Installing and Configuring the LDAP Server 

29 

Directory Users and Computers . 

3. Select the domain name created above (e.g., ldap.yealink.com). 

4. Right click Users, and then select New ->User. 

 

5. Enter desired values in the corresponding fields and click Next . 

 

6. Enter the password for the user, select the appropriate options  and click Next . 

  


